|
|
|
@ -1,6 +1,92 @@
|
|
|
|
|
diff -Nur linux-2.6.16.4/arch/arm/boot/compressed/head-xscale.S linux-2.6.16.4-owrt/arch/arm/boot/compressed/head-xscale.S
|
|
|
|
|
--- linux-2.6.16.4/arch/arm/boot/compressed/head-xscale.S 2006-04-11 19:19:28.000000000 +0200
|
|
|
|
|
+++ linux-2.6.16.4-owrt/arch/arm/boot/compressed/head-xscale.S 2006-04-16 16:51:05.000000000 +0200
|
|
|
|
|
@@ -47,6 +47,11 @@
|
|
|
|
|
orr r7, r7, #(MACH_TYPE_GTWX5715 & 0xff00)
|
|
|
|
|
#endif
|
|
|
|
|
|
|
|
|
|
+#ifdef CONFIG_MACH_GATEWAY7001
|
|
|
|
|
+ mov r7, #(MACH_TYPE_GATEWAY7001 & 0xff)
|
|
|
|
|
+ orr r7, r7, #(MACH_TYPE_GATEWAY7001 & 0xff00)
|
|
|
|
|
+#endif
|
|
|
|
|
+
|
|
|
|
|
#ifdef CONFIG_ARCH_IXP2000
|
|
|
|
|
mov r1, #-1
|
|
|
|
|
mov r0, #0xd6000000
|
|
|
|
|
diff -Nur linux-2.6.16.4/arch/arm/mach-ixp4xx/gateway7001-pci.c linux-2.6.16.4-owrt/arch/arm/mach-ixp4xx/gateway7001-pci.c
|
|
|
|
|
--- linux-2.6.16.4/arch/arm/mach-ixp4xx/gateway7001-pci.c 1970-01-01 01:00:00.000000000 +0100
|
|
|
|
|
+++ linux-2.6.16.4-owrt/arch/arm/mach-ixp4xx/gateway7001-pci.c 2006-04-17 19:21:55.000000000 +0200
|
|
|
|
|
@@ -0,0 +1,67 @@
|
|
|
|
|
+/*
|
|
|
|
|
+ * arch/arch/mach-ixp4xx/gateway7001-pci.c
|
|
|
|
|
+ *
|
|
|
|
|
+ * PCI setup routines for Gateway 7001
|
|
|
|
|
+ *
|
|
|
|
|
+ * Copyright (C) 2006 Imre Kaloz <kaloz@openwrt.org>
|
|
|
|
|
+ *
|
|
|
|
|
+ * based on coyote-pci.c:
|
|
|
|
|
+ * Copyright (C) 2002 Jungo Software Technologies.
|
|
|
|
|
+ * Copyright (C) 2003 MontaVista Softwrae, Inc.
|
|
|
|
|
+ *
|
|
|
|
|
+ * Maintainer: Imre Kaloz <kaloz@openwrt.org>
|
|
|
|
|
+ *
|
|
|
|
|
+ * This program is free software; you can redistribute it and/or modify
|
|
|
|
|
+ * it under the terms of the GNU General Public License version 2 as
|
|
|
|
|
+ * published by the Free Software Foundation.
|
|
|
|
|
+ *
|
|
|
|
|
+ */
|
|
|
|
|
+
|
|
|
|
|
+#include <linux/kernel.h>
|
|
|
|
|
+#include <linux/pci.h>
|
|
|
|
|
+#include <linux/init.h>
|
|
|
|
|
+
|
|
|
|
|
+#include <asm/mach-types.h>
|
|
|
|
|
+#include <asm/hardware.h>
|
|
|
|
|
+#include <asm/irq.h>
|
|
|
|
|
+
|
|
|
|
|
+#include <asm/mach/pci.h>
|
|
|
|
|
+
|
|
|
|
|
+extern void ixp4xx_pci_preinit(void);
|
|
|
|
|
+extern int ixp4xx_setup(int nr, struct pci_sys_data *sys);
|
|
|
|
|
+extern struct pci_bus *ixp4xx_scan_bus(int nr, struct pci_sys_data *sys);
|
|
|
|
|
+
|
|
|
|
|
+void __init gateway7001_pci_preinit(void)
|
|
|
|
|
+{
|
|
|
|
|
+ set_irq_type(IRQ_IXP4XX_GPIO10, IRQT_LOW);
|
|
|
|
|
+ set_irq_type(IRQ_IXP4XX_GPIO11, IRQT_LOW);
|
|
|
|
|
+
|
|
|
|
|
+ ixp4xx_pci_preinit();
|
|
|
|
|
+}
|
|
|
|
|
+
|
|
|
|
|
+static int __init gateway7001_map_irq(struct pci_dev *dev, u8 slot, u8 pin)
|
|
|
|
|
+{
|
|
|
|
|
+ if (slot == 0)
|
|
|
|
|
+ return IRQ_IXP4XX_GPIO10;
|
|
|
|
|
+ else if (slot == 1)
|
|
|
|
|
+ return IRQ_IXP4XX_GPIO11;
|
|
|
|
|
+ else return -1;
|
|
|
|
|
+}
|
|
|
|
|
+
|
|
|
|
|
+struct hw_pci gateway7001_pci __initdata = {
|
|
|
|
|
+ .nr_controllers = 1,
|
|
|
|
|
+ .preinit = gateway7001_pci_preinit,
|
|
|
|
|
+ .swizzle = pci_std_swizzle,
|
|
|
|
|
+ .setup = ixp4xx_setup,
|
|
|
|
|
+ .scan = ixp4xx_scan_bus,
|
|
|
|
|
+ .map_irq = gateway7001_map_irq,
|
|
|
|
|
+};
|
|
|
|
|
+
|
|
|
|
|
+int __init gateway7001_pci_init(void)
|
|
|
|
|
+{
|
|
|
|
|
+ if (machine_is_gateway7001())
|
|
|
|
|
+ pci_common_init(&gateway7001_pci);
|
|
|
|
|
+ return 0;
|
|
|
|
|
+}
|
|
|
|
|
+
|
|
|
|
|
+subsys_initcall(gateway7001_pci_init);
|
|
|
|
|
diff -Nur linux-2.6.16.4/arch/arm/mach-ixp4xx/Kconfig linux-2.6.16.4-owrt/arch/arm/mach-ixp4xx/Kconfig
|
|
|
|
|
--- linux-2.6.16.4/arch/arm/mach-ixp4xx/Kconfig 2006-04-11 19:19:28.000000000 +0200
|
|
|
|
|
+++ linux-2.6.16.4-owrt/arch/arm/mach-ixp4xx/Kconfig 2006-04-12 16:47:34.000000000 +0200
|
|
|
|
|
+++ linux-2.6.16.4-owrt/arch/arm/mach-ixp4xx/Kconfig 2006-04-16 15:58:37.000000000 +0200
|
|
|
|
|
@@ -30,6 +30,13 @@
|
|
|
|
|
Engineering Coyote Gateway Reference Platform. For more
|
|
|
|
|
information on this platform, see <file:Documentation/arm/IXP4xx>.
|
|
|
|
@ -17,221 +103,44 @@ diff -Nur linux-2.6.16.4/arch/arm/mach-ixp4xx/Kconfig linux-2.6.16.4-owrt/arch/a
|
|
|
|
|
help
|
|
|
|
|
diff -Nur linux-2.6.16.4/arch/arm/mach-ixp4xx/Makefile linux-2.6.16.4-owrt/arch/arm/mach-ixp4xx/Makefile
|
|
|
|
|
--- linux-2.6.16.4/arch/arm/mach-ixp4xx/Makefile 2006-04-11 19:19:28.000000000 +0200
|
|
|
|
|
+++ linux-2.6.16.4-owrt/arch/arm/mach-ixp4xx/Makefile 2006-04-12 22:34:09.000000000 +0200
|
|
|
|
|
+++ linux-2.6.16.4-owrt/arch/arm/mach-ixp4xx/Makefile 2006-04-16 16:03:42.000000000 +0200
|
|
|
|
|
@@ -10,4 +10,5 @@
|
|
|
|
|
obj-$(CONFIG_MACH_GTWX5715) += gtwx5715-pci.o gtwx5715-setup.o
|
|
|
|
|
obj-$(CONFIG_MACH_NSLU2) += nslu2-pci.o nslu2-setup.o nslu2-power.o
|
|
|
|
|
obj-$(CONFIG_MACH_NAS100D) += nas100d-pci.o nas100d-setup.o nas100d-power.o
|
|
|
|
|
+obj-$(CONFIG_MACH_GATEWAY7001) += gateway7001-pci.o gateway7001-setup.o
|
|
|
|
|
+obj-$(CONFIG_MACH_GATEWAY7001) += gateway7001-pci.o coyote-setup.o
|
|
|
|
|
|
|
|
|
|
diff -Nur linux-2.6.16.4/include/asm-arm/arch-ixp4xx/uncompress.h linux-2.6.16.4-owrt/include/asm-arm/arch-ixp4xx/uncompress.h
|
|
|
|
|
--- linux-2.6.16.4/include/asm-arm/arch-ixp4xx/uncompress.h 2006-04-11 19:19:28.000000000 +0200
|
|
|
|
|
+++ linux-2.6.16.4-owrt/include/asm-arm/arch-ixp4xx/uncompress.h 2006-04-16 16:25:34.000000000 +0200
|
|
|
|
|
@@ -48,7 +48,7 @@
|
|
|
|
|
/*
|
|
|
|
|
* Coyote and gtwx5715 only have UART2 connected
|
|
|
|
|
*/
|
|
|
|
|
- if (machine_is_adi_coyote() || machine_is_gtwx5715())
|
|
|
|
|
+ if (machine_is_adi_coyote() || machine_is_gtwx5715() || machine_is_gateway7001())
|
|
|
|
|
uart_base = (volatile u32*) IXP4XX_UART2_BASE_PHYS;
|
|
|
|
|
else
|
|
|
|
|
uart_base = (volatile u32*) IXP4XX_UART1_BASE_PHYS;
|
|
|
|
|
diff -Nur linux-2.6.16.4/arch/arm/mach-ixp4xx/coyote-setup.c linux-2.6.16.4-owrt/arch/arm/mach-ixp4xx/coyote-setup.c
|
|
|
|
|
--- linux-2.6.16.4/arch/arm/mach-ixp4xx/coyote-setup.c 2006-04-11 19:19:28.000000000 +0200
|
|
|
|
|
+++ linux-2.6.16.4-owrt/arch/arm/mach-ixp4xx/coyote-setup.c 2006-04-16 16:03:23.000000000 +0200
|
|
|
|
|
@@ -1,9 +1,10 @@
|
|
|
|
|
/*
|
|
|
|
|
* arch/arm/mach-ixp4xx/coyote-setup.c
|
|
|
|
|
*
|
|
|
|
|
- * Board setup for ADI Engineering and IXDGP425 boards
|
|
|
|
|
+ * Board setup for ADI Engineering, IXDGP425 and Gateway 7001 boards
|
|
|
|
|
*
|
|
|
|
|
* Copyright (C) 2003-2005 MontaVista Software, Inc.
|
|
|
|
|
+ * Copyright (C) 2006 Imre Kaloz <Kaloz@openwrt.org>
|
|
|
|
|
*
|
|
|
|
|
* Author: Deepak Saxena <dsaxena@plexity.net>
|
|
|
|
|
*/
|
|
|
|
|
@@ -111,6 +112,19 @@
|
|
|
|
|
MACHINE_END
|
|
|
|
|
#endif
|
|
|
|
|
|
|
|
|
|
diff -Nur linux-2.6.16.4/arch/arm/mach-ixp4xx/gateway7001-pci.c linux-2.6.16.4-owrt/arch/arm/mach-ixp4xx/gateway7001-pci.c
|
|
|
|
|
--- linux-2.6.16.4/arch/arm/mach-ixp4xx/gateway7001-pci.c 1970-01-01 01:00:00.000000000 +0100
|
|
|
|
|
+++ linux-2.6.16.4-owrt/arch/arm/mach-ixp4xx/gateway7001-pci.c 2006-04-12 22:35:29.000000000 +0200
|
|
|
|
|
@@ -0,0 +1,77 @@
|
|
|
|
|
+/*
|
|
|
|
|
+ * arch/arm/mach-ixp4xx/gateway7001-pci.c
|
|
|
|
|
+ *
|
|
|
|
|
+ * Gateway 7001 board-level PCI initialization
|
|
|
|
|
+ *
|
|
|
|
|
+ * Copyright (c) 2006 Imre Kaloz <kaloz@openwrt.org>
|
|
|
|
|
+ *
|
|
|
|
|
+ * based on ixdp425-pci.c:
|
|
|
|
|
+ * Copyright (C) 2002 Intel Corporation.
|
|
|
|
|
+ * Copyright (C) 2003-2004 MontaVista Software, Inc.
|
|
|
|
|
+ *
|
|
|
|
|
+ * Maintainer: Imre Kaloz <kaloz@openwrt.org>
|
|
|
|
|
+ *
|
|
|
|
|
+ * This program is free software; you can redistribute it and/or modify
|
|
|
|
|
+ * it under the terms of the GNU General Public License version 2 as
|
|
|
|
|
+ * published by the Free Software Foundation.
|
|
|
|
|
+ *
|
|
|
|
|
+ */
|
|
|
|
|
+
|
|
|
|
|
+#include <linux/kernel.h>
|
|
|
|
|
+#include <linux/config.h>
|
|
|
|
|
+#include <linux/pci.h>
|
|
|
|
|
+#include <linux/init.h>
|
|
|
|
|
+#include <linux/delay.h>
|
|
|
|
|
+
|
|
|
|
|
+#include <asm/mach/pci.h>
|
|
|
|
|
+#include <asm/irq.h>
|
|
|
|
|
+#include <asm/hardware.h>
|
|
|
|
|
+#include <asm/mach-types.h>
|
|
|
|
|
+
|
|
|
|
|
+void __init gateway7001_pci_preinit(void)
|
|
|
|
|
+{
|
|
|
|
|
+ set_irq_type(IRQ_GATEWAY7001_PCI_INTA, IRQT_LOW);
|
|
|
|
|
+ set_irq_type(IRQ_GATEWAY7001_PCI_INTB, IRQT_LOW);
|
|
|
|
|
+ set_irq_type(IRQ_GATEWAY7001_PCI_INTC, IRQT_LOW);
|
|
|
|
|
+ set_irq_type(IRQ_GATEWAY7001_PCI_INTD, IRQT_LOW);
|
|
|
|
|
+
|
|
|
|
|
+ ixp4xx_pci_preinit();
|
|
|
|
|
+}
|
|
|
|
|
+
|
|
|
|
|
+static int __init gateway7001_map_irq(struct pci_dev *dev, u8 slot, u8 pin)
|
|
|
|
|
+{
|
|
|
|
|
+ static int pci_irq_table[GATEWAY7001_PCI_IRQ_LINES] = {
|
|
|
|
|
+ IRQ_GATEWAY7001_PCI_INTA,
|
|
|
|
|
+ IRQ_GATEWAY7001_PCI_INTB,
|
|
|
|
|
+ IRQ_GATEWAY7001_PCI_INTC,
|
|
|
|
|
+ IRQ_GATEWAY7001_PCI_INTD
|
|
|
|
|
+ };
|
|
|
|
|
+
|
|
|
|
|
+ int irq = -1;
|
|
|
|
|
+
|
|
|
|
|
+ if (slot >= 1 && slot <= GATEWAY7001_PCI_MAX_DEV &&
|
|
|
|
|
+ pin >= 1 && pin <= GATEWAY7001_PCI_IRQ_LINES) {
|
|
|
|
|
+ irq = pci_irq_table[(slot + pin - 2) % 4];
|
|
|
|
|
+ }
|
|
|
|
|
+
|
|
|
|
|
+ return irq;
|
|
|
|
|
+}
|
|
|
|
|
+
|
|
|
|
|
+struct hw_pci gateway7001_pci __initdata = {
|
|
|
|
|
+ .nr_controllers = 1,
|
|
|
|
|
+ .preinit = gateway7001_pci_preinit,
|
|
|
|
|
+ .swizzle = pci_std_swizzle,
|
|
|
|
|
+ .setup = ixp4xx_setup,
|
|
|
|
|
+ .scan = ixp4xx_scan_bus,
|
|
|
|
|
+ .map_irq = gateway7001_map_irq,
|
|
|
|
|
+};
|
|
|
|
|
+
|
|
|
|
|
+int __init gateway7001_pci_init(void)
|
|
|
|
|
+{
|
|
|
|
|
+ if (machine_is_gateway7001())
|
|
|
|
|
+ pci_common_init(&gateway7001_pci);
|
|
|
|
|
+ return 0;
|
|
|
|
|
+}
|
|
|
|
|
+
|
|
|
|
|
+subsys_initcall(gateway7001_pci_init);
|
|
|
|
|
+
|
|
|
|
|
diff -Nur linux-2.6.16.4/arch/arm/mach-ixp4xx/gateway7001-setup.c linux-2.6.16.4-owrt/arch/arm/mach-ixp4xx/gateway7001-setup.c
|
|
|
|
|
--- linux-2.6.16.4/arch/arm/mach-ixp4xx/gateway7001-setup.c 1970-01-01 01:00:00.000000000 +0100
|
|
|
|
|
+++ linux-2.6.16.4-owrt/arch/arm/mach-ixp4xx/gateway7001-setup.c 2006-04-12 22:45:53.000000000 +0200
|
|
|
|
|
@@ -0,0 +1,136 @@
|
|
|
|
|
+/*
|
|
|
|
|
+ * arch/arm/mach-ixp4xx/gateway7001-setup.c
|
|
|
|
|
+ *
|
|
|
|
|
+ * Gateway 7001 board-setup
|
|
|
|
|
+ *
|
|
|
|
|
+ * Copyright (C) 2006 Imre Kaloz <kaloz@openwrt.org>
|
|
|
|
|
+ *
|
|
|
|
|
+ * based-on ixdp425-setup.c:
|
|
|
|
|
+ * Copyright (C) 2003-2005 MontaVista Software, Inc.
|
|
|
|
|
+ *
|
|
|
|
|
+ * Author: Imre Kaloz <kaloz@openwrt.org>
|
|
|
|
|
+ */
|
|
|
|
|
+
|
|
|
|
|
+#include <linux/kernel.h>
|
|
|
|
|
+#include <linux/init.h>
|
|
|
|
|
+#include <linux/device.h>
|
|
|
|
|
+#include <linux/serial.h>
|
|
|
|
|
+#include <linux/tty.h>
|
|
|
|
|
+#include <linux/serial_8250.h>
|
|
|
|
|
+#include <linux/slab.h>
|
|
|
|
|
+
|
|
|
|
|
+#include <asm/types.h>
|
|
|
|
|
+#include <asm/setup.h>
|
|
|
|
|
+#include <asm/memory.h>
|
|
|
|
|
+#include <asm/hardware.h>
|
|
|
|
|
+#include <asm/mach-types.h>
|
|
|
|
|
+#include <asm/irq.h>
|
|
|
|
|
+#include <asm/mach/arch.h>
|
|
|
|
|
+#include <asm/mach/flash.h>
|
|
|
|
|
+
|
|
|
|
|
+static struct flash_platform_data gateway7001_flash_data = {
|
|
|
|
|
+ .map_name = "cfi_probe",
|
|
|
|
|
+ .width = 2,
|
|
|
|
|
+};
|
|
|
|
|
+
|
|
|
|
|
+static struct resource gateway7001_flash_resource = {
|
|
|
|
|
+ .flags = IORESOURCE_MEM,
|
|
|
|
|
+};
|
|
|
|
|
+
|
|
|
|
|
+static struct platform_device gateway7001_flash = {
|
|
|
|
|
+ .name = "IXP4XX-Flash",
|
|
|
|
|
+ .id = 0,
|
|
|
|
|
+ .dev = {
|
|
|
|
|
+ .platform_data = &gateway7001_flash_data,
|
|
|
|
|
+ },
|
|
|
|
|
+ .num_resources = 1,
|
|
|
|
|
+ .resource = &gateway7001_flash_resource,
|
|
|
|
|
+};
|
|
|
|
|
+
|
|
|
|
|
+static struct ixp4xx_i2c_pins gateway7001_i2c_gpio_pins = {
|
|
|
|
|
+ .sda_pin = GATEWAY7001_SDA_PIN,
|
|
|
|
|
+ .scl_pin = GATEWAY7001_SCL_PIN,
|
|
|
|
|
+};
|
|
|
|
|
+
|
|
|
|
|
+static struct platform_device gateway7001_i2c_controller = {
|
|
|
|
|
+ .name = "IXP4XX-I2C",
|
|
|
|
|
+ .id = 0,
|
|
|
|
|
+ .dev = {
|
|
|
|
|
+ .platform_data = &gateway7001_i2c_gpio_pins,
|
|
|
|
|
+ },
|
|
|
|
|
+ .num_resources = 0
|
|
|
|
|
+};
|
|
|
|
|
+
|
|
|
|
|
+static struct resource gateway7001_uart_resources[] = {
|
|
|
|
|
+ {
|
|
|
|
|
+ .start = IXP4XX_UART1_BASE_PHYS,
|
|
|
|
|
+ .end = IXP4XX_UART1_BASE_PHYS + 0x0fff,
|
|
|
|
|
+ .flags = IORESOURCE_MEM
|
|
|
|
|
+ },
|
|
|
|
|
+ {
|
|
|
|
|
+ .start = IXP4XX_UART2_BASE_PHYS,
|
|
|
|
|
+ .end = IXP4XX_UART2_BASE_PHYS + 0x0fff,
|
|
|
|
|
+ .flags = IORESOURCE_MEM
|
|
|
|
|
+ }
|
|
|
|
|
+};
|
|
|
|
|
+
|
|
|
|
|
+static struct plat_serial8250_port gateway7001_uart_data[] = {
|
|
|
|
|
+ {
|
|
|
|
|
+ .mapbase = IXP4XX_UART1_BASE_PHYS,
|
|
|
|
|
+ .membase = (char *)IXP4XX_UART1_BASE_VIRT + REG_OFFSET,
|
|
|
|
|
+ .irq = IRQ_IXP4XX_UART1,
|
|
|
|
|
+ .flags = UPF_BOOT_AUTOCONF | UPF_SKIP_TEST,
|
|
|
|
|
+ .iotype = UPIO_MEM,
|
|
|
|
|
+ .regshift = 2,
|
|
|
|
|
+ .uartclk = IXP4XX_UART_XTAL,
|
|
|
|
|
+ },
|
|
|
|
|
+ {
|
|
|
|
|
+ .mapbase = IXP4XX_UART2_BASE_PHYS,
|
|
|
|
|
+ .membase = (char *)IXP4XX_UART2_BASE_VIRT + REG_OFFSET,
|
|
|
|
|
+ .irq = IRQ_IXP4XX_UART2,
|
|
|
|
|
+ .flags = UPF_BOOT_AUTOCONF | UPF_SKIP_TEST,
|
|
|
|
|
+ .iotype = UPIO_MEM,
|
|
|
|
|
+ .regshift = 2,
|
|
|
|
|
+ .uartclk = IXP4XX_UART_XTAL,
|
|
|
|
|
+ },
|
|
|
|
|
+ { },
|
|
|
|
|
+};
|
|
|
|
|
+
|
|
|
|
|
+static struct platform_device gateway7001_uart = {
|
|
|
|
|
+ .name = "serial8250",
|
|
|
|
|
+ .id = PLAT8250_DEV_PLATFORM,
|
|
|
|
|
+ .dev.platform_data = gateway7001_uart_data,
|
|
|
|
|
+ .num_resources = 2,
|
|
|
|
|
+ .resource = gateway7001_uart_resources
|
|
|
|
|
+};
|
|
|
|
|
+
|
|
|
|
|
+static struct platform_device *gateway7001_devices[] __initdata = {
|
|
|
|
|
+ &gateway7001_i2c_controller,
|
|
|
|
|
+ &gateway7001_flash,
|
|
|
|
|
+ &gateway7001_uart
|
|
|
|
|
+};
|
|
|
|
|
+
|
|
|
|
|
+static void __init gateway7001_init(void)
|
|
|
|
|
+{
|
|
|
|
|
+ ixp4xx_sys_init();
|
|
|
|
|
+
|
|
|
|
|
+ gateway7001_flash_resource.start = IXP4XX_EXP_BUS_BASE(0);
|
|
|
|
|
+ gateway7001_flash_resource.end =
|
|
|
|
|
+ IXP4XX_EXP_BUS_BASE(0) + ixp4xx_exp_bus_size - 1;
|
|
|
|
|
+
|
|
|
|
|
+ platform_add_devices(gateway7001_devices, ARRAY_SIZE(gateway7001_devices));
|
|
|
|
|
+}
|
|
|
|
|
+
|
|
|
|
|
+#ifdef CONFIG_MACH_GATEWAY7001
|
|
|
|
|
+MACHINE_START(GATEWAY7001, "Gateway 7001")
|
|
|
|
|
+ /* Maintainer: Imre Kaloz <kaloz@openwrt.org> */
|
|
|
|
@ -241,73 +150,10 @@ diff -Nur linux-2.6.16.4/arch/arm/mach-ixp4xx/gateway7001-setup.c linux-2.6.16.4
|
|
|
|
|
+ .init_irq = ixp4xx_init_irq,
|
|
|
|
|
+ .timer = &ixp4xx_timer,
|
|
|
|
|
+ .boot_params = 0x0100,
|
|
|
|
|
+ .init_machine = gateway7001_init,
|
|
|
|
|
+ .init_machine = coyote_init,
|
|
|
|
|
+MACHINE_END
|
|
|
|
|
+#endif
|
|
|
|
|
+
|
|
|
|
|
diff -Nur linux-2.6.16.4/include/asm-arm/arch-ixp4xx/gateway7001.h linux-2.6.16.4-owrt/include/asm-arm/arch-ixp4xx/gateway7001.h
|
|
|
|
|
--- linux-2.6.16.4/include/asm-arm/arch-ixp4xx/gateway7001.h 1970-01-01 01:00:00.000000000 +0100
|
|
|
|
|
+++ linux-2.6.16.4-owrt/include/asm-arm/arch-ixp4xx/gateway7001.h 2006-04-12 22:34:43.000000000 +0200
|
|
|
|
|
@@ -0,0 +1,36 @@
|
|
|
|
|
+/*
|
|
|
|
|
+ * include/asm-arm/arch-ixp4xx/gateway7001.h
|
|
|
|
|
+ *
|
|
|
|
|
+ * Gateway 7001 platform specific definitions
|
|
|
|
|
+ *
|
|
|
|
|
+ * Author: Imre Kaloz <kaloz@openwrt.org>
|
|
|
|
|
+ *
|
|
|
|
|
+ * Copyright 2006 (c) Imre Kaloz <kaloz@openwrt.org>
|
|
|
|
|
+ *
|
|
|
|
|
+ * based on ixdp425.h:
|
|
|
|
|
+ * Copyright 2004 (c) MontaVista, Software, Inc.
|
|
|
|
|
+ *
|
|
|
|
|
+ * This file is licensed under the terms of the GNU General Public
|
|
|
|
|
+ * License version 2. This program is licensed "as is" without any
|
|
|
|
|
+ * warranty of any kind, whether express or implied.
|
|
|
|
|
+ */
|
|
|
|
|
+
|
|
|
|
|
+#ifndef __ASM_ARCH_HARDWARE_H__
|
|
|
|
|
+#error "Do not include this directly, instead #include <asm/hardware.h>"
|
|
|
|
|
+#endif
|
|
|
|
|
+
|
|
|
|
|
+#define GATEWAY7001_SDA_PIN 7
|
|
|
|
|
+#define GATEWAY7001_SCL_PIN 6
|
|
|
|
|
+
|
|
|
|
|
+/*
|
|
|
|
|
+ * GATEWAY7001 PCI IRQs
|
|
|
|
|
+ */
|
|
|
|
|
+#define GATEWAY7001_PCI_MAX_DEV 4
|
|
|
|
|
+#define GATEWAY7001_PCI_IRQ_LINES 4
|
|
|
|
|
+
|
|
|
|
|
+
|
|
|
|
|
+/* PCI controller GPIO to IRQ pin mappings */
|
|
|
|
|
+#define GATEWAY7001_PCI_INTA_PIN 11
|
|
|
|
|
+#define GATEWAY7001_PCI_INTB_PIN 10
|
|
|
|
|
+#define GATEWAY7001_PCI_INTC_PIN 9
|
|
|
|
|
+#define GATEWAY7001_PCI_INTD_PIN 8
|
|
|
|
|
diff -Nur linux-2.6.16.4/include/asm-arm/arch-ixp4xx/hardware.h linux-2.6.16.4-owrt/include/asm-arm/arch-ixp4xx/hardware.h
|
|
|
|
|
--- linux-2.6.16.4/include/asm-arm/arch-ixp4xx/hardware.h 2006-04-11 19:19:28.000000000 +0200
|
|
|
|
|
+++ linux-2.6.16.4-owrt/include/asm-arm/arch-ixp4xx/hardware.h 2006-04-12 22:34:52.000000000 +0200
|
|
|
|
|
@@ -46,5 +46,6 @@
|
|
|
|
|
#include "prpmc1100.h"
|
|
|
|
|
#include "nslu2.h"
|
|
|
|
|
#include "nas100d.h"
|
|
|
|
|
+#include "gateway7001.h"
|
|
|
|
|
|
|
|
|
|
#endif /* _ASM_ARCH_HARDWARE_H */
|
|
|
|
|
diff -Nur linux-2.6.16.4/include/asm-arm/arch-ixp4xx/irqs.h linux-2.6.16.4-owrt/include/asm-arm/arch-ixp4xx/irqs.h
|
|
|
|
|
--- linux-2.6.16.4/include/asm-arm/arch-ixp4xx/irqs.h 2006-04-11 19:19:28.000000000 +0200
|
|
|
|
|
+++ linux-2.6.16.4-owrt/include/asm-arm/arch-ixp4xx/irqs.h 2006-04-12 22:35:05.000000000 +0200
|
|
|
|
|
@@ -109,4 +109,12 @@
|
|
|
|
|
#define IRQ_NAS100D_PCI_INTD IRQ_IXP4XX_GPIO8
|
|
|
|
|
#define IRQ_NAS100D_PCI_INTE IRQ_IXP4XX_GPIO7
|
|
|
|
|
|
|
|
|
|
+/*
|
|
|
|
|
+ * GATEWAY7001 board IRQs
|
|
|
|
|
+ */
|
|
|
|
|
+#define IRQ_GATEWAY7001_PCI_INTA IRQ_IXP4XX_GPIO11
|
|
|
|
|
+#define IRQ_GATEWAY7001_PCI_INTB IRQ_IXP4XX_GPIO10
|
|
|
|
|
+#define IRQ_GATEWAY7001_PCI_INTC IRQ_IXP4XX_GPIO9
|
|
|
|
|
+#define IRQ_GATEWAY7001_PCI_INTD IRQ_IXP4XX_GPIO8
|
|
|
|
|
+
|
|
|
|
|
#endif
|
|
|
|
|
/*
|
|
|
|
|
* IXDPG425 is identical to Coyote except for which serial port
|
|
|
|
|
* is connected.
|
|
|
|
|