bump brcm63xx to 2.6.22.1, too
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8018 3c298f89-4303-0410-b956-a3cf2f4a3e73master
parent
9246de4ea2
commit
fda40cfa40
|
@ -11,7 +11,7 @@ BOARD:=brcm63xx
|
||||||
BOARDNAME:=Broadcom BCM963xx
|
BOARDNAME:=Broadcom BCM963xx
|
||||||
FEATURES:=squashfs jffs2 broken usb atm
|
FEATURES:=squashfs jffs2 broken usb atm
|
||||||
|
|
||||||
LINUX_VERSION:=2.6.21.5
|
LINUX_VERSION:=2.6.22.1
|
||||||
|
|
||||||
define Target/Description
|
define Target/Description
|
||||||
Build firmware images for Broadcom based xDSL/routers
|
Build firmware images for Broadcom based xDSL/routers
|
||||||
|
|
|
@ -2,8 +2,8 @@ diff -urN linux-2.6.19/arch/mips/Kconfig linux-2.6.19.new/arch/mips/Kconfig
|
||||||
--- linux-2.6.19/arch/mips/Kconfig 2006-11-29 22:57:37.000000000 +0100
|
--- linux-2.6.19/arch/mips/Kconfig 2006-11-29 22:57:37.000000000 +0100
|
||||||
+++ linux-2.6.19.new/arch/mips/Kconfig 2006-12-16 18:46:31.000000000 +0100
|
+++ linux-2.6.19.new/arch/mips/Kconfig 2006-12-16 18:46:31.000000000 +0100
|
||||||
@@ -4,6 +4,10 @@
|
@@ -4,6 +4,10 @@
|
||||||
# Horrible source of confusion. Die, die, die ...
|
# Horrible source of confusion. Die, die, die ...
|
||||||
select EMBEDDED
|
select EMBEDDED
|
||||||
|
|
||||||
+config CFE
|
+config CFE
|
||||||
+ bool
|
+ bool
|
||||||
|
@ -12,7 +12,7 @@ diff -urN linux-2.6.19/arch/mips/Kconfig linux-2.6.19.new/arch/mips/Kconfig
|
||||||
mainmenu "Linux/MIPS Kernel Configuration"
|
mainmenu "Linux/MIPS Kernel Configuration"
|
||||||
|
|
||||||
menu "Machine selection"
|
menu "Machine selection"
|
||||||
@@ -12,6 +12,18 @@
|
@@ -15,6 +15,18 @@
|
||||||
prompt "System type"
|
prompt "System type"
|
||||||
default SGI_IP22
|
default SGI_IP22
|
||||||
|
|
||||||
|
@ -28,9 +28,9 @@ diff -urN linux-2.6.19/arch/mips/Kconfig linux-2.6.19.new/arch/mips/Kconfig
|
||||||
+ help
|
+ help
|
||||||
+ This is a fmaily of boards based on the Broadcom MIPS32
|
+ This is a fmaily of boards based on the Broadcom MIPS32
|
||||||
+
|
+
|
||||||
config MIPS_MTX1
|
config MACH_ALCHEMY
|
||||||
bool "4G Systems MTX-1 board"
|
bool "Alchemy processor based machines"
|
||||||
select DMA_NONCOHERENT
|
|
||||||
diff -urN linux-2.6.19/arch/mips/Makefile linux-2.6.19.new/arch/mips/Makefile
|
diff -urN linux-2.6.19/arch/mips/Makefile linux-2.6.19.new/arch/mips/Makefile
|
||||||
--- linux-2.6.19/arch/mips/Makefile 2006-12-16 17:36:29.000000000 +0100
|
--- linux-2.6.19/arch/mips/Makefile 2006-12-16 17:36:29.000000000 +0100
|
||||||
+++ linux-2.6.19.new/arch/mips/Makefile 2006-12-16 18:46:31.000000000 +0100
|
+++ linux-2.6.19.new/arch/mips/Makefile 2006-12-16 18:46:31.000000000 +0100
|
||||||
|
@ -57,7 +57,7 @@ diff -urN linux-2.6.19/arch/mips/Makefile linux-2.6.19.new/arch/mips/Makefile
|
||||||
diff -urN linux-2.6.19/arch/mips/kernel/cpu-probe.c linux-2.6.19.new/arch/mips/kernel/cpu-probe.c
|
diff -urN linux-2.6.19/arch/mips/kernel/cpu-probe.c linux-2.6.19.new/arch/mips/kernel/cpu-probe.c
|
||||||
--- linux-2.6.19/arch/mips/kernel/cpu-probe.c 2006-11-29 22:57:37.000000000 +0100
|
--- linux-2.6.19/arch/mips/kernel/cpu-probe.c 2006-11-29 22:57:37.000000000 +0100
|
||||||
+++ linux-2.6.19.new/arch/mips/kernel/cpu-probe.c 2006-12-16 18:46:31.000000000 +0100
|
+++ linux-2.6.19.new/arch/mips/kernel/cpu-probe.c 2006-12-16 18:46:31.000000000 +0100
|
||||||
@@ -602,6 +602,25 @@
|
@@ -590,6 +590,25 @@
|
||||||
return;
|
return;
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -83,7 +83,7 @@ diff -urN linux-2.6.19/arch/mips/kernel/cpu-probe.c linux-2.6.19.new/arch/mips/k
|
||||||
static inline void cpu_probe_mips(struct cpuinfo_mips *c)
|
static inline void cpu_probe_mips(struct cpuinfo_mips *c)
|
||||||
{
|
{
|
||||||
decode_configs(c);
|
decode_configs(c);
|
||||||
@@ -736,6 +755,9 @@
|
@@ -724,6 +743,9 @@
|
||||||
case PRID_COMP_LEGACY:
|
case PRID_COMP_LEGACY:
|
||||||
cpu_probe_legacy(c);
|
cpu_probe_legacy(c);
|
||||||
break;
|
break;
|
||||||
|
@ -126,7 +126,7 @@ diff -urN linux-2.6.19/arch/mips/mm/c-r4k.c linux-2.6.19.new/arch/mips/mm/c-r4k.
|
||||||
diff -urN linux-2.6.19/arch/mips/mm/tlbex.c linux-2.6.19.new/arch/mips/mm/tlbex.c
|
diff -urN linux-2.6.19/arch/mips/mm/tlbex.c linux-2.6.19.new/arch/mips/mm/tlbex.c
|
||||||
--- linux-2.6.19/arch/mips/mm/tlbex.c 2006-11-29 22:57:37.000000000 +0100
|
--- linux-2.6.19/arch/mips/mm/tlbex.c 2006-11-29 22:57:37.000000000 +0100
|
||||||
+++ linux-2.6.19.new/arch/mips/mm/tlbex.c 2006-12-16 18:46:31.000000000 +0100
|
+++ linux-2.6.19.new/arch/mips/mm/tlbex.c 2006-12-16 18:46:31.000000000 +0100
|
||||||
@@ -880,6 +880,9 @@
|
@@ -892,6 +892,9 @@
|
||||||
case CPU_4KSC:
|
case CPU_4KSC:
|
||||||
case CPU_20KC:
|
case CPU_20KC:
|
||||||
case CPU_25KF:
|
case CPU_25KF:
|
||||||
|
@ -139,7 +139,7 @@ diff -urN linux-2.6.19/arch/mips/mm/tlbex.c linux-2.6.19.new/arch/mips/mm/tlbex.
|
||||||
diff -urN linux-2.6.19/arch/mips/pci/Makefile linux-2.6.19.new/arch/mips/pci/Makefile
|
diff -urN linux-2.6.19/arch/mips/pci/Makefile linux-2.6.19.new/arch/mips/pci/Makefile
|
||||||
--- linux-2.6.19/arch/mips/pci/Makefile 2006-11-29 22:57:37.000000000 +0100
|
--- linux-2.6.19/arch/mips/pci/Makefile 2006-11-29 22:57:37.000000000 +0100
|
||||||
+++ linux-2.6.19.new/arch/mips/pci/Makefile 2006-12-16 18:48:18.000000000 +0100
|
+++ linux-2.6.19.new/arch/mips/pci/Makefile 2006-12-16 18:48:18.000000000 +0100
|
||||||
@@ -17,6 +17,7 @@
|
@@ -16,6 +16,7 @@
|
||||||
obj-$(CONFIG_PCI_VR41XX) += ops-vr41xx.o pci-vr41xx.o
|
obj-$(CONFIG_PCI_VR41XX) += ops-vr41xx.o pci-vr41xx.o
|
||||||
obj-$(CONFIG_NEC_CMBVR4133) += fixup-vr4133.o
|
obj-$(CONFIG_NEC_CMBVR4133) += fixup-vr4133.o
|
||||||
obj-$(CONFIG_MARKEINS) += ops-emma2rh.o pci-emma2rh.o fixup-emma2rh.o
|
obj-$(CONFIG_MARKEINS) += ops-emma2rh.o pci-emma2rh.o fixup-emma2rh.o
|
||||||
|
@ -150,7 +150,7 @@ diff -urN linux-2.6.19/arch/mips/pci/Makefile linux-2.6.19.new/arch/mips/pci/Mak
|
||||||
diff -urN linux-2.6.19/include/asm-mips/bootinfo.h linux-2.6.19.new/include/asm-mips/bootinfo.h
|
diff -urN linux-2.6.19/include/asm-mips/bootinfo.h linux-2.6.19.new/include/asm-mips/bootinfo.h
|
||||||
--- linux-2.6.19/include/asm-mips/bootinfo.h 2006-11-29 22:57:37.000000000 +0100
|
--- linux-2.6.19/include/asm-mips/bootinfo.h 2006-11-29 22:57:37.000000000 +0100
|
||||||
+++ linux-2.6.19.new/include/asm-mips/bootinfo.h 2006-12-16 18:46:31.000000000 +0100
|
+++ linux-2.6.19.new/include/asm-mips/bootinfo.h 2006-12-16 18:46:31.000000000 +0100
|
||||||
@@ -212,6 +212,14 @@
|
@@ -213,6 +213,14 @@
|
||||||
#define MACH_GROUP_NEC_EMMA2RH 25 /* NEC EMMA2RH (was 23) */
|
#define MACH_GROUP_NEC_EMMA2RH 25 /* NEC EMMA2RH (was 23) */
|
||||||
#define MACH_NEC_MARKEINS 0 /* NEC EMMA2RH Mark-eins */
|
#define MACH_NEC_MARKEINS 0 /* NEC EMMA2RH Mark-eins */
|
||||||
|
|
||||||
|
|
|
@ -1,8 +1,8 @@
|
||||||
diff -urN linux-2.6.21.1/drivers/serial/Makefile linux-2.6.21.1.new/drivers/serial/Makefile
|
diff -urN linux-2.6.21.1/drivers/serial/Makefile linux-2.6.21.1.new/drivers/serial/Makefile
|
||||||
--- linux-2.6.21.1/drivers/serial/Makefile 2007-04-27 23:49:26.000000000 +0200
|
--- linux-2.6.21.1/drivers/serial/Makefile 2007-04-27 23:49:26.000000000 +0200
|
||||||
+++ linux-2.6.21.1.new/drivers/serial/Makefile 2007-05-30 20:32:27.000000000 +0200
|
+++ linux-2.6.21.1.new/drivers/serial/Makefile 2007-05-30 20:32:27.000000000 +0200
|
||||||
@@ -60,3 +60,4 @@
|
@@ -62,3 +62,4 @@
|
||||||
obj-$(CONFIG_SERIAL_UARTLITE) += uartlite.o
|
|
||||||
obj-$(CONFIG_SERIAL_NETX) += netx-serial.o
|
obj-$(CONFIG_SERIAL_NETX) += netx-serial.o
|
||||||
obj-$(CONFIG_SERIAL_OF_PLATFORM) += of_serial.o
|
obj-$(CONFIG_SERIAL_OF_PLATFORM) += of_serial.o
|
||||||
|
obj-$(CONFIG_SERIAL_KS8695) += serial_ks8695.o
|
||||||
+obj-$(CONFIG_BCM963XX) += bcm63xx_cons.o
|
+obj-$(CONFIG_BCM963XX) += bcm63xx_cons.o
|
||||||
|
|
|
@ -1,7 +1,7 @@
|
||||||
diff -urN linux-2.6.19/drivers/mtd/maps/Kconfig linux-2.6.19.new/drivers/mtd/maps/Kconfig
|
diff -urN linux-2.6.19/drivers/mtd/maps/Kconfig linux-2.6.19.new/drivers/mtd/maps/Kconfig
|
||||||
--- linux-2.6.19/drivers/mtd/maps/Kconfig 2006-11-29 22:57:37.000000000 +0100
|
--- linux-2.6.19/drivers/mtd/maps/Kconfig 2006-11-29 22:57:37.000000000 +0100
|
||||||
+++ linux-2.6.19.new/drivers/mtd/maps/Kconfig 2006-12-18 17:21:07.000000000 +0100
|
+++ linux-2.6.19.new/drivers/mtd/maps/Kconfig 2006-12-18 17:21:07.000000000 +0100
|
||||||
@@ -224,6 +224,13 @@
|
@@ -283,6 +283,13 @@
|
||||||
Flash memory access on 4G Systems MTX-1 Board. If you have one of
|
Flash memory access on 4G Systems MTX-1 Board. If you have one of
|
||||||
these boards and would like to use the flash chips on it, say 'Y'.
|
these boards and would like to use the flash chips on it, say 'Y'.
|
||||||
|
|
||||||
|
@ -18,7 +18,7 @@ diff -urN linux-2.6.19/drivers/mtd/maps/Kconfig linux-2.6.19.new/drivers/mtd/map
|
||||||
diff -urN linux-2.6.19/drivers/mtd/maps/Makefile linux-2.6.19.new/drivers/mtd/maps/Makefile
|
diff -urN linux-2.6.19/drivers/mtd/maps/Makefile linux-2.6.19.new/drivers/mtd/maps/Makefile
|
||||||
--- linux-2.6.19/drivers/mtd/maps/Makefile 2006-11-29 22:57:37.000000000 +0100
|
--- linux-2.6.19/drivers/mtd/maps/Makefile 2006-11-29 22:57:37.000000000 +0100
|
||||||
+++ linux-2.6.19.new/drivers/mtd/maps/Makefile 2006-12-18 17:21:07.000000000 +0100
|
+++ linux-2.6.19.new/drivers/mtd/maps/Makefile 2006-12-18 17:21:07.000000000 +0100
|
||||||
@@ -70,3 +70,4 @@
|
@@ -72,3 +72,4 @@
|
||||||
obj-$(CONFIG_MTD_OMAP_NOR) += omap_nor.o
|
obj-$(CONFIG_MTD_OMAP_NOR) += omap_nor.o
|
||||||
obj-$(CONFIG_MTD_MTX1) += mtx-1_flash.o
|
obj-$(CONFIG_MTD_MTX1) += mtx-1_flash.o
|
||||||
obj-$(CONFIG_MTD_TQM834x) += tqm834x.o
|
obj-$(CONFIG_MTD_TQM834x) += tqm834x.o
|
||||||
|
@ -35,7 +35,7 @@ diff -urN linux-2.6.19/drivers/mtd/redboot.c linux-2.6.19.new/drivers/mtd/redboo
|
||||||
struct mtd_partition **pparts,
|
struct mtd_partition **pparts,
|
||||||
unsigned long fis_origin)
|
unsigned long fis_origin)
|
||||||
{
|
{
|
||||||
@@ -132,6 +132,14 @@
|
@@ -146,6 +146,14 @@
|
||||||
goto out;
|
goto out;
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -50,7 +50,7 @@ diff -urN linux-2.6.19/drivers/mtd/redboot.c linux-2.6.19.new/drivers/mtd/redboo
|
||||||
for (i = 0; i < numslots; i++) {
|
for (i = 0; i < numslots; i++) {
|
||||||
struct fis_list *new_fl, **prev;
|
struct fis_list *new_fl, **prev;
|
||||||
|
|
||||||
@@ -154,9 +162,8 @@
|
@@ -168,9 +176,8 @@
|
||||||
new_fl->img = &buf[i];
|
new_fl->img = &buf[i];
|
||||||
if (fis_origin) {
|
if (fis_origin) {
|
||||||
buf[i].flash_base -= fis_origin;
|
buf[i].flash_base -= fis_origin;
|
||||||
|
|
Loading…
Reference in New Issue