kernel: fix x86 objdump invocation on 3.14 and 3.18
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43557 3c298f89-4303-0410-b956-a3cf2f4a3e73master
parent
31a1718d09
commit
e760d60fa4
|
@ -0,0 +1,16 @@
|
||||||
|
Use the cross toolchain objdump command instead of assuming that the host
|
||||||
|
toolchain has it.
|
||||||
|
|
||||||
|
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
|
||||||
|
|
||||||
|
--- a/arch/x86/boot/compressed/Makefile
|
||||||
|
+++ b/arch/x86/boot/compressed/Makefile
|
||||||
|
@@ -75,7 +75,7 @@ suffix-$(CONFIG_KERNEL_XZ) := xz
|
||||||
|
suffix-$(CONFIG_KERNEL_LZO) := lzo
|
||||||
|
suffix-$(CONFIG_KERNEL_LZ4) := lz4
|
||||||
|
|
||||||
|
-RUN_SIZE = $(shell objdump -h vmlinux | \
|
||||||
|
+RUN_SIZE = $(shell $(OBJDUMP) -h vmlinux | \
|
||||||
|
perl $(srctree)/arch/x86/tools/calc_run_size.pl)
|
||||||
|
quiet_cmd_mkpiggy = MKPIGGY $@
|
||||||
|
cmd_mkpiggy = $(obj)/mkpiggy $< $(RUN_SIZE) > $@ || ( rm -f $@ ; false )
|
|
@ -0,0 +1,11 @@
|
||||||
|
--- a/arch/x86/boot/compressed/Makefile
|
||||||
|
+++ b/arch/x86/boot/compressed/Makefile
|
||||||
|
@@ -76,7 +76,7 @@ suffix-$(CONFIG_KERNEL_XZ) := xz
|
||||||
|
suffix-$(CONFIG_KERNEL_LZO) := lzo
|
||||||
|
suffix-$(CONFIG_KERNEL_LZ4) := lz4
|
||||||
|
|
||||||
|
-RUN_SIZE = $(shell objdump -h vmlinux | \
|
||||||
|
+RUN_SIZE = $(shell $(OBJDUMP) -h vmlinux | \
|
||||||
|
perl $(srctree)/arch/x86/tools/calc_run_size.pl)
|
||||||
|
quiet_cmd_mkpiggy = MKPIGGY $@
|
||||||
|
cmd_mkpiggy = $(obj)/mkpiggy $< $(RUN_SIZE) > $@ || ( rm -f $@ ; false )
|
Loading…
Reference in New Issue