kernel: add driver for the RTL8366RB switch

Thanks to Andrew Tarabaras.


git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19837 3c298f89-4303-0410-b956-a3cf2f4a3e73
master
Gabor Juhos 2010-02-24 13:39:02 +00:00
parent b3ee4a5c4e
commit d41036f849
8 changed files with 1803 additions and 12 deletions

View File

@ -1752,6 +1752,7 @@ CONFIG_RTC_LIB=y
# CONFIG_RTL8366_SMI is not set # CONFIG_RTL8366_SMI is not set
# CONFIG_RTL8366S_PHY_DEBUG_FS is not set # CONFIG_RTL8366S_PHY_DEBUG_FS is not set
# CONFIG_RTL8366S_PHY is not set # CONFIG_RTL8366S_PHY is not set
# CONFIG_RTL8366RB_PHY is not set
CONFIG_RT_MUTEXES=y CONFIG_RT_MUTEXES=y
# CONFIG_RT_MUTEX_TESTER is not set # CONFIG_RT_MUTEX_TESTER is not set
# CONFIG_RUNTIME_DEBUG is not set # CONFIG_RUNTIME_DEBUG is not set

View File

@ -1765,6 +1765,7 @@ CONFIG_RTC_LIB=y
# CONFIG_RTL8366_SMI is not set # CONFIG_RTL8366_SMI is not set
# CONFIG_RTL8366S_PHY_DEBUG_FS is not set # CONFIG_RTL8366S_PHY_DEBUG_FS is not set
# CONFIG_RTL8366S_PHY is not set # CONFIG_RTL8366S_PHY is not set
# CONFIG_RTL8366RB_PHY is not set
CONFIG_RT_MUTEXES=y CONFIG_RT_MUTEXES=y
CONFIG_RWSEM_GENERIC_SPINLOCK=y CONFIG_RWSEM_GENERIC_SPINLOCK=y
# CONFIG_S2IO is not set # CONFIG_S2IO is not set

View File

@ -1854,6 +1854,7 @@ CONFIG_RTC_LIB=y
# CONFIG_RTL8366_SMI is not set # CONFIG_RTL8366_SMI is not set
# CONFIG_RTL8366S_PHY_DEBUG_FS is not set # CONFIG_RTL8366S_PHY_DEBUG_FS is not set
# CONFIG_RTL8366S_PHY is not set # CONFIG_RTL8366S_PHY is not set
# CONFIG_RTL8366RB_PHY is not set
CONFIG_RT_MUTEXES=y CONFIG_RT_MUTEXES=y
# CONFIG_RT_MUTEX_TESTER is not set # CONFIG_RT_MUTEX_TESTER is not set
# CONFIG_RUNTIME_DEBUG is not set # CONFIG_RUNTIME_DEBUG is not set

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1,21 @@
/*
* Platform data definition for the Realtek RTL8366S ethernet switch driver
*
* Copyright (C) 2009-2010 Gabor Juhos <juhosg@openwrt.org>
*
* This program is free software; you can redistribute it and/or modify it
* under the terms of the GNU General Public License version 2 as published
* by the Free Software Foundation.
*/
#ifndef _RTL8366RB_H
#define _RTL8366RB_H
#define RTL8366RB_DRIVER_NAME "rtl8366rb"
struct rtl8366rb_platform_data {
unsigned gpio_sda;
unsigned gpio_sck;
};
#endif /* _RTL8366RB_SMI_H */

View File

@ -1,6 +1,6 @@
--- a/drivers/net/phy/Kconfig --- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig +++ b/drivers/net/phy/Kconfig
@@ -135,4 +135,25 @@ config MDIO_GPIO @@ -135,4 +135,29 @@ config MDIO_GPIO
To compile this driver as a module, choose M here: the module To compile this driver as a module, choose M here: the module
will be called mdio-gpio. will be called mdio-gpio.
@ -17,9 +17,13 @@
+ tristate "Driver for the Realtek RTL8366S switch" + tristate "Driver for the Realtek RTL8366S switch"
+ select SWCONFIG + select SWCONFIG
+ +
+config RTL8366RB_PHY
+ tristate "Driver for the Realtek RTL8366RB switch"
+ select SWCONFIG
+
+config RTL8366S_PHY_DEBUG_FS +config RTL8366S_PHY_DEBUG_FS
+ bool "RTL8366S switch driver DEBUG_FS support" + bool "RTL8366 switch driver DEBUG_FS support"
+ depends on RTL8366S_PHY + depends on RTL8366S_PHY || RTL8366RB_PHY
+ depends on DEBUG_FS + depends on DEBUG_FS
+ default n + default n
+ +
@ -28,12 +32,13 @@
endif # PHYLIB endif # PHYLIB
--- a/drivers/net/phy/Makefile --- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile +++ b/drivers/net/phy/Makefile
@@ -19,6 +19,8 @@ obj-$(CONFIG_IP175C_PHY) += ip175c.o @@ -19,6 +19,9 @@ obj-$(CONFIG_IP175C_PHY) += ip175c.o
obj-$(CONFIG_REALTEK_PHY) += realtek.o obj-$(CONFIG_REALTEK_PHY) += realtek.o
obj-$(CONFIG_AR8216_PHY) += ar8216.o obj-$(CONFIG_AR8216_PHY) += ar8216.o
obj-$(CONFIG_RTL8306_PHY) += rtl8306.o obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
+obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi.o +obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi.o
+obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o +obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
+obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb.o
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
obj-$(CONFIG_FIXED_PHY) += fixed.o obj-$(CONFIG_FIXED_PHY) += fixed.o
obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o

View File

@ -1,6 +1,6 @@
--- a/drivers/net/phy/Kconfig --- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig +++ b/drivers/net/phy/Kconfig
@@ -135,4 +135,25 @@ config MDIO_GPIO @@ -135,4 +135,29 @@ config MDIO_GPIO
To compile this driver as a module, choose M here: the module To compile this driver as a module, choose M here: the module
will be called mdio-gpio. will be called mdio-gpio.
@ -17,9 +17,13 @@
+ tristate "Driver for the Realtek RTL8366S switch" + tristate "Driver for the Realtek RTL8366S switch"
+ select SWCONFIG + select SWCONFIG
+ +
+config RTL8366RB_PHY
+ tristate "Driver for the Realtek RTL8366RB switch"
+ select SWCONFIG
+
+config RTL8366S_PHY_DEBUG_FS +config RTL8366S_PHY_DEBUG_FS
+ bool "RTL8366S switch driver DEBUG_FS support" + bool "RTL8366 switch driver DEBUG_FS support"
+ depends on RTL8366S_PHY + depends on RTL8366S_PHY || RTL8366RB_PHY
+ depends on DEBUG_FS + depends on DEBUG_FS
+ default n + default n
+ +
@ -28,12 +32,13 @@
endif # PHYLIB endif # PHYLIB
--- a/drivers/net/phy/Makefile --- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile +++ b/drivers/net/phy/Makefile
@@ -19,6 +19,8 @@ obj-$(CONFIG_IP175C_PHY) += ip175c.o @@ -19,6 +19,9 @@ obj-$(CONFIG_IP175C_PHY) += ip175c.o
obj-$(CONFIG_REALTEK_PHY) += realtek.o obj-$(CONFIG_REALTEK_PHY) += realtek.o
obj-$(CONFIG_AR8216_PHY) += ar8216.o obj-$(CONFIG_AR8216_PHY) += ar8216.o
obj-$(CONFIG_RTL8306_PHY) += rtl8306.o obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
+obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi.o +obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi.o
+obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o +obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
+obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb.o
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
obj-$(CONFIG_FIXED_PHY) += fixed.o obj-$(CONFIG_FIXED_PHY) += fixed.o
obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o

View File

@ -1,6 +1,6 @@
--- a/drivers/net/phy/Kconfig --- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig +++ b/drivers/net/phy/Kconfig
@@ -141,4 +141,25 @@ config MDIO_GPIO @@ -141,4 +141,29 @@ config MDIO_GPIO
To compile this driver as a module, choose M here: the module To compile this driver as a module, choose M here: the module
will be called mdio-gpio. will be called mdio-gpio.
@ -17,9 +17,13 @@
+ tristate "Driver for the Realtek RTL8366S switch" + tristate "Driver for the Realtek RTL8366S switch"
+ select SWCONFIG + select SWCONFIG
+ +
+config RTL8366RB_PHY
+ tristate "Driver for the Realtek RTL8366RB switch"
+ select SWCONFIG
+
+config RTL8366S_PHY_DEBUG_FS +config RTL8366S_PHY_DEBUG_FS
+ bool "RTL8366S switch driver DEBUG_FS support" + bool "RTL8366 switch driver DEBUG_FS support"
+ depends on RTL8366S_PHY + depends on RTL8366S_PHY || RTL8366RB_PHY
+ depends on DEBUG_FS + depends on DEBUG_FS
+ default n + default n
+ +
@ -28,12 +32,13 @@
endif # PHYLIB endif # PHYLIB
--- a/drivers/net/phy/Makefile --- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile +++ b/drivers/net/phy/Makefile
@@ -20,6 +20,8 @@ obj-$(CONFIG_IP175C_PHY) += ip175c.o @@ -20,6 +20,9 @@ obj-$(CONFIG_IP175C_PHY) += ip175c.o
obj-$(CONFIG_REALTEK_PHY) += realtek.o obj-$(CONFIG_REALTEK_PHY) += realtek.o
obj-$(CONFIG_AR8216_PHY) += ar8216.o obj-$(CONFIG_AR8216_PHY) += ar8216.o
obj-$(CONFIG_RTL8306_PHY) += rtl8306.o obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
+obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi.o +obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi.o
+obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o +obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
+obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb.o
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
obj-$(CONFIG_FIXED_PHY) += fixed.o obj-$(CONFIG_FIXED_PHY) += fixed.o
obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o