mac80211: fix compile issues on 2.6.35

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21990 3c298f89-4303-0410-b956-a3cf2f4a3e73
master
Alexandros C. Couloumbis 2010-06-30 14:10:41 +00:00
parent 7c3d1411b5
commit c5ea3cd4d1
1 changed files with 11 additions and 0 deletions

View File

@ -0,0 +1,11 @@
--- a/scripts/gen-compat-autoconf.sh
+++ b/scripts/gen-compat-autoconf.sh
@@ -192,7 +192,7 @@ if [ -f $KLIB_BUILD/Makefile ]; then
define_config_multiple_deps CONFIG_MAC80211_QOS y $ALL_DEPS
rm -f $MULT_DEP_FILE
# Kernels >= 2.6.32 can disable WEXT :D
- if [ $SUBLEVEL -le 32 ]; then
+ if [ $SUBLEVEL -le 35 ]; then
define_config_dep CONFIG_CFG80211_WEXT 1 CONFIG_WIRELESS_EXT
fi
fi