dnsmasq: bump to 2.7.0
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40759 3c298f89-4303-0410-b956-a3cf2f4a3e73master
parent
a9ccf0aace
commit
bfaa1ec952
|
@ -8,12 +8,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=dnsmasq
|
PKG_NAME:=dnsmasq
|
||||||
PKG_VERSION:=2.66
|
PKG_VERSION:=2.70
|
||||||
PKG_RELEASE:=5
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
|
PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
|
||||||
PKG_MD5SUM:=c5eb8fb88847a5e9bf18db67c74efd47
|
PKG_MD5SUM:=d6afbf46cd80bb0b7f6ed1404733ed4f
|
||||||
|
|
||||||
PKG_LICENSE:=GPLv2
|
PKG_LICENSE:=GPLv2
|
||||||
PKG_LICENSE_FILES:=COPYING
|
PKG_LICENSE_FILES:=COPYING
|
||||||
|
|
|
@ -1,51 +0,0 @@
|
||||||
Index: dnsmasq-2.66/src/dhcp.c
|
|
||||||
===================================================================
|
|
||||||
--- dnsmasq-2.66.orig/src/dhcp.c 2013-04-17 14:52:49.000000000 +0200
|
|
||||||
+++ dnsmasq-2.66/src/dhcp.c 2013-04-24 08:24:20.393711625 +0200
|
|
||||||
@@ -140,7 +140,7 @@
|
|
||||||
struct iovec iov;
|
|
||||||
ssize_t sz;
|
|
||||||
int iface_index = 0, unicast_dest = 0, is_inform = 0;
|
|
||||||
- struct in_addr iface_addr;
|
|
||||||
+ struct in_addr iface_addr, *addrp = NULL;
|
|
||||||
struct iface_param parm;
|
|
||||||
#ifdef HAVE_LINUX_NETWORK
|
|
||||||
struct arpreq arp_req;
|
|
||||||
@@ -252,11 +252,9 @@
|
|
||||||
|
|
||||||
ifr.ifr_addr.sa_family = AF_INET;
|
|
||||||
if (ioctl(daemon->dhcpfd, SIOCGIFADDR, &ifr) != -1 )
|
|
||||||
- iface_addr = ((struct sockaddr_in *) &ifr.ifr_addr)->sin_addr;
|
|
||||||
- else
|
|
||||||
{
|
|
||||||
- my_syslog(MS_DHCP | LOG_WARNING, _("DHCP packet received on %s which has no address"), ifr.ifr_name);
|
|
||||||
- return;
|
|
||||||
+ addrp = &iface_addr;
|
|
||||||
+ iface_addr = ((struct sockaddr_in *) &ifr.ifr_addr)->sin_addr;
|
|
||||||
}
|
|
||||||
|
|
||||||
for (tmp = daemon->dhcp_except; tmp; tmp = tmp->next)
|
|
||||||
@@ -270,7 +268,7 @@
|
|
||||||
parm.current = NULL;
|
|
||||||
parm.ind = iface_index;
|
|
||||||
|
|
||||||
- if (!iface_check(AF_INET, (struct all_addr *)&iface_addr, ifr.ifr_name, NULL))
|
|
||||||
+ if (!iface_check(AF_INET, (struct all_addr *)addrp, ifr.ifr_name, NULL))
|
|
||||||
{
|
|
||||||
/* If we failed to match the primary address of the interface, see if we've got a --listen-address
|
|
||||||
for a secondary */
|
|
||||||
@@ -289,7 +287,13 @@
|
|
||||||
there is more than one address on the interface in the same subnet */
|
|
||||||
complete_context(match.addr, iface_index, match.netmask, match.broadcast, &parm);
|
|
||||||
}
|
|
||||||
-
|
|
||||||
+
|
|
||||||
+ if (!addrp)
|
|
||||||
+ {
|
|
||||||
+ my_syslog(MS_DHCP | LOG_WARNING, _("DHCP packet received on %s which has no address"), ifr.ifr_name);
|
|
||||||
+ return;
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
if (!iface_enumerate(AF_INET, &parm, complete_context))
|
|
||||||
return;
|
|
||||||
|
|
|
@ -1,13 +0,0 @@
|
||||||
Index: dnsmasq-2.66/src/ipset.c
|
|
||||||
===================================================================
|
|
||||||
--- dnsmasq-2.66.orig/src/ipset.c 2013-04-17 14:52:49.000000000 +0200
|
|
||||||
+++ dnsmasq-2.66/src/ipset.c 2013-04-24 08:25:05.905712707 +0200
|
|
||||||
@@ -110,7 +110,7 @@
|
|
||||||
return -1;
|
|
||||||
}
|
|
||||||
|
|
||||||
- memset(buffer, 0, sizeof(buffer));
|
|
||||||
+ memset(buffer, 0, BUFF_SZ);
|
|
||||||
|
|
||||||
nlh = (struct nlmsghdr *)buffer;
|
|
||||||
nlh->nlmsg_len = NL_ALIGN(sizeof(struct nlmsghdr));
|
|
Loading…
Reference in New Issue