mac80211: fix GPIO pin assignment for the LEDs on the WNDR3700 board
Signed-off-by: Scott Dudley <spmsink@hotmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19745 3c298f89-4303-0410-b956-a3cf2f4a3e73master
parent
299fec26a9
commit
ab3d70a223
|
@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
|
||||||
PKG_NAME:=mac80211
|
PKG_NAME:=mac80211
|
||||||
|
|
||||||
PKG_VERSION:=2010-02-16
|
PKG_VERSION:=2010-02-16
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=2
|
||||||
PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
|
PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
|
||||||
# http://www.orbit-lab.org/kernel/compat-wireless-2.6/2010/11 \
|
# http://www.orbit-lab.org/kernel/compat-wireless-2.6/2010/11 \
|
||||||
# http://wireless.kernel.org/download/compat-wireless-2.6
|
# http://wireless.kernel.org/download/compat-wireless-2.6
|
||||||
|
|
|
@ -0,0 +1,23 @@
|
||||||
|
--- a/drivers/net/wireless/ath/ath9k/gpio.c
|
||||||
|
+++ b/drivers/net/wireless/ath/ath9k/gpio.c
|
||||||
|
@@ -138,7 +138,9 @@ void ath_init_leds(struct ath_softc *sc)
|
||||||
|
if (AR_SREV_9100(sc->sc_ah))
|
||||||
|
return;
|
||||||
|
|
||||||
|
- if (AR_SREV_9287(sc->sc_ah))
|
||||||
|
+ if (sc->quirk_wndr3700)
|
||||||
|
+ sc->sc_ah->led_pin = ATH_LED_PIN_WNDR3700;
|
||||||
|
+ else if (AR_SREV_9287(sc->sc_ah))
|
||||||
|
sc->sc_ah->led_pin = ATH_LED_PIN_9287;
|
||||||
|
else
|
||||||
|
sc->sc_ah->led_pin = ATH_LED_PIN_DEF;
|
||||||
|
--- a/drivers/net/wireless/ath/ath9k/ath9k.h
|
||||||
|
+++ b/drivers/net/wireless/ath/ath9k/ath9k.h
|
||||||
|
@@ -379,6 +379,7 @@ void ath9k_btcoex_timer_pause(struct ath
|
||||||
|
|
||||||
|
#define ATH_LED_PIN_DEF 1
|
||||||
|
#define ATH_LED_PIN_9287 8
|
||||||
|
+#define ATH_LED_PIN_WNDR3700 5
|
||||||
|
#define ATH_LED_ON_DURATION_IDLE 350 /* in msecs */
|
||||||
|
#define ATH_LED_OFF_DURATION_IDLE 250 /* in msecs */
|
||||||
|
|
Loading…
Reference in New Issue