openssl: fix upstream regression for non-ec builds
Signed-off-by: Steven Barth <steven@midlink.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44364 3c298f89-4303-0410-b956-a3cf2f4a3e73master
parent
66b84f777a
commit
a98b1cf597
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=openssl
|
||||
PKG_VERSION:=1.0.2
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
PKG_USE_MIPS16:=0
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
|
|
@ -0,0 +1,14 @@
|
|||
--- a/ssl/t1_lib.c
|
||||
+++ b/ssl/t1_lib.c
|
||||
@@ -113,9 +113,11 @@
|
||||
#include <openssl/objects.h>
|
||||
#include <openssl/evp.h>
|
||||
#include <openssl/hmac.h>
|
||||
+#ifndef OPENSSL_NO_EC
|
||||
#ifdef OPENSSL_NO_EC2M
|
||||
# include <openssl/ec.h>
|
||||
#endif
|
||||
+#endif
|
||||
#include <openssl/ocsp.h>
|
||||
#include <openssl/rand.h>
|
||||
#include "ssl_locl.h"
|
Loading…
Reference in New Issue