Allow mac80211 drivers to work in master mode

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12299 3c298f89-4303-0410-b956-a3cf2f4a3e73
master
Florian Fainelli 2008-08-13 19:35:29 +00:00
parent 401d64162b
commit a44a1c7594
2 changed files with 27 additions and 3 deletions

View File

@ -12,10 +12,9 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=mac80211
PKG_RELEASE:=1
PKG_VERSION:=$(if $(CONFIG_TARGET_brcm47xx),2008-05-26,2008-07-19)
PKG_VERSION:=2008-08-06
PKG_SOURCE:=compat-wireless-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=$(if $(CONFIG_TARGET_brcm47xx),http://www.orbit-lab.org/kernel/compat-wireless-2.6/2008/05,http://www.orbit-lab.org/kernel/compat-wireless-2.6/2008/07)
#PKG_SOURCE_URL:=http://downloads.openwrt.org/sources/
PKG_SOURCE_URL:=http://www.orbit-lab.org/kernel/compat-wireless-2.6/2008/08/
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/compat-wireless-$(PKG_VERSION)
include $(INCLUDE_DIR)/package.mk

View File

@ -0,0 +1,25 @@
Subject: mac80211: allow AP and VLAN modes
This patch allows switching interfaces into AP/VLAN modes using
cfg80211 (nl80211). Don't allow doing it with wext because then
people will just attempt to do it manually (without hostapd) and
complain that it doesn't work.
Signed-off-by: Johannes Berg <johannes@sipsolutions.net>
---
net/mac80211/cfg.c | 4 ++++
1 file changed, 4 insertions(+)
--- everything.orig/net/mac80211/cfg.c 2008-08-06 21:38:13.000000000 +0200
+++ everything/net/mac80211/cfg.c 2008-08-06 21:38:24.000000000 +0200
@@ -33,6 +33,10 @@ nl80211_type_to_mac80211_type(enum nl802
case NL80211_IFTYPE_MESH_POINT:
return IEEE80211_IF_TYPE_MESH_POINT;
#endif
+ case NL80211_IFTYPE_AP:
+ return IEEE80211_IF_TYPE_AP;
+ case NL80211_IFTYPE_AP_VLAN:
+ return IEEE80211_IF_TYPE_VLAN;
case NL80211_IFTYPE_WDS:
return IEEE80211_IF_TYPE_WDS;
default: