add a patch to use relative symlinks for development shared libraries

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12355 3c298f89-4303-0410-b956-a3cf2f4a3e73
master
Nicolas Thill 2008-08-20 16:01:33 +00:00
parent eca3668c83
commit 9edadd52ba
1 changed files with 12 additions and 0 deletions

View File

@ -0,0 +1,12 @@
diff -ruN e2fsprogs-1.40.11.orig/lib/Makefile.elf-lib e2fsprogs-1.40.11/lib/Makefile.elf-lib
--- e2fsprogs-1.40.11.orig/lib/Makefile.elf-lib 2008-01-01 22:47:01.000000000 +0100
+++ e2fsprogs-1.40.11/lib/Makefile.elf-lib 2008-08-13 13:32:47.206558190 +0200
@@ -45,7 +45,7 @@
@echo " SYMLINK $(ELF_INSTALL_DIR)/$(ELF_SONAME)"
@$(LN_S) -f $(ELF_LIB) $(DESTDIR)$(ELF_INSTALL_DIR)/$(ELF_SONAME)
@echo " SYMLINK $(libdir)/$(ELF_IMAGE).so"
- @$(LN_S) -f $(ELF_INSTALL_DIR)/$(ELF_SONAME) \
+ @$(LN_S) -f $(ELF_SONAME) \
$(DESTDIR)$(libdir)/$(ELF_IMAGE).so
@echo " LDCONFIG"
@-$(LDCONFIG)