orion: Update Orion in trunk to kernel 2.6.34.
Was flashed on WRT350Nv2, booted and is running for several days. Closes #7405 Thank you maddes for your patch. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21682 3c298f89-4303-0410-b956-a3cf2f4a3e73master
parent
e69562eb28
commit
9d9eb999e1
|
@ -13,7 +13,7 @@ FEATURES:=squashfs
|
||||||
SUBTARGETS=generic harddisk
|
SUBTARGETS=generic harddisk
|
||||||
CFLAGS=-Os -pipe -march=armv5t -mtune=xscale -funit-at-a-time
|
CFLAGS=-Os -pipe -march=armv5t -mtune=xscale -funit-at-a-time
|
||||||
|
|
||||||
LINUX_VERSION:=2.6.32.14
|
LINUX_VERSION:=2.6.34
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
|
|
@ -0,0 +1,11 @@
|
||||||
|
--- a/arch/arm/kernel/setup.c
|
||||||
|
+++ b/arch/arm/kernel/setup.c
|
||||||
|
@@ -629,7 +629,7 @@ __tagtable(ATAG_REVISION, parse_tag_revi
|
||||||
|
|
||||||
|
static int __init parse_tag_cmdline(const struct tag *tag)
|
||||||
|
{
|
||||||
|
- strlcpy(default_command_line, tag->u.cmdline.cmdline, COMMAND_LINE_SIZE);
|
||||||
|
+// strlcpy(default_command_line, tag->u.cmdline.cmdline, COMMAND_LINE_SIZE);
|
||||||
|
return 0;
|
||||||
|
}
|
||||||
|
|
|
@ -0,0 +1,14 @@
|
||||||
|
--- a/drivers/mtd/chips/cfi_cmdset_0002.c
|
||||||
|
+++ b/drivers/mtd/chips/cfi_cmdset_0002.c
|
||||||
|
@@ -374,8 +374,9 @@ struct mtd_info *cfi_cmdset_0002(struct
|
||||||
|
|
||||||
|
cfi_fixup_major_minor(cfi, extp);
|
||||||
|
|
||||||
|
- if (extp->MajorVersion < '0' || extp->MajorVersion > '3' ||
|
||||||
|
- (extp->MinorVersion < '0' || extp->MinorVersion > '4')) {
|
||||||
|
+ if ((extp->MajorVersion != '0' && extp->MinorVersion != '0') &&
|
||||||
|
+ (extp->MajorVersion < '0' || extp->MajorVersion > '3' ||
|
||||||
|
+ (extp->MinorVersion < '0' || extp->MinorVersion > '4'))) {
|
||||||
|
if (cfi->mfr == MANUFACTURER_SAMSUNG &&
|
||||||
|
(extp->MajorVersion == '3' && extp->MinorVersion == '3')) {
|
||||||
|
printk(KERN_NOTICE " Newer Samsung flash detected, "
|
|
@ -0,0 +1,32 @@
|
||||||
|
--- a/arch/arm/mach-orion5x/wrt350n-v2-setup.c
|
||||||
|
+++ b/arch/arm/mach-orion5x/wrt350n-v2-setup.c
|
||||||
|
@@ -135,11 +135,11 @@ static struct mtd_partition wrt350n_v2_n
|
||||||
|
{
|
||||||
|
.name = "kernel",
|
||||||
|
.offset = 0x00000000,
|
||||||
|
- .size = 0x00760000,
|
||||||
|
+ .size = 0x00100000, // change to kernel mtd size here (1/3)
|
||||||
|
}, {
|
||||||
|
.name = "rootfs",
|
||||||
|
- .offset = 0x001a0000,
|
||||||
|
- .size = 0x005c0000,
|
||||||
|
+ .offset = 0x00100000, // change to kernel mtd size here (2/3)
|
||||||
|
+ .size = 0x00650000, // adopt to kernel mtd size here (3/3) = 0x00750000 - <kernel mtd size>
|
||||||
|
}, {
|
||||||
|
.name = "lang",
|
||||||
|
.offset = 0x00760000,
|
||||||
|
@@ -152,6 +152,14 @@ static struct mtd_partition wrt350n_v2_n
|
||||||
|
.name = "u-boot",
|
||||||
|
.offset = 0x007c0000,
|
||||||
|
.size = 0x00040000,
|
||||||
|
+ }, {
|
||||||
|
+ .name = "eRcOmM_do_not_touch",
|
||||||
|
+ .offset = 0x00750000,
|
||||||
|
+ .size = 0x00010000, // erasesize
|
||||||
|
+ }, {
|
||||||
|
+ .name = "image", // for sysupgrade
|
||||||
|
+ .offset = 0x00000000,
|
||||||
|
+ .size = 0x00750000,
|
||||||
|
},
|
||||||
|
};
|
||||||
|
|
|
@ -0,0 +1,13 @@
|
||||||
|
--- a/arch/arm/mach-orion5x/wnr854t-setup.c
|
||||||
|
+++ b/arch/arm/mach-orion5x/wnr854t-setup.c
|
||||||
|
@@ -67,6 +67,10 @@ static struct mtd_partition wnr854t_nor_
|
||||||
|
.name = "uboot",
|
||||||
|
.offset = 0x00760000,
|
||||||
|
.size = 0x00040000,
|
||||||
|
+ }, {
|
||||||
|
+ .name = "image", // for sysupgrade
|
||||||
|
+ .offset = 0x00000000,
|
||||||
|
+ .size = 0x00760000,
|
||||||
|
},
|
||||||
|
};
|
||||||
|
|
|
@ -0,0 +1,23 @@
|
||||||
|
--- a/arch/arm/mach-orion5x/Kconfig
|
||||||
|
+++ b/arch/arm/mach-orion5x/Kconfig
|
||||||
|
@@ -16,6 +16,13 @@ config MACH_RD88F5182
|
||||||
|
Say 'Y' here if you want your kernel to support the
|
||||||
|
Marvell Orion-NAS (88F5182) RD2
|
||||||
|
|
||||||
|
+config MACH_DT2
|
||||||
|
+ bool "Freecom DataTank Gateway"
|
||||||
|
+ select I2C_BOARDINFO
|
||||||
|
+ help
|
||||||
|
+ Say 'Y' here if you want your kernel to support the
|
||||||
|
+ Freecom DataTank Gateway
|
||||||
|
+
|
||||||
|
config MACH_KUROBOX_PRO
|
||||||
|
bool "KuroBox Pro"
|
||||||
|
select I2C_BOARDINFO
|
||||||
|
--- a/arch/arm/mach-orion5x/Makefile
|
||||||
|
+++ b/arch/arm/mach-orion5x/Makefile
|
||||||
|
@@ -20,3 +20,4 @@ obj-$(CONFIG_MACH_WNR854T) += wnr854t-se
|
||||||
|
obj-$(CONFIG_MACH_RD88F5181L_GE) += rd88f5181l-ge-setup.o
|
||||||
|
obj-$(CONFIG_MACH_RD88F5181L_FXO) += rd88f5181l-fxo-setup.o
|
||||||
|
obj-$(CONFIG_MACH_RD88F6183AP_GE) += rd88f6183ap-ge-setup.o
|
||||||
|
+obj-$(CONFIG_MACH_DT2) += dt2-setup.o
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/arch/arm/kernel/setup.c
|
--- a/arch/arm/kernel/setup.c
|
||||||
+++ b/arch/arm/kernel/setup.c
|
+++ b/arch/arm/kernel/setup.c
|
||||||
@@ -629,7 +629,7 @@ __tagtable(ATAG_REVISION, parse_tag_revi
|
@@ -595,7 +595,7 @@ __tagtable(ATAG_REVISION, parse_tag_revi
|
||||||
|
|
||||||
static int __init parse_tag_cmdline(const struct tag *tag)
|
static int __init parse_tag_cmdline(const struct tag *tag)
|
||||||
{
|
{
|
||||||
|
|
|
@ -16,7 +16,7 @@
|
||||||
select I2C_BOARDINFO
|
select I2C_BOARDINFO
|
||||||
--- a/arch/arm/mach-orion5x/Makefile
|
--- a/arch/arm/mach-orion5x/Makefile
|
||||||
+++ b/arch/arm/mach-orion5x/Makefile
|
+++ b/arch/arm/mach-orion5x/Makefile
|
||||||
@@ -20,3 +20,4 @@ obj-$(CONFIG_MACH_WNR854T) += wnr854t-se
|
@@ -21,3 +21,4 @@ obj-$(CONFIG_MACH_WNR854T) += wnr854t-se
|
||||||
obj-$(CONFIG_MACH_RD88F5181L_GE) += rd88f5181l-ge-setup.o
|
obj-$(CONFIG_MACH_RD88F5181L_GE) += rd88f5181l-ge-setup.o
|
||||||
obj-$(CONFIG_MACH_RD88F5181L_FXO) += rd88f5181l-fxo-setup.o
|
obj-$(CONFIG_MACH_RD88F5181L_FXO) += rd88f5181l-fxo-setup.o
|
||||||
obj-$(CONFIG_MACH_RD88F6183AP_GE) += rd88f6183ap-ge-setup.o
|
obj-$(CONFIG_MACH_RD88F6183AP_GE) += rd88f6183ap-ge-setup.o
|
||||||
|
|
Loading…
Reference in New Issue