madwifi: remove the get_arch.mk build failure when the 'detected' arch doesn't match the build system's value
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17084 3c298f89-4303-0410-b956-a3cf2f4a3e73master
parent
273b8a2100
commit
9b19c72b56
|
@ -1,6 +1,6 @@
|
|||
--- a/scripts/get_arch.mk
|
||||
+++ b/scripts/get_arch.mk
|
||||
@@ -36,6 +36,13 @@ ifeq (,$(ARCH-y))
|
||||
@@ -36,11 +36,14 @@ ifeq (,$(ARCH-y))
|
||||
$(Cannot determine ARCH)
|
||||
endif
|
||||
|
||||
|
@ -14,3 +14,8 @@
|
|||
# Don't allow ARCH to be overridden by a different value.
|
||||
ifeq (,$(ARCH))
|
||||
ARCH = $(ARCH-y)
|
||||
-else
|
||||
-ifneq ($(ARCH),$(ARCH-y))
|
||||
-$(error ARCH mismatch: supplied "$(ARCH)", determined "$(ARCH-y)")
|
||||
-endif
|
||||
endif
|
||||
|
|
Loading…
Reference in New Issue