json-c: update to 0.12 and bump all depending services
Version 0.12 deprecates json_object_object_get and moves the header files around Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44657 3c298f89-4303-0410-b956-a3cf2f4a3e73master
parent
8d41dec38a
commit
93cd017604
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=json-c
|
||||
PKG_VERSION:=0.11
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=0.12
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://s3.amazonaws.com/json-c_releases/releases/
|
||||
PKG_MD5SUM:=aa02367d2f7a830bf1e3376f77881e98
|
||||
PKG_MD5SUM:=3ca4bbb881dfc4017e8021b5e0a8c491
|
||||
|
||||
PKG_LICENSE:=MIT
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
@ -38,30 +38,13 @@ define Package/libjson-c/description
|
|||
This package contains a library for javascript object notation backends.
|
||||
endef
|
||||
|
||||
define Package/libjson
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
DEPENDS:=+libjson-c
|
||||
TITLE:=javascript object notation (compat library)
|
||||
URL:=http://oss.metaparadigm.com/json-c/
|
||||
endef
|
||||
|
||||
define Package/libjson/description
|
||||
This package contains a compatibility library for packages that have not
|
||||
been adapted to the json-c library rename yet
|
||||
endef
|
||||
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/include
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/json $(1)/usr/include/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/json-c $(1)/usr/include/
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libjson.{a,so*} $(1)/usr/lib/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libjson-c.{a,so*} $(1)/usr/lib/
|
||||
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/json-c.pc $(1)/usr/lib/pkgconfig/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/json.pc $(1)/usr/lib/pkgconfig/
|
||||
endef
|
||||
|
||||
define Package/libjson-c/install
|
||||
|
@ -69,10 +52,4 @@ define Package/libjson-c/install
|
|||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libjson-c.so.* $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
define Package/libjson/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libjson.so.* $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,libjson-c))
|
||||
$(eval $(call BuildPackage,libjson))
|
||||
|
|
|
@ -0,0 +1,50 @@
|
|||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -43,12 +43,6 @@
|
||||
AC_FUNC_MALLOC
|
||||
AC_FUNC_REALLOC
|
||||
AC_CHECK_FUNCS(strcasecmp strdup strerror snprintf vsnprintf vasprintf open vsyslog strncasecmp setlocale)
|
||||
-AC_CHECK_DECLS([INFINITY], [], [], [[#include <math.h>]])
|
||||
-AC_CHECK_DECLS([nan], [], [], [[#include <math.h>]])
|
||||
-AC_CHECK_DECLS([isnan], [], [], [[#include <math.h>]])
|
||||
-AC_CHECK_DECLS([isinf], [], [], [[#include <math.h>]])
|
||||
-AC_CHECK_DECLS([_isnan], [], [], [[#include <float.h>]])
|
||||
-AC_CHECK_DECLS([_finite], [], [], [[#include <float.h>]])
|
||||
|
||||
#check if .section.gnu.warning accepts long strings (for __warn_references)
|
||||
AC_LANG_PUSH([C])
|
||||
--- a/math_compat.h
|
||||
+++ b/math_compat.h
|
||||
@@ -1,28 +1,9 @@
|
||||
#ifndef __math_compat_h
|
||||
#define __math_compat_h
|
||||
|
||||
-/* Define isnan and isinf on Windows/MSVC */
|
||||
-
|
||||
-#ifndef HAVE_DECL_ISNAN
|
||||
-# ifdef HAVE_DECL__ISNAN
|
||||
-#include <float.h>
|
||||
-#define isnan(x) _isnan(x)
|
||||
-# endif
|
||||
-#endif
|
||||
-
|
||||
-#ifndef HAVE_DECL_ISINF
|
||||
-# ifdef HAVE_DECL__FINITE
|
||||
-#include <float.h>
|
||||
-#define isinf(x) (!_finite(x))
|
||||
-# endif
|
||||
-#endif
|
||||
-
|
||||
-#ifndef HAVE_DECL_NAN
|
||||
-#error This platform does not have nan()
|
||||
-#endif
|
||||
-
|
||||
-#ifndef HAVE_DECL_INFINITY
|
||||
-#error This platform does not have INFINITY
|
||||
-#endif
|
||||
+#undef isnan
|
||||
+#define isnan(x) __builtin_isnan(x)
|
||||
+#undef isinf
|
||||
+#define isinf(x) __builtin_isinf(x)
|
||||
|
||||
#endif
|
|
@ -1,13 +1,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=netifd
|
||||
PKG_VERSION:=2015-02-17
|
||||
PKG_VERSION:=2015-03-06
|
||||
PKG_RELEASE=$(PKG_SOURCE_VERSION)
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=http://git.openwrt.org/project/netifd.git
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE_VERSION:=4d84111e1014c817653db92bcd8024ff1935b6be
|
||||
PKG_SOURCE_VERSION:=45fd905c980e56b20770d4b34556749fbca53fcc
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
|
||||
PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
|
||||
# PKG_MIRROR_MD5SUM:=
|
||||
|
|
|
@ -8,14 +8,14 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=procd
|
||||
PKG_VERSION:=2015-02-27
|
||||
PKG_VERSION:=2015-03-06
|
||||
|
||||
PKG_RELEASE=$(PKG_SOURCE_VERSION)
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=git://nbd.name/luci2/procd.git
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE_VERSION:=b6777a45becef915d6a99f01e044ad508bb278c6
|
||||
PKG_SOURCE_VERSION:=47d5be7160e33966f5ded484232d10dcc220f172
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
|
||||
CMAKE_INSTALL:=1
|
||||
|
||||
|
|
|
@ -8,13 +8,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=rpcd
|
||||
PKG_VERSION:=2015-02-09
|
||||
PKG_VERSION:=2015-03-11
|
||||
PKG_RELEASE=$(PKG_SOURCE_VERSION)
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=git://nbd.name/luci2/rpcd.git
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)
|
||||
PKG_SOURCE_VERSION:=7b7f254682d24aee497a545a3e20cdaf7cec4f22
|
||||
PKG_SOURCE_VERSION:=ae3fe30b6a1d4a45a34b3a896e9a4997c5da500f
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
|
||||
PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
|
||||
|
||||
|
|
Loading…
Reference in New Issue