kernel: update linux 3.8 to 3.8.7
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36332 3c298f89-4303-0410-b956-a3cf2f4a3e73master
parent
988e72c790
commit
9198c2f4ab
|
@ -11,8 +11,8 @@ endif
|
|||
ifeq ($(LINUX_VERSION),3.7.10)
|
||||
LINUX_KERNEL_MD5SUM:=09624c3702107076efcac5e1cd8a18ec
|
||||
endif
|
||||
ifeq ($(LINUX_VERSION),3.8.6)
|
||||
LINUX_KERNEL_MD5SUM:=0934e6b31931c1832e48a28bd35ef27f
|
||||
ifeq ($(LINUX_VERSION),3.8.7)
|
||||
LINUX_KERNEL_MD5SUM:=37ce9b5cc33551b45fea59c1c4c9da13
|
||||
endif
|
||||
|
||||
# disable the md5sum check for unknown kernel versions
|
||||
|
|
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
BOARD:=adm5120
|
||||
BOARDNAME:=Infineon/ADMtek ADM5120
|
||||
LINUX_VERSION:=3.8.6
|
||||
LINUX_VERSION:=3.8.7
|
||||
SUBTARGETS:=router_le router_be rb1xx
|
||||
INITRAMFS_EXTRA_FILES:=
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
|
|||
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
|
||||
SUBTARGETS:=generic nand
|
||||
|
||||
LINUX_VERSION:=3.8.6
|
||||
LINUX_VERSION:=3.8.7
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -27,7 +27,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
|
|||
|
||||
--- a/arch/mips/pci/pci.c
|
||||
+++ b/arch/mips/pci/pci.c
|
||||
@@ -175,9 +175,20 @@ static DEFINE_MUTEX(pci_scan_mutex);
|
||||
@@ -181,9 +181,20 @@ static DEFINE_MUTEX(pci_scan_mutex);
|
||||
|
||||
void register_pci_controller(struct pci_controller *hose)
|
||||
{
|
||||
|
|
|
@ -84,7 +84,7 @@
|
|||
mutex_unlock(&flash->lock);
|
||||
|
||||
return 0;
|
||||
@@ -916,6 +939,12 @@ static int m25p_probe(struct spi_device
|
||||
@@ -917,6 +940,12 @@ static int m25p_probe(struct spi_device
|
||||
flash->mtd._erase = m25p80_erase;
|
||||
flash->mtd._read = m25p80_read;
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/drivers/mtd/devices/m25p80.c
|
||||
+++ b/drivers/mtd/devices/m25p80.c
|
||||
@@ -1016,7 +1016,9 @@ static int m25p_probe(struct spi_device
|
||||
@@ -1017,7 +1017,9 @@ static int m25p_probe(struct spi_device
|
||||
/* partitions should match sector boundaries; and it may be good to
|
||||
* use readonly partitions for writeprotected sectors (BP2..BP0).
|
||||
*/
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/drivers/mtd/devices/m25p80.c
|
||||
+++ b/drivers/mtd/devices/m25p80.c
|
||||
@@ -966,6 +966,7 @@ static int m25p_probe(struct spi_device
|
||||
@@ -967,6 +967,7 @@ static int m25p_probe(struct spi_device
|
||||
if (info->flags & M25P_NO_ERASE)
|
||||
flash->mtd.flags |= MTD_NO_ERASE;
|
||||
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=atheros
|
|||
BOARDNAME:=Atheros AR231x/AR5312
|
||||
FEATURES:=squashfs jffs2
|
||||
|
||||
LINUX_VERSION:=3.8.6
|
||||
LINUX_VERSION:=3.8.7
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Atmel AVR32
|
|||
FEATURES:=squashfs
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.8.6
|
||||
LINUX_VERSION:=3.8.7
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -11,7 +11,7 @@ Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
|
|||
|
||||
--- a/drivers/mtd/devices/m25p80.c
|
||||
+++ b/drivers/mtd/devices/m25p80.c
|
||||
@@ -987,7 +987,8 @@ static int m25p_probe(struct spi_device
|
||||
@@ -988,7 +988,8 @@ static int m25p_probe(struct spi_device
|
||||
/* partitions should match sector boundaries; and it may be good to
|
||||
* use readonly partitions for writeprotected sectors (BP2..BP0).
|
||||
*/
|
||||
|
|
|
@ -60,7 +60,7 @@ Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
|
|||
/*
|
||||
* Write an address range to the flash chip. Data must be written in
|
||||
* FLASH_PAGESIZE chunks. The address range may be any size provided
|
||||
@@ -888,6 +910,9 @@ static int m25p_probe(struct spi_device
|
||||
@@ -889,6 +911,9 @@ static int m25p_probe(struct spi_device
|
||||
return -ENOMEM;
|
||||
}
|
||||
|
||||
|
|
|
@ -10,7 +10,7 @@ Subject: [PATCH 64/79] MTD: m25p80: allow passing pp_data
|
|||
|
||||
--- a/drivers/mtd/devices/m25p80.c
|
||||
+++ b/drivers/mtd/devices/m25p80.c
|
||||
@@ -877,6 +877,9 @@ static int m25p_probe(struct spi_device
|
||||
@@ -878,6 +878,9 @@ static int m25p_probe(struct spi_device
|
||||
dev_warn(&spi->dev, "unrecognized id %s\n", data->type);
|
||||
}
|
||||
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Econa CNS21xx
|
|||
FEATURES:=squashfs
|
||||
CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
|
||||
|
||||
LINUX_VERSION:=3.8.6
|
||||
LINUX_VERSION:=3.8.7
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs fpu gpio pcie usb usbgadget
|
|||
CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.8.6
|
||||
LINUX_VERSION:=3.8.7
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 ext4 targz usb display sound
|
|||
CFLAGS:=-Os -pipe -march=armv4t -fno-caller-saves
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.8.6
|
||||
LINUX_VERSION:=3.8.7
|
||||
|
||||
DEVICE_TYPE:=developerboard
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/drivers/mtd/devices/m25p80.c
|
||||
+++ b/drivers/mtd/devices/m25p80.c
|
||||
@@ -682,6 +682,7 @@
|
||||
@@ -674,6 +674,7 @@ static const struct spi_device_id m25p_i
|
||||
/* PMC -- pm25x "blocks" are 32K, sectors are 4K */
|
||||
{ "pm25lv512", INFO(0, 0, 32 * 1024, 2, SECT_4K_PMC) },
|
||||
{ "pm25lv010", INFO(0, 0, 32 * 1024, 4, SECT_4K_PMC) },
|
||||
|
|
|
@ -30,7 +30,7 @@
|
|||
/****************************************************************************/
|
||||
|
||||
struct m25p {
|
||||
@@ -917,7 +923,7 @@ static int m25p_probe(struct spi_device
|
||||
@@ -918,7 +924,7 @@ static int m25p_probe(struct spi_device
|
||||
flash->mtd._write = m25p80_write;
|
||||
|
||||
/* prefer "small sector" erase if possible */
|
||||
|
|
|
@ -24,7 +24,7 @@ commont qdiscs.
|
|||
}
|
||||
--- a/net/sched/sch_fifo.c
|
||||
+++ b/net/sched/sch_fifo.c
|
||||
@@ -29,17 +29,21 @@ static int bfifo_enqueue(struct sk_buff
|
||||
@@ -29,17 +29,21 @@ static int bfifo_enqueue(struct sk_buff
|
||||
|
||||
static int pfifo_enqueue(struct sk_buff *skb, struct Qdisc *sch)
|
||||
{
|
||||
|
|
|
@ -45,7 +45,7 @@
|
|||
/**
|
||||
* pskb_trim_unique - remove end from a paged unique (not cloned) buffer
|
||||
* @skb: buffer to alter
|
||||
@@ -1859,16 +1863,6 @@ static inline struct sk_buff *dev_alloc_
|
||||
@@ -1877,16 +1881,6 @@ static inline struct sk_buff *dev_alloc_
|
||||
}
|
||||
|
||||
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARDNAME:=Lantiq GPON/XWAY/SVIP
|
|||
FEATURES:=squashfs jffs2
|
||||
SUBTARGETS=xway ase falcon
|
||||
|
||||
LINUX_VERSION:=3.8.6
|
||||
LINUX_VERSION:=3.8.7
|
||||
|
||||
CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
|
||||
|
||||
|
|
|
@ -14,7 +14,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
|
|||
|
||||
--- a/drivers/mtd/devices/m25p80.c
|
||||
+++ b/drivers/mtd/devices/m25p80.c
|
||||
@@ -827,10 +827,13 @@ static int m25p_probe(struct spi_device
|
||||
@@ -828,10 +828,13 @@ static int m25p_probe(struct spi_device
|
||||
unsigned i;
|
||||
struct mtd_part_parser_data ppdata;
|
||||
struct device_node __maybe_unused *np = spi->dev.of_node;
|
||||
|
@ -28,7 +28,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
|
|||
#endif
|
||||
|
||||
/* Platform data helps sort out which chip type we have, as
|
||||
@@ -906,6 +909,8 @@ static int m25p_probe(struct spi_device
|
||||
@@ -907,6 +910,8 @@ static int m25p_probe(struct spi_device
|
||||
|
||||
if (data && data->name)
|
||||
flash->mtd.name = data->name;
|
||||
|
|
|
@ -12,11 +12,9 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
|
|||
create mode 100644 firmware/lantiq/COPYING
|
||||
create mode 100644 firmware/lantiq/README
|
||||
|
||||
Index: linux-3.8.6/firmware/Makefile
|
||||
===================================================================
|
||||
--- linux-3.8.6.orig/firmware/Makefile 2013-04-05 18:49:06.000000000 +0200
|
||||
+++ linux-3.8.6/firmware/Makefile 2013-04-11 11:25:42.252465469 +0200
|
||||
@@ -134,6 +134,9 @@
|
||||
--- a/firmware/Makefile
|
||||
+++ b/firmware/Makefile
|
||||
@@ -134,6 +134,9 @@ fw-shipped-$(CONFIG_USB_SERIAL_KEYSPAN_P
|
||||
fw-shipped-$(CONFIG_USB_SERIAL_XIRCOM) += keyspan_pda/xircom_pgs.fw
|
||||
fw-shipped-$(CONFIG_USB_VICAM) += vicam/firmware.fw
|
||||
fw-shipped-$(CONFIG_VIDEO_CPIA2) += cpia2/stv0672_vp4.bin
|
||||
|
@ -26,10 +24,8 @@ Index: linux-3.8.6/firmware/Makefile
|
|||
fw-shipped-$(CONFIG_YAM) += yam/1200.bin yam/9600.bin
|
||||
|
||||
fw-shipped-all := $(fw-shipped-y) $(fw-shipped-m) $(fw-shipped-)
|
||||
Index: linux-3.8.6/firmware/lantiq/COPYING
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ linux-3.8.6/firmware/lantiq/COPYING 2013-04-11 10:23:19.408305468 +0200
|
||||
--- /dev/null
|
||||
+++ b/firmware/lantiq/COPYING
|
||||
@@ -0,0 +1,286 @@
|
||||
+All firmware files are copyrighted by Lantiq Deutschland GmbH.
|
||||
+The files have been extracted from header files found in Lantiq BSPs.
|
||||
|
@ -317,10 +313,8 @@ Index: linux-3.8.6/firmware/lantiq/COPYING
|
|||
+POSSIBILITY OF SUCH DAMAGES.
|
||||
+
|
||||
+ END OF TERMS AND CONDITIONS
|
||||
Index: linux-3.8.6/firmware/lantiq/README
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ linux-3.8.6/firmware/lantiq/README 2013-04-11 10:23:19.408305468 +0200
|
||||
--- /dev/null
|
||||
+++ b/firmware/lantiq/README
|
||||
@@ -0,0 +1,45 @@
|
||||
+#
|
||||
+# This program is free software; you can redistribute it and/or
|
||||
|
|
|
@ -4663,7 +4663,7 @@ Subject: [PATCH 30/40] MIPS: lantiq: add pcie driver
|
|||
+
|
||||
--- a/arch/mips/pci/pci.c
|
||||
+++ b/arch/mips/pci/pci.c
|
||||
@@ -249,6 +249,31 @@ static int __init pcibios_init(void)
|
||||
@@ -255,6 +255,31 @@ static int __init pcibios_init(void)
|
||||
|
||||
subsys_initcall(pcibios_init);
|
||||
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- a/drivers/pinctrl/pinctrl-xway.c 2013-04-10 21:51:51.739780800 +0200
|
||||
+++ b/drivers/pinctrl/pinctrl-xway.c 2013-04-10 21:56:47.990049456 +0200
|
||||
--- a/drivers/pinctrl/pinctrl-xway.c
|
||||
+++ b/drivers/pinctrl/pinctrl-xway.c
|
||||
@@ -563,10 +563,9 @@ static struct pinctrl_desc xway_pctrl_de
|
||||
.confops = &xway_pinconf_ops,
|
||||
};
|
||||
|
|
|
@ -12,7 +12,7 @@ SUBTARGETS:=le be le64 be64
|
|||
INITRAMFS_EXTRA_FILES:=
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.8.6
|
||||
LINUX_VERSION:=3.8.7
|
||||
|
||||
DEVICE_TYPE:=developerboard
|
||||
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Freescale MPC52xx
|
|||
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
|
||||
FEATURES:=targz ext4
|
||||
|
||||
LINUX_VERSION:=3.8.6
|
||||
LINUX_VERSION:=3.8.7
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
|
|||
FEATURES:=squashfs targz
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.8.6
|
||||
LINUX_VERSION:=3.8.7
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=8540
|
|||
FEATURES:=spe_fpu squashfs
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.8.6
|
||||
LINUX_VERSION:=3.8.7
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=targz usb jffs2 pci pcie gpio
|
|||
CFLAGS:=-Os -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.8.6
|
||||
LINUX_VERSION:=3.8.7
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ Cc: linux-kernel@vger.kernel.org
|
|||
|
||||
--- a/lib/devres.c
|
||||
+++ b/lib/devres.c
|
||||
@@ -195,6 +195,7 @@ void devm_ioport_unmap(struct device *de
|
||||
@@ -226,6 +226,7 @@ void devm_ioport_unmap(struct device *de
|
||||
devm_ioport_map_match, (void *)addr));
|
||||
}
|
||||
EXPORT_SYMBOL(devm_ioport_unmap);
|
||||
|
@ -21,7 +21,7 @@ Cc: linux-kernel@vger.kernel.org
|
|||
|
||||
#ifdef CONFIG_PCI
|
||||
/*
|
||||
@@ -400,4 +401,3 @@ void pcim_iounmap_regions(struct pci_dev
|
||||
@@ -431,4 +432,3 @@ void pcim_iounmap_regions(struct pci_dev
|
||||
}
|
||||
EXPORT_SYMBOL(pcim_iounmap_regions);
|
||||
#endif /* CONFIG_PCI */
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs
|
|||
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.8.6
|
||||
LINUX_VERSION:=3.8.7
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs broken
|
|||
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.8.6
|
||||
LINUX_VERSION:=3.8.7
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x rt3883
|
|||
CFLAGS:=-Os -pipe -fno-caller-saves -mno-branch-likely
|
||||
FEATURES:=squashfs gpio
|
||||
|
||||
LINUX_VERSION:=3.8.6
|
||||
LINUX_VERSION:=3.8.7
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
DEFAULT_PACKAGES+=\
|
||||
|
|
|
@ -19,11 +19,9 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
|
|||
create mode 100644 arch/mips/include/asm/mach-ralink/rt288x.h
|
||||
create mode 100644 arch/mips/ralink/rt288x.c
|
||||
|
||||
diff --git a/arch/mips/Kconfig b/arch/mips/Kconfig
|
||||
index 27a4bfa..c1997db 100644
|
||||
--- a/arch/mips/Kconfig
|
||||
+++ b/arch/mips/Kconfig
|
||||
@@ -1144,7 +1144,7 @@ config BOOT_ELF32
|
||||
@@ -1189,7 +1189,7 @@ config BOOT_ELF32
|
||||
|
||||
config MIPS_L1_CACHE_SHIFT
|
||||
int
|
||||
|
@ -32,9 +30,6 @@ index 27a4bfa..c1997db 100644
|
|||
default "6" if MIPS_CPU_SCACHE
|
||||
default "7" if SGI_IP22 || SGI_IP27 || SGI_IP28 || SNI_RM || CPU_CAVIUM_OCTEON
|
||||
default "5"
|
||||
diff --git a/arch/mips/include/asm/mach-ralink/rt288x.h b/arch/mips/include/asm/mach-ralink/rt288x.h
|
||||
new file mode 100644
|
||||
index 0000000..ad8b42d
|
||||
--- /dev/null
|
||||
+++ b/arch/mips/include/asm/mach-ralink/rt288x.h
|
||||
@@ -0,0 +1,49 @@
|
||||
|
@ -87,8 +82,6 @@ index 0000000..ad8b42d
|
|||
+#define CLKCFG_SRAM_CS_N_WDT BIT(9)
|
||||
+
|
||||
+#endif
|
||||
diff --git a/arch/mips/ralink/Kconfig b/arch/mips/ralink/Kconfig
|
||||
index a0b0197..6723b94 100644
|
||||
--- a/arch/mips/ralink/Kconfig
|
||||
+++ b/arch/mips/ralink/Kconfig
|
||||
@@ -6,6 +6,9 @@ choice
|
||||
|
@ -101,23 +94,19 @@ index a0b0197..6723b94 100644
|
|||
config SOC_RT305X
|
||||
bool "RT305x"
|
||||
select USB_ARCH_HAS_HCD
|
||||
diff --git a/arch/mips/ralink/Makefile b/arch/mips/ralink/Makefile
|
||||
index 939757f..6d826f2 100644
|
||||
--- a/arch/mips/ralink/Makefile
|
||||
+++ b/arch/mips/ralink/Makefile
|
||||
@@ -8,6 +8,7 @@
|
||||
|
||||
obj-y := prom.o of.o reset.o clk.o irq.o
|
||||
obj-y := prom.o of.o reset.o clk.o irq.o pinmux.o
|
||||
|
||||
+obj-$(CONFIG_SOC_RT288X) += rt288x.o
|
||||
obj-$(CONFIG_SOC_RT305X) += rt305x.o
|
||||
|
||||
obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
|
||||
diff --git a/arch/mips/ralink/Platform b/arch/mips/ralink/Platform
|
||||
index 6babd65..3f49e51 100644
|
||||
--- a/arch/mips/ralink/Platform
|
||||
+++ b/arch/mips/ralink/Platform
|
||||
@@ -5,6 +5,11 @@ core-$(CONFIG_RALINK) += arch/mips/ralink/
|
||||
@@ -5,6 +5,11 @@ core-$(CONFIG_RALINK) += arch/mips/rali
|
||||
cflags-$(CONFIG_RALINK) += -I$(srctree)/arch/mips/include/asm/mach-ralink
|
||||
|
||||
#
|
||||
|
@ -129,9 +118,6 @@ index 6babd65..3f49e51 100644
|
|||
# Ralink RT305x
|
||||
#
|
||||
load-$(CONFIG_SOC_RT305X) += 0xffffffff80000000
|
||||
diff --git a/arch/mips/ralink/rt288x.c b/arch/mips/ralink/rt288x.c
|
||||
new file mode 100644
|
||||
index 0000000..8f3a0fa
|
||||
--- /dev/null
|
||||
+++ b/arch/mips/ralink/rt288x.c
|
||||
@@ -0,0 +1,143 @@
|
||||
|
@ -278,6 +264,3 @@ index 0000000..8f3a0fa
|
|||
+ (id >> CHIP_ID_ID_SHIFT) & CHIP_ID_ID_MASK,
|
||||
+ (id & CHIP_ID_REV_MASK));
|
||||
+}
|
||||
--
|
||||
1.7.10.4
|
||||
|
||||
|
|
|
@ -26,10 +26,8 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
|
|||
create mode 100644 drivers/net/ethernet/ramips/ramips_eth.h
|
||||
create mode 100644 drivers/net/ethernet/ramips/ramips_main.c
|
||||
|
||||
Index: linux-3.8.6/arch/mips/include/asm/mach-ralink/rt305x_esw_platform.h
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ linux-3.8.6/arch/mips/include/asm/mach-ralink/rt305x_esw_platform.h 2013-04-07 14:13:35.688091644 +0200
|
||||
--- /dev/null
|
||||
+++ b/arch/mips/include/asm/mach-ralink/rt305x_esw_platform.h
|
||||
@@ -0,0 +1,27 @@
|
||||
+/*
|
||||
+ * Ralink RT305x SoC platform device registration
|
||||
|
@ -58,11 +56,9 @@ Index: linux-3.8.6/arch/mips/include/asm/mach-ralink/rt305x_esw_platform.h
|
|||
+};
|
||||
+
|
||||
+#endif /* _RT305X_ESW_PLATFORM_H */
|
||||
Index: linux-3.8.6/arch/mips/ralink/rt305x.c
|
||||
===================================================================
|
||||
--- linux-3.8.6.orig/arch/mips/ralink/rt305x.c 2013-04-07 14:13:35.580091641 +0200
|
||||
+++ linux-3.8.6/arch/mips/ralink/rt305x.c 2013-04-07 14:13:35.688091644 +0200
|
||||
@@ -182,6 +182,7 @@
|
||||
--- a/arch/mips/ralink/rt305x.c
|
||||
+++ b/arch/mips/ralink/rt305x.c
|
||||
@@ -182,6 +182,7 @@ void __init ralink_clk_init(void)
|
||||
}
|
||||
|
||||
ralink_clk_add("cpu", cpu_rate);
|
||||
|
@ -70,11 +66,9 @@ Index: linux-3.8.6/arch/mips/ralink/rt305x.c
|
|||
ralink_clk_add("10000b00.spi", sys_rate);
|
||||
ralink_clk_add("10000100.timer", wdt_rate);
|
||||
ralink_clk_add("10000120.watchdog", wdt_rate);
|
||||
Index: linux-3.8.6/drivers/net/ethernet/Kconfig
|
||||
===================================================================
|
||||
--- linux-3.8.6.orig/drivers/net/ethernet/Kconfig 2013-04-05 18:49:06.000000000 +0200
|
||||
+++ linux-3.8.6/drivers/net/ethernet/Kconfig 2013-04-07 14:13:35.688091644 +0200
|
||||
@@ -136,6 +136,7 @@
|
||||
--- a/drivers/net/ethernet/Kconfig
|
||||
+++ b/drivers/net/ethernet/Kconfig
|
||||
@@ -136,6 +136,7 @@ source "drivers/net/ethernet/packetengin
|
||||
source "drivers/net/ethernet/pasemi/Kconfig"
|
||||
source "drivers/net/ethernet/qlogic/Kconfig"
|
||||
source "drivers/net/ethernet/racal/Kconfig"
|
||||
|
@ -82,11 +76,9 @@ Index: linux-3.8.6/drivers/net/ethernet/Kconfig
|
|||
source "drivers/net/ethernet/realtek/Kconfig"
|
||||
source "drivers/net/ethernet/renesas/Kconfig"
|
||||
source "drivers/net/ethernet/rdc/Kconfig"
|
||||
Index: linux-3.8.6/drivers/net/ethernet/Makefile
|
||||
===================================================================
|
||||
--- linux-3.8.6.orig/drivers/net/ethernet/Makefile 2013-04-05 18:49:06.000000000 +0200
|
||||
+++ linux-3.8.6/drivers/net/ethernet/Makefile 2013-04-07 14:13:35.688091644 +0200
|
||||
@@ -54,6 +54,7 @@
|
||||
--- a/drivers/net/ethernet/Makefile
|
||||
+++ b/drivers/net/ethernet/Makefile
|
||||
@@ -54,6 +54,7 @@ obj-$(CONFIG_NET_PACKET_ENGINE) += packe
|
||||
obj-$(CONFIG_NET_VENDOR_PASEMI) += pasemi/
|
||||
obj-$(CONFIG_NET_VENDOR_QLOGIC) += qlogic/
|
||||
obj-$(CONFIG_NET_VENDOR_RACAL) += racal/
|
||||
|
@ -94,10 +86,8 @@ Index: linux-3.8.6/drivers/net/ethernet/Makefile
|
|||
obj-$(CONFIG_NET_VENDOR_REALTEK) += realtek/
|
||||
obj-$(CONFIG_SH_ETH) += renesas/
|
||||
obj-$(CONFIG_NET_VENDOR_RDC) += rdc/
|
||||
Index: linux-3.8.6/drivers/net/ethernet/ramips/Kconfig
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ linux-3.8.6/drivers/net/ethernet/ramips/Kconfig 2013-04-07 14:13:35.688091644 +0200
|
||||
--- /dev/null
|
||||
+++ b/drivers/net/ethernet/ramips/Kconfig
|
||||
@@ -0,0 +1,18 @@
|
||||
+config NET_RAMIPS
|
||||
+ tristate "Ralink RT288X/RT3X5X/RT3662/RT3883 ethernet driver"
|
||||
|
@ -117,10 +107,8 @@ Index: linux-3.8.6/drivers/net/ethernet/ramips/Kconfig
|
|||
+ depends on DEBUG_FS
|
||||
+
|
||||
+endif
|
||||
Index: linux-3.8.6/drivers/net/ethernet/ramips/Makefile
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ linux-3.8.6/drivers/net/ethernet/ramips/Makefile 2013-04-07 14:13:35.688091644 +0200
|
||||
--- /dev/null
|
||||
+++ b/drivers/net/ethernet/ramips/Makefile
|
||||
@@ -0,0 +1,9 @@
|
||||
+#
|
||||
+# Makefile for the Ramips SoCs built-in ethernet macs
|
||||
|
@ -131,10 +119,8 @@ Index: linux-3.8.6/drivers/net/ethernet/ramips/Makefile
|
|||
+ramips-$(CONFIG_NET_RAMIPS_DEBUG_FS) += ramips_debugfs.o
|
||||
+
|
||||
+obj-$(CONFIG_NET_RAMIPS) += ramips.o
|
||||
Index: linux-3.8.6/drivers/net/ethernet/ramips/ramips_debugfs.c
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ linux-3.8.6/drivers/net/ethernet/ramips/ramips_debugfs.c 2013-04-07 14:13:35.688091644 +0200
|
||||
--- /dev/null
|
||||
+++ b/drivers/net/ethernet/ramips/ramips_debugfs.c
|
||||
@@ -0,0 +1,127 @@
|
||||
+/*
|
||||
+ * Ralink SoC ethernet driver debugfs code
|
||||
|
@ -263,10 +249,8 @@ Index: linux-3.8.6/drivers/net/ethernet/ramips/ramips_debugfs.c
|
|||
+ debugfs_remove(raeth_debugfs_root);
|
||||
+ raeth_debugfs_root = NULL;
|
||||
+}
|
||||
Index: linux-3.8.6/drivers/net/ethernet/ramips/ramips_esw.c
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ linux-3.8.6/drivers/net/ethernet/ramips/ramips_esw.c 2013-04-07 16:16:56.172408006 +0200
|
||||
--- /dev/null
|
||||
+++ b/drivers/net/ethernet/ramips/ramips_esw.c
|
||||
@@ -0,0 +1,1221 @@
|
||||
+#include <linux/ioport.h>
|
||||
+#include <linux/switch.h>
|
||||
|
@ -1489,10 +1473,8 @@ Index: linux-3.8.6/drivers/net/ethernet/ramips/ramips_esw.c
|
|||
+{
|
||||
+ platform_driver_unregister(&rt305x_esw_driver);
|
||||
+}
|
||||
Index: linux-3.8.6/drivers/net/ethernet/ramips/ramips_eth.h
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ linux-3.8.6/drivers/net/ethernet/ramips/ramips_eth.h 2013-04-07 14:13:35.688091644 +0200
|
||||
--- /dev/null
|
||||
+++ b/drivers/net/ethernet/ramips/ramips_eth.h
|
||||
@@ -0,0 +1,375 @@
|
||||
+/*
|
||||
+ * This program is free software; you can redistribute it and/or modify
|
||||
|
@ -1869,10 +1851,8 @@ Index: linux-3.8.6/drivers/net/ethernet/ramips/ramips_eth.h
|
|||
+#endif /* CONFIG_NET_RAMIPS_DEBUG_FS */
|
||||
+
|
||||
+#endif /* RAMIPS_ETH_H */
|
||||
Index: linux-3.8.6/drivers/net/ethernet/ramips/ramips_main.c
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ linux-3.8.6/drivers/net/ethernet/ramips/ramips_main.c 2013-04-07 14:13:35.688091644 +0200
|
||||
--- /dev/null
|
||||
+++ b/drivers/net/ethernet/ramips/ramips_main.c
|
||||
@@ -0,0 +1,1285 @@
|
||||
+/*
|
||||
+ * This program is free software; you can redistribute it and/or modify
|
||||
|
|
|
@ -10,8 +10,6 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
|
|||
arch/mips/ralink/early_printk.c | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/arch/mips/ralink/early_printk.c b/arch/mips/ralink/early_printk.c
|
||||
index c4ae47e..b46d041 100644
|
||||
--- a/arch/mips/ralink/early_printk.c
|
||||
+++ b/arch/mips/ralink/early_printk.c
|
||||
@@ -11,7 +11,11 @@
|
||||
|
@ -26,6 +24,3 @@ index c4ae47e..b46d041 100644
|
|||
|
||||
#define UART_REG_RX 0x00
|
||||
#define UART_REG_TX 0x04
|
||||
--
|
||||
1.7.10.4
|
||||
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=rb532
|
|||
BOARDNAME:=Mikrotik RouterBoard 532
|
||||
FEATURES:=jffs2 pci targz broken
|
||||
|
||||
LINUX_VERSION:=3.8.6
|
||||
LINUX_VERSION:=3.8.7
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=fpu ramdisk
|
|||
CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.8.6
|
||||
LINUX_VERSION:=3.8.7
|
||||
|
||||
DEVICE_TYPE:=developerboard
|
||||
|
||||
|
|
|
@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
|
|||
FEATURES:=ext4 audio
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.8.6
|
||||
LINUX_VERSION:=3.8.7
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -19,7 +19,7 @@ DEFAULT_PACKAGES += \
|
|||
kmod-ledtrig-heartbeat kmod-ledtrig-gpio \
|
||||
kmod-ledtrig-netdev \
|
||||
kmod-cpu-msr hwclock wpad
|
||||
LINUX_VERSION:=3.8.6
|
||||
LINUX_VERSION:=3.8.7
|
||||
CS5535_MASK:=0x0b000042
|
||||
|
||||
CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
BOARDNAME:=Generic
|
||||
|
||||
LINUX_VERSION:=3.8.6
|
||||
LINUX_VERSION:=3.8.7
|
||||
|
||||
define Target/Description
|
||||
Build firmware images for x86 based boards
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Ingenic XBurst
|
|||
FEATURES:=jffs2 targz ubifs audio broken
|
||||
SUBTARGETS:=qi_lb60 n516 n526 id800wt
|
||||
|
||||
LINUX_VERSION:=3.8.6
|
||||
LINUX_VERSION:=3.8.7
|
||||
|
||||
DEVICE_TYPE=other
|
||||
|
||||
|
|
Loading…
Reference in New Issue