upgrade hostapd to 0.5.7 (patch from #1133)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6047 3c298f89-4303-0410-b956-a3cf2f4a3e73master
parent
bd078bad0f
commit
8a9a6d62b4
|
@ -9,12 +9,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=hostapd
|
PKG_NAME:=hostapd
|
||||||
PKG_VERSION:=0.5.5
|
PKG_VERSION:=0.5.7
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://hostap.epitest.fi/releases/
|
PKG_SOURCE_URL:=http://hostap.epitest.fi/releases/
|
||||||
PKG_MD5SUM:=92288aeb2b90c0c81ae3f50beff9b890
|
PKG_MD5SUM:=d5113247dc6ee17106e6bc7cb89aa507
|
||||||
PKG_CAT:=zcat
|
PKG_CAT:=zcat
|
||||||
|
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||||
|
|
|
@ -1,40 +1,40 @@
|
||||||
diff -ur hostapd.old/driver_madwifi.c hostapd.dev/driver_madwifi.c
|
--- hostapd-0.5.7.orig/driver_madwifi.c 2006-11-25 02:16:56.000000000 +0100
|
||||||
--- hostapd.old/driver_madwifi.c 2006-03-25 20:55:18.000000000 +0100
|
+++ hostapd-0.5.7/driver_madwifi.c 2007-01-06 15:58:23.761503234 +0100
|
||||||
+++ hostapd.dev/driver_madwifi.c 2006-06-12 21:54:22.000000000 +0200
|
@@ -21,12 +21,9 @@
|
||||||
@@ -20,11 +20,6 @@
|
|
||||||
|
|
||||||
#include <include/compat.h>
|
#include <include/compat.h>
|
||||||
#include <net80211/ieee80211.h>
|
#include <net80211/ieee80211.h>
|
||||||
-#ifdef WME_NUM_AC
|
#ifdef WME_NUM_AC
|
||||||
-/* Assume this is built against BSD branch of madwifi driver. */
|
-/* Assume this is built against BSD branch of madwifi driver. */
|
||||||
-#define MADWIFI_BSD
|
-#define MADWIFI_BSD
|
||||||
-#include <net80211/_ieee80211.h>
|
-#include <net80211/_ieee80211.h>
|
||||||
-#endif /* WME_NUM_AC */
|
-#endif /* WME_NUM_AC */
|
||||||
#include <net80211/ieee80211_crypto.h>
|
#include <net80211/ieee80211_crypto.h>
|
||||||
#include <net80211/ieee80211_ioctl.h>
|
#include <net80211/ieee80211_ioctl.h>
|
||||||
|
+#endif /* WME_NUM_AC */
|
||||||
|
|
||||||
@@ -168,7 +164,10 @@
|
#ifdef IEEE80211_IOCTL_SETWMMPARAMS
|
||||||
}
|
/* Assume this is built against madwifi-ng */
|
||||||
|
@@ -169,6 +166,11 @@
|
||||||
return 0;
|
return 0;
|
||||||
}
|
}
|
||||||
-
|
|
||||||
+static int madwifi_get_inact_sec(void *priv, const u8 *addr)
|
+static int madwifi_get_inact_sec(void *priv, const u8 *addr)
|
||||||
+{
|
+{
|
||||||
+return 0;
|
+ return 0;
|
||||||
+}
|
+}
|
||||||
|
+
|
||||||
static int
|
static int
|
||||||
set80211param(struct madwifi_driver_data *drv, int op, int arg)
|
set80211param(struct madwifi_driver_data *drv, int op, int arg)
|
||||||
{
|
{
|
||||||
@@ -1204,8 +1203,6 @@
|
@@ -1258,7 +1260,6 @@
|
||||||
goto bad;
|
goto bad;
|
||||||
}
|
}
|
||||||
|
|
||||||
- madwifi_set_iface_flags(drv, 0); /* mark down during setup */
|
- madwifi_set_iface_flags(drv, 0); /* mark down during setup */
|
||||||
-
|
madwifi_set_privacy(drv->iface, drv, 0); /* default to no privacy */
|
||||||
|
|
||||||
hapd->driver = &drv->ops;
|
hapd->driver = &drv->ops;
|
||||||
return 0;
|
@@ -1281,7 +1282,6 @@
|
||||||
bad:
|
|
||||||
@@ -1226,7 +1223,6 @@
|
|
||||||
|
|
||||||
drv->hapd->driver = NULL;
|
drv->hapd->driver = NULL;
|
||||||
|
|
||||||
|
@ -42,11 +42,11 @@ diff -ur hostapd.old/driver_madwifi.c hostapd.dev/driver_madwifi.c
|
||||||
if (drv->ioctl_sock >= 0)
|
if (drv->ioctl_sock >= 0)
|
||||||
close(drv->ioctl_sock);
|
close(drv->ioctl_sock);
|
||||||
if (drv->sock_recv != NULL && drv->sock_recv != drv->sock_xmit)
|
if (drv->sock_recv != NULL && drv->sock_recv != drv->sock_xmit)
|
||||||
@@ -1306,6 +1452,7 @@
|
@@ -1367,6 +1367,7 @@
|
||||||
.get_ssid = madwifi_get_ssid,
|
.get_ssid = madwifi_get_ssid,
|
||||||
.set_countermeasures = madwifi_set_countermeasures,
|
.set_countermeasures = madwifi_set_countermeasures,
|
||||||
.sta_clear_stats = madwifi_sta_clear_stats,
|
.sta_clear_stats = madwifi_sta_clear_stats,
|
||||||
+ .get_inact_sec = madwifi_get_inact_sec,
|
+ .get_inact_sec = madwifi_get_inact_sec,
|
||||||
|
.commit = madwifi_commit,
|
||||||
};
|
};
|
||||||
|
|
||||||
void madwifi_driver_register(void)
|
|
||||||
|
|
Loading…
Reference in New Issue