Enabled working ar7_wdt, style cleanups
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8764 3c298f89-4303-0410-b956-a3cf2f4a3e73master
parent
044c76f119
commit
8a62330b65
|
@ -3,7 +3,7 @@ CONFIG_32BIT=y
|
||||||
# CONFIG_64BIT_PHYS_ADDR is not set
|
# CONFIG_64BIT_PHYS_ADDR is not set
|
||||||
CONFIG_AR7=y
|
CONFIG_AR7=y
|
||||||
CONFIG_AR7_GPIO=y
|
CONFIG_AR7_GPIO=y
|
||||||
# CONFIG_AR7_WDT is not set
|
CONFIG_AR7_WDT=y
|
||||||
# CONFIG_ARCH_HAS_ILOG2_U32 is not set
|
# CONFIG_ARCH_HAS_ILOG2_U32 is not set
|
||||||
# CONFIG_ARCH_HAS_ILOG2_U64 is not set
|
# CONFIG_ARCH_HAS_ILOG2_U64 is not set
|
||||||
# CONFIG_ARCH_SUPPORTS_MSI is not set
|
# CONFIG_ARCH_SUPPORTS_MSI is not set
|
||||||
|
|
|
@ -133,7 +133,8 @@ static inline u32 vlynq_get_mapped(struct vlynq_device *dev, int res)
|
||||||
return ret;
|
return ret;
|
||||||
}
|
}
|
||||||
|
|
||||||
static inline u32 vlynq_read(u32 val, int size) {
|
static inline u32 vlynq_read(u32 val, int size)
|
||||||
|
{
|
||||||
switch (size) {
|
switch (size) {
|
||||||
case 1:
|
case 1:
|
||||||
return *(u8 *)&val;
|
return *(u8 *)&val;
|
||||||
|
|
|
@ -438,8 +438,10 @@ void vlynq_set_local_mapping(struct vlynq_device *dev, u32 tx_offset,
|
||||||
|
|
||||||
vlynq_reg_write(dev->local->tx_offset, tx_offset);
|
vlynq_reg_write(dev->local->tx_offset, tx_offset);
|
||||||
for (i = 0; i < 4; i++) {
|
for (i = 0; i < 4; i++) {
|
||||||
vlynq_reg_write(dev->local->rx_mapping[i].offset, mapping[i].offset);
|
vlynq_reg_write(dev->local->rx_mapping[i].offset,
|
||||||
vlynq_reg_write(dev->local->rx_mapping[i].size, mapping[i].size);
|
mapping[i].offset);
|
||||||
|
vlynq_reg_write(dev->local->rx_mapping[i].size,
|
||||||
|
mapping[i].size);
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -450,8 +452,10 @@ void vlynq_set_remote_mapping(struct vlynq_device *dev, u32 tx_offset,
|
||||||
|
|
||||||
vlynq_reg_write(dev->remote->tx_offset, tx_offset);
|
vlynq_reg_write(dev->remote->tx_offset, tx_offset);
|
||||||
for (i = 0; i < 4; i++) {
|
for (i = 0; i < 4; i++) {
|
||||||
vlynq_reg_write(dev->remote->rx_mapping[i].offset, mapping[i].offset);
|
vlynq_reg_write(dev->remote->rx_mapping[i].offset,
|
||||||
vlynq_reg_write(dev->remote->rx_mapping[i].size, mapping[i].size);
|
mapping[i].offset);
|
||||||
|
vlynq_reg_write(dev->remote->rx_mapping[i].size,
|
||||||
|
mapping[i].size);
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
|
|
||||||
|
|
|
@ -55,8 +55,8 @@ static int nowayout = WATCHDOG_NOWAYOUT;
|
||||||
module_param(nowayout, int, 0);
|
module_param(nowayout, int, 0);
|
||||||
MODULE_PARM_DESC(nowayout, "Disable watchdog shutdown on close");
|
MODULE_PARM_DESC(nowayout, "Disable watchdog shutdown on close");
|
||||||
|
|
||||||
#define READ_REG(x) readl((void __iomem*)&(x))
|
#define READ_REG(x) readl((void __iomem *)&(x))
|
||||||
#define WRITE_REG(x,v) writel((v), (void __iomem*)&(x))
|
#define WRITE_REG(x, v) writel((v), (void __iomem *)&(x))
|
||||||
|
|
||||||
struct ar7_wdt {
|
struct ar7_wdt {
|
||||||
u32 kick_lock;
|
u32 kick_lock;
|
||||||
|
|
|
@ -137,5 +137,6 @@ static int __init ar7_parser_init(void)
|
||||||
module_init(ar7_parser_init);
|
module_init(ar7_parser_init);
|
||||||
|
|
||||||
MODULE_LICENSE("GPL");
|
MODULE_LICENSE("GPL");
|
||||||
MODULE_AUTHOR("Felix Fietkau <nbd@openwrt.org>, Eugene Konev <ejka@openwrt.org>");
|
MODULE_AUTHOR( "Felix Fietkau <nbd@openwrt.org>, "
|
||||||
|
"Eugene Konev <ejka@openwrt.org>");
|
||||||
MODULE_DESCRIPTION("MTD partitioning for TI AR7");
|
MODULE_DESCRIPTION("MTD partitioning for TI AR7");
|
||||||
|
|
|
@ -20,8 +20,8 @@
|
||||||
#define _ASM_MACH_MMZONE_H
|
#define _ASM_MACH_MMZONE_H
|
||||||
|
|
||||||
extern pg_data_t __node_data[];
|
extern pg_data_t __node_data[];
|
||||||
#define NODE_DATA(nid) (&__node_data[nid])
|
#define NODE_DATA(nid) (&__node_data[nid])
|
||||||
#define NODE_MEM_MAP(nid) (NODE_DATA(nid)->node_mem_map)
|
#define NODE_MEM_MAP(nid) (NODE_DATA(nid)->node_mem_map)
|
||||||
#define pa_to_nid(addr) (((addr) >= ARCH_PFN_OFFSET << PAGE_SHIFT) ? 0 : -1)
|
#define pa_to_nid(addr) (((addr) >= ARCH_PFN_OFFSET << PAGE_SHIFT) ? 0 : -1)
|
||||||
|
|
||||||
#endif /* _ASM_MACH_MMZONE_H */
|
#endif /* _ASM_MACH_MMZONE_H */
|
||||||
|
|
|
@ -28,12 +28,13 @@ diff -Nru linux-2.6.19.2/drivers/mtd/Makefile linux-ar7/drivers/mtd/Makefile
|
||||||
diff -Nru linux-2.6.19.2/drivers/mtd/maps/physmap.c linux-ar7/drivers/mtd/maps/physmap.c
|
diff -Nru linux-2.6.19.2/drivers/mtd/maps/physmap.c linux-ar7/drivers/mtd/maps/physmap.c
|
||||||
--- linux-2.6.19.2/drivers/mtd/maps/physmap.c 2006-12-12 02:32:53.000000000 +0700
|
--- linux-2.6.19.2/drivers/mtd/maps/physmap.c 2006-12-12 02:32:53.000000000 +0700
|
||||||
+++ linux-ar7/drivers/mtd/maps/physmap.c 2007-02-03 21:57:11.000000000 +0700
|
+++ linux-ar7/drivers/mtd/maps/physmap.c 2007-02-03 21:57:11.000000000 +0700
|
||||||
@@ -74,7 +74,7 @@
|
@@ -74,7 +74,8 @@
|
||||||
|
|
||||||
static const char *rom_probe_types[] = { "cfi_probe", "jedec_probe", "map_rom", NULL };
|
static const char *rom_probe_types[] = { "cfi_probe", "jedec_probe", "map_rom", NULL };
|
||||||
#ifdef CONFIG_MTD_PARTITIONS
|
#ifdef CONFIG_MTD_PARTITIONS
|
||||||
-static const char *part_probe_types[] = { "cmdlinepart", "RedBoot", NULL };
|
-static const char *part_probe_types[] = { "cmdlinepart", "RedBoot", NULL };
|
||||||
+static const char *part_probe_types[] = { "cmdlinepart", "RedBoot", "ar7part", NULL };
|
+static const char *part_probe_types[] = {"cmdlinepart", "RedBoot",
|
||||||
|
+ "ar7part", NULL };
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
static int physmap_flash_probe(struct platform_device *dev)
|
static int physmap_flash_probe(struct platform_device *dev)
|
||||||
|
|
|
@ -38,13 +38,14 @@ diff -urN linux-2.6.22.orig/include/linux/serial_core.h linux-2.6.22/include/lin
|
||||||
diff -urN linux-2.6.22.orig/include/linux/serialP.h linux-2.6.22/include/linux/serialP.h
|
diff -urN linux-2.6.22.orig/include/linux/serialP.h linux-2.6.22/include/linux/serialP.h
|
||||||
--- linux-2.6.22.orig/include/linux/serialP.h 2007-07-09 01:32:17.000000000 +0200
|
--- linux-2.6.22.orig/include/linux/serialP.h 2007-07-09 01:32:17.000000000 +0200
|
||||||
+++ linux-2.6.22/include/linux/serialP.h 2007-07-11 03:08:57.000000000 +0200
|
+++ linux-2.6.22/include/linux/serialP.h 2007-07-11 03:08:57.000000000 +0200
|
||||||
@@ -135,6 +135,9 @@
|
@@ -135,6 +135,10 @@
|
||||||
* the interrupt line _up_ instead of down, so if we register the IRQ
|
* the interrupt line _up_ instead of down, so if we register the IRQ
|
||||||
* while the UART is in that state, we die in an IRQ storm. */
|
* while the UART is in that state, we die in an IRQ storm. */
|
||||||
#define ALPHA_KLUDGE_MCR (UART_MCR_OUT2)
|
#define ALPHA_KLUDGE_MCR (UART_MCR_OUT2)
|
||||||
+#elif defined(CONFIG_AR7)
|
+#elif defined(CONFIG_AR7)
|
||||||
+/* This is how it is set up by bootloader... */
|
+/* This is how it is set up by bootloader... */
|
||||||
+#define ALPHA_KLUDGE_MCR (UART_MCR_OUT2 | UART_MCR_OUT1 | UART_MCR_RTS | UART_MCR_DTR)
|
+#define ALPHA_KLUDGE_MCR (UART_MCR_OUT2 | UART_MCR_OUT1 \
|
||||||
|
+ | UART_MCR_RTS | UART_MCR_DTR)
|
||||||
#else
|
#else
|
||||||
#define ALPHA_KLUDGE_MCR 0
|
#define ALPHA_KLUDGE_MCR 0
|
||||||
#endif
|
#endif
|
||||||
|
|
Loading…
Reference in New Issue