[package] grub: fix potential build issues on redhat/fedora host systems (should close: #3793)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15608 3c298f89-4303-0410-b956-a3cf2f4a3e73master
parent
8d222ed479
commit
74f9a035ae
|
@ -1,5 +1,5 @@
|
||||||
#
|
#
|
||||||
# Copyright (C) 2006-2008 OpenWrt.org
|
# Copyright (C) 2006-2009 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
|
@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
|
||||||
|
|
||||||
PKG_NAME:=grub
|
PKG_NAME:=grub
|
||||||
PKG_VERSION:=0.97
|
PKG_VERSION:=0.97
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=2
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=ftp://alpha.gnu.org/gnu/grub
|
PKG_SOURCE_URL:=ftp://alpha.gnu.org/gnu/grub
|
||||||
|
|
|
@ -0,0 +1,22 @@
|
||||||
|
--- a/stage1/Makefile.in
|
||||||
|
+++ b/stage1/Makefile.in
|
||||||
|
@@ -427,7 +427,7 @@ uninstall-am: uninstall-info-am uninstal
|
||||||
|
uninstall-nodist_pkglibDATA
|
||||||
|
|
||||||
|
.exec:
|
||||||
|
- $(OBJCOPY) -O binary $< $@
|
||||||
|
+ $(OBJCOPY) -O binary -R .comment -R .note -R .note.gnu.build-id $< $@
|
||||||
|
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
||||||
|
# Otherwise a system limit (for SysV at least) may be exceeded.
|
||||||
|
.NOEXPORT:
|
||||||
|
--- a/stage2/Makefile.in
|
||||||
|
+++ b/stage2/Makefile.in
|
||||||
|
@@ -3244,7 +3244,7 @@ pxegrub: pxeloader diskless
|
||||||
|
-rm -f $@
|
||||||
|
cat $^ > $@
|
||||||
|
.exec:
|
||||||
|
- $(OBJCOPY) -O binary $< $@
|
||||||
|
+ $(OBJCOPY) -O binary -R .comment -R .note -R .note.gnu.build-id $< $@
|
||||||
|
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
||||||
|
# Otherwise a system limit (for SysV at least) may be exceeded.
|
||||||
|
.NOEXPORT:
|
Loading…
Reference in New Issue