[tools] cmake: upgrade to 2.8.12

Signed-off-by: Luka Perkov <luka@openwrt.org>

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38457 3c298f89-4303-0410-b956-a3cf2f4a3e73
master
Luka Perkov 2013-10-18 23:38:26 +00:00
parent 0cbcc1e6b2
commit 66f724f3ad
2 changed files with 10 additions and 6 deletions

View File

@ -7,11 +7,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=cmake
PKG_VERSION:=2.8.11.2
PKG_VERSION:=2.8.12
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.cmake.org/files/v2.8/
PKG_MD5SUM:=6f5d7b8e7534a5d9e1a7664ba63cf882
PKG_MD5SUM:=105bc6d21cc2e9b6aff901e43c53afea
HOST_BUILD_PARALLEL:=1
HOST_CONFIGURE_PARALLEL:=1

View File

@ -1,21 +1,25 @@
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
@@ -76,12 +76,6 @@ add_RunCMake_test(include_directories)
add_RunCMake_test(list)
add_RunCMake_test(CMP0004)
@@ -101,16 +101,6 @@
add_RunCMake_test(TargetPolicies)
add_RunCMake_test(alias_targets)
-find_package(Qt4 QUIET)
-find_package(Qt5Core QUIET)
-if (QT4_FOUND AND Qt5Core_FOUND AND NOT Qt5Core_VERSION VERSION_LESS 5.1.0)
- add_RunCMake_test(IncompatibleQt)
-endif()
-if (QT4_FOUND)
- set(ObsoleteQtMacros_ARGS -DQT_QMAKE_EXECUTABLE:FILEPATH=${QT_QMAKE_EXECUTABLE})
- add_RunCMake_test(ObsoleteQtMacros)
-endif()
-
if("${CMAKE_TEST_GENERATOR}" MATCHES "Visual Studio [^6]")
add_RunCMake_test(include_external_msproject)
add_RunCMake_test(SolutionGlobalSections)
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -259,10 +259,6 @@ if(BUILD_TESTING)
@@ -262,10 +262,6 @@
list(APPEND TEST_BUILD_DIRS ${CMake_TEST_INSTALL_PREFIX})