target/linux: refresh 2.6.32 patches

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21566 3c298f89-4303-0410-b956-a3cf2f4a3e73
master
Nicolas Thill 2010-05-24 20:35:46 +00:00
parent cfbeeb7b85
commit 6598259ef5
42 changed files with 142 additions and 171 deletions

View File

@ -6,11 +6,9 @@
Signed-off-by: Florian Fainelli <florian@openwrt.org> Signed-off-by: Florian Fainelli <florian@openwrt.org>
Index: linux-2.6.32.12/arch/mips/ar7/platform.c --- a/arch/mips/ar7/platform.c
=================================================================== +++ b/arch/mips/ar7/platform.c
--- linux-2.6.32.12.orig/arch/mips/ar7/platform.c 2010-05-15 18:01:11.000000000 +0200 @@ -509,7 +509,7 @@ static int __init ar7_register_devices(v
+++ linux-2.6.32.12/arch/mips/ar7/platform.c 2010-05-15 18:02:44.000000000 +0200
@@ -509,7 +509,7 @@
memset(uart_port, 0, sizeof(struct uart_port) * 2); memset(uart_port, 0, sizeof(struct uart_port) * 2);
@ -19,7 +17,7 @@ Index: linux-2.6.32.12/arch/mips/ar7/platform.c
uart_port[0].line = 0; uart_port[0].line = 0;
uart_port[0].irq = AR7_IRQ_UART0; uart_port[0].irq = AR7_IRQ_UART0;
uart_port[0].uartclk = ar7_bus_freq() / 2; uart_port[0].uartclk = ar7_bus_freq() / 2;
@@ -524,7 +524,7 @@ @@ -524,7 +524,7 @@ static int __init ar7_register_devices(v
/* Only TNETD73xx have a second serial port */ /* Only TNETD73xx have a second serial port */
if (ar7_has_second_uart()) { if (ar7_has_second_uart()) {

View File

@ -30,7 +30,7 @@
depends on USB_OHCI_HCD && (STB03xxx || PPC_MPC52xx) depends on USB_OHCI_HCD && (STB03xxx || PPC_MPC52xx)
--- a/drivers/usb/host/ehci-hcd.c --- a/drivers/usb/host/ehci-hcd.c
+++ b/drivers/usb/host/ehci-hcd.c +++ b/drivers/usb/host/ehci-hcd.c
@@ -1141,6 +1141,11 @@ MODULE_LICENSE ("GPL"); @@ -1142,6 +1142,11 @@ MODULE_LICENSE ("GPL");
#define PLATFORM_DRIVER ehci_atmel_driver #define PLATFORM_DRIVER ehci_atmel_driver
#endif #endif

View File

@ -12,7 +12,7 @@
/* makes sure the async qh will become idle */ /* makes sure the async qh will become idle */
--- a/drivers/usb/host/ehci.h --- a/drivers/usb/host/ehci.h
+++ b/drivers/usb/host/ehci.h +++ b/drivers/usb/host/ehci.h
@@ -129,6 +129,7 @@ struct ehci_hcd { /* one per controlle @@ -130,6 +130,7 @@ struct ehci_hcd { /* one per controlle
unsigned has_amcc_usb23:1; unsigned has_amcc_usb23:1;
unsigned need_io_watchdog:1; unsigned need_io_watchdog:1;
unsigned broken_periodic:1; unsigned broken_periodic:1;

View File

@ -164,7 +164,7 @@ Signed-off-by: Maxime Bizon <mbizon@freebox.fr>
+MODULE_ALIAS("platform:bcm63xx_ehci"); +MODULE_ALIAS("platform:bcm63xx_ehci");
--- a/drivers/usb/host/ehci-hcd.c --- a/drivers/usb/host/ehci-hcd.c
+++ b/drivers/usb/host/ehci-hcd.c +++ b/drivers/usb/host/ehci-hcd.c
@@ -1141,6 +1141,11 @@ MODULE_LICENSE ("GPL"); @@ -1142,6 +1142,11 @@ MODULE_LICENSE ("GPL");
#define PLATFORM_DRIVER ehci_atmel_driver #define PLATFORM_DRIVER ehci_atmel_driver
#endif #endif

View File

@ -11,7 +11,7 @@
static struct gpio_led_platform_data bcm63xx_led_data; static struct gpio_led_platform_data bcm63xx_led_data;
static struct platform_device bcm63xx_gpio_leds = { static struct platform_device bcm63xx_gpio_leds = {
@@ -853,6 +857,8 @@ int __init board_register_devices(void) @@ -854,6 +858,8 @@ int __init board_register_devices(void)
platform_device_register(&mtd_dev); platform_device_register(&mtd_dev);

View File

@ -79,4 +79,4 @@
+ struct gpio_led leds[8]; + struct gpio_led leds[8];
/* Buttons */ /* Buttons */
struct gpio_button buttons[1]; struct gpio_button buttons[2];

View File

@ -16,7 +16,7 @@
}; };
static struct board_info __initdata board_rta1025w_16 = { static struct board_info __initdata board_rta1025w_16 = {
@@ -949,6 +951,9 @@ int __init board_register_devices(void) @@ -950,6 +952,9 @@ int __init board_register_devices(void)
if (board.has_dsp) if (board.has_dsp)
bcm63xx_dsp_register(&board.dsp); bcm63xx_dsp_register(&board.dsp);

View File

@ -937,7 +937,7 @@
obj-y += boards/ obj-y += boards/
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
@@ -29,6 +29,7 @@ @@ -30,6 +30,7 @@
#include <bcm63xx_dev_usb_ohci.h> #include <bcm63xx_dev_usb_ohci.h>
#include <bcm63xx_dev_usb_ehci.h> #include <bcm63xx_dev_usb_ehci.h>
#include <bcm63xx_dev_usb_udc.h> #include <bcm63xx_dev_usb_udc.h>
@ -945,7 +945,7 @@
#include <board_bcm963xx.h> #include <board_bcm963xx.h>
#define PFX "board_bcm963xx: " #define PFX "board_bcm963xx: "
@@ -998,6 +999,9 @@ int __init board_register_devices(void) @@ -1495,6 +1496,9 @@ int __init board_register_devices(void)
if (board.has_udc0) if (board.has_udc0)
bcm63xx_udc_register(); bcm63xx_udc_register();

View File

@ -1,6 +1,6 @@
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
@@ -1308,6 +1308,8 @@ void __init board_prom_init(void) @@ -1338,6 +1338,8 @@ void __init board_prom_init(void)
if (BCMCPU_IS_6348()) if (BCMCPU_IS_6348())
val |= GPIO_MODE_6348_G3_EXT_MII | val |= GPIO_MODE_6348_G3_EXT_MII |
GPIO_MODE_6348_G0_EXT_MII; GPIO_MODE_6348_G0_EXT_MII;

View File

@ -1,8 +1,6 @@
Index: linux-2.6.32.12/drivers/usb/host/ehci-hub.c --- a/drivers/usb/host/ehci-hub.c
=================================================================== +++ b/drivers/usb/host/ehci-hub.c
--- linux-2.6.32.12.orig/drivers/usb/host/ehci-hub.c 2010-05-02 21:06:45.000000000 +0200 @@ -741,11 +741,13 @@ static int ehci_hub_control (
+++ linux-2.6.32.12/drivers/usb/host/ehci-hub.c 2010-05-02 21:07:08.000000000 +0200
@@ -741,11 +741,13 @@
* power switching; they're allowed to just limit the * power switching; they're allowed to just limit the
* current. khubd will turn the power back on. * current. khubd will turn the power back on.
*/ */

View File

@ -26,7 +26,7 @@
1: mcr p15, 0, r0, c1, c0, 0 @ load control register 1: mcr p15, 0, r0, c1, c0, 0 @ load control register
mrc p15, 0, r0, c1, c0, 0 @ and read it back to mrc p15, 0, r0, c1, c0, 0 @ and read it back to
sub pc, lr, r0, lsr #32 @ properly flush pipeline sub pc, lr, r0, lsr #32 @ properly flush pipeline
@@ -539,7 +540,7 @@ __common_mmu_cache_on: @@ -538,7 +539,7 @@ __common_mmu_cache_on:
* r8 = atags pointer * r8 = atags pointer
* r9-r12,r14 = corrupted * r9-r12,r14 = corrupted
*/ */
@ -35,8 +35,8 @@
reloc_start: add r9, r5, r0 reloc_start: add r9, r5, r0
sub r9, r9, #128 @ do not copy the stack sub r9, r9, #128 @ do not copy the stack
debug_reloc_start debug_reloc_start
@@ -768,7 +769,7 @@ proc_types: @@ -766,7 +767,7 @@ proc_types:
* On exit, r0, r1, r2, r3, r12 corrupted * On exit, r0, r1, r2, r3, r9, r12 corrupted
* This routine must preserve: r4, r6, r7 * This routine must preserve: r4, r6, r7
*/ */
- .align 5 - .align 5
@ -44,7 +44,7 @@
cache_off: mov r3, #12 @ cache_off function cache_off: mov r3, #12 @ cache_off function
b call_cache_fn b call_cache_fn
@@ -845,7 +846,7 @@ __armv3_mmu_cache_off: @@ -841,7 +842,7 @@ __armv3_mmu_cache_off:
* This routine must preserve: * This routine must preserve:
* r0, r4, r5, r6, r7 * r0, r4, r5, r6, r7
*/ */
@ -4640,7 +4640,7 @@
} }
/* ehci_shutdown kick in for silicon on any bus (not just pci, etc). /* ehci_shutdown kick in for silicon on any bus (not just pci, etc).
@@ -653,7 +656,9 @@ static int ehci_run (struct usb_hcd *hcd @@ -654,7 +657,9 @@ static int ehci_run (struct usb_hcd *hcd
// Philips, Intel, and maybe others need CMD_RUN before the // Philips, Intel, and maybe others need CMD_RUN before the
// root hub will detect new devices (why?); NEC doesn't // root hub will detect new devices (why?); NEC doesn't
ehci->command &= ~(CMD_LRESET|CMD_IAAD|CMD_PSE|CMD_ASE|CMD_RESET); ehci->command &= ~(CMD_LRESET|CMD_IAAD|CMD_PSE|CMD_ASE|CMD_RESET);
@ -4650,7 +4650,7 @@
ehci_writel(ehci, ehci->command, &ehci->regs->command); ehci_writel(ehci, ehci->command, &ehci->regs->command);
dbg_cmd (ehci, "init", ehci->command); dbg_cmd (ehci, "init", ehci->command);
@@ -673,9 +678,11 @@ static int ehci_run (struct usb_hcd *hcd @@ -674,9 +679,11 @@ static int ehci_run (struct usb_hcd *hcd
*/ */
down_write(&ehci_cf_port_reset_rwsem); down_write(&ehci_cf_port_reset_rwsem);
hcd->state = HC_STATE_RUNNING; hcd->state = HC_STATE_RUNNING;
@ -4662,7 +4662,7 @@
up_write(&ehci_cf_port_reset_rwsem); up_write(&ehci_cf_port_reset_rwsem);
ehci->last_periodic_enable = ktime_get_real(); ehci->last_periodic_enable = ktime_get_real();
@@ -767,9 +774,10 @@ static irqreturn_t ehci_irq (struct usb_ @@ -768,9 +775,10 @@ static irqreturn_t ehci_irq (struct usb_
pcd_status = status; pcd_status = status;
/* resume root hub? */ /* resume root hub? */
@ -4674,7 +4674,7 @@
while (i--) { while (i--) {
int pstatus = ehci_readl(ehci, int pstatus = ehci_readl(ehci,
&ehci->regs->port_status [i]); &ehci->regs->port_status [i]);
@@ -802,7 +810,9 @@ static irqreturn_t ehci_irq (struct usb_ @@ -803,7 +811,9 @@ static irqreturn_t ehci_irq (struct usb_
ehci_halt(ehci); ehci_halt(ehci);
dead: dead:
ehci_reset(ehci); ehci_reset(ehci);
@ -4684,7 +4684,7 @@
/* generic layer kills/unlinks all urbs, then /* generic layer kills/unlinks all urbs, then
* uses ehci_stop to clean up the rest * uses ehci_stop to clean up the rest
*/ */
@@ -1101,6 +1111,11 @@ MODULE_LICENSE ("GPL"); @@ -1102,6 +1112,11 @@ MODULE_LICENSE ("GPL");
#define PCI_DRIVER ehci_pci_driver #define PCI_DRIVER ehci_pci_driver
#endif #endif

View File

@ -11,11 +11,9 @@ Changes from v2:
- removed pci_dev accessors - removed pci_dev accessors
- use DEFINE_PCI_DEVICE_TABLE - use DEFINE_PCI_DEVICE_TABLE
Index: linux-2.6.32.10/drivers/mfd/Kconfig --- a/drivers/mfd/Kconfig
=================================================================== +++ b/drivers/mfd/Kconfig
--- linux-2.6.32.10.orig/drivers/mfd/Kconfig 2010-03-15 16:52:04.000000000 +0100 @@ -305,6 +305,15 @@ config EZX_PCAP
+++ linux-2.6.32.10/drivers/mfd/Kconfig 2010-05-15 21:48:27.000000000 +0200
@@ -305,6 +305,15 @@
This enables the PCAP ASIC present on EZX Phones. This is This enables the PCAP ASIC present on EZX Phones. This is
needed for MMC, TouchScreen, Sound, USB, etc.. needed for MMC, TouchScreen, Sound, USB, etc..
@ -31,20 +29,16 @@ Index: linux-2.6.32.10/drivers/mfd/Kconfig
endmenu endmenu
menu "Multimedia Capabilities Port drivers" menu "Multimedia Capabilities Port drivers"
Index: linux-2.6.32.10/drivers/mfd/Makefile --- a/drivers/mfd/Makefile
=================================================================== +++ b/drivers/mfd/Makefile
--- linux-2.6.32.10.orig/drivers/mfd/Makefile 2010-03-15 16:52:04.000000000 +0100 @@ -50,3 +50,5 @@ obj-$(CONFIG_PCF50633_ADC) += pcf50633-a
+++ linux-2.6.32.10/drivers/mfd/Makefile 2010-05-15 21:48:27.000000000 +0200
@@ -50,3 +50,5 @@
obj-$(CONFIG_PCF50633_GPIO) += pcf50633-gpio.o obj-$(CONFIG_PCF50633_GPIO) += pcf50633-gpio.o
obj-$(CONFIG_AB3100_CORE) += ab3100-core.o obj-$(CONFIG_AB3100_CORE) += ab3100-core.o
obj-$(CONFIG_AB3100_OTP) += ab3100-otp.o obj-$(CONFIG_AB3100_OTP) += ab3100-otp.o
+ +
+obj-$(CONFIG_MFD_RDC321X) += rdc321x-southbridge.o +obj-$(CONFIG_MFD_RDC321X) += rdc321x-southbridge.o
Index: linux-2.6.32.10/drivers/mfd/rdc321x-southbridge.c --- /dev/null
=================================================================== +++ b/drivers/mfd/rdc321x-southbridge.c
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
+++ linux-2.6.32.10/drivers/mfd/rdc321x-southbridge.c 2010-05-15 22:53:39.000000000 +0200
@@ -0,0 +1,123 @@ @@ -0,0 +1,123 @@
+/* +/*
+ * RDC321x MFD southbrige driver + * RDC321x MFD southbrige driver
@ -169,10 +163,8 @@ Index: linux-2.6.32.10/drivers/mfd/rdc321x-southbridge.c
+MODULE_AUTHOR("Florian Fainelli <florian@openwrt.org>"); +MODULE_AUTHOR("Florian Fainelli <florian@openwrt.org>");
+MODULE_LICENSE("GPL"); +MODULE_LICENSE("GPL");
+MODULE_DESCRIPTION("RDC R-321x MFD southbridge driver"); +MODULE_DESCRIPTION("RDC R-321x MFD southbridge driver");
Index: linux-2.6.32.10/include/linux/mfd/rdc321x.h --- /dev/null
=================================================================== +++ b/include/linux/mfd/rdc321x.h
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
+++ linux-2.6.32.10/include/linux/mfd/rdc321x.h 2010-05-15 21:48:27.000000000 +0200
@@ -0,0 +1,26 @@ @@ -0,0 +1,26 @@
+#ifndef __RDC321X_MFD_H +#ifndef __RDC321X_MFD_H
+#define __RDC321X_MFD_H +#define __RDC321X_MFD_H

View File

@ -8,11 +8,9 @@ Changes from v2:
- use the pci_dev pointer passed as platform data - use the pci_dev pointer passed as platform data
- replaced rdc321x_pci_{read,write} - replaced rdc321x_pci_{read,write}
Index: linux-2.6.32.10/drivers/gpio/Kconfig --- a/drivers/gpio/Kconfig
=================================================================== +++ b/drivers/gpio/Kconfig
--- linux-2.6.32.10.orig/drivers/gpio/Kconfig 2010-05-15 22:54:31.000000000 +0200 @@ -196,6 +196,14 @@ config GPIO_LANGWELL
+++ linux-2.6.32.10/drivers/gpio/Kconfig 2010-05-15 22:54:51.000000000 +0200
@@ -196,6 +196,14 @@
help help
Say Y here to support Intel Moorestown platform GPIO. Say Y here to support Intel Moorestown platform GPIO.
@ -27,19 +25,15 @@ Index: linux-2.6.32.10/drivers/gpio/Kconfig
comment "SPI GPIO expanders:" comment "SPI GPIO expanders:"
config GPIO_MAX7301 config GPIO_MAX7301
Index: linux-2.6.32.10/drivers/gpio/Makefile --- a/drivers/gpio/Makefile
=================================================================== +++ b/drivers/gpio/Makefile
--- linux-2.6.32.10.orig/drivers/gpio/Makefile 2010-05-15 22:54:31.000000000 +0200 @@ -19,3 +19,4 @@ obj-$(CONFIG_GPIO_XILINX) += xilinx_gpio
+++ linux-2.6.32.10/drivers/gpio/Makefile 2010-05-15 22:54:51.000000000 +0200
@@ -19,3 +19,4 @@
obj-$(CONFIG_GPIO_BT8XX) += bt8xxgpio.o obj-$(CONFIG_GPIO_BT8XX) += bt8xxgpio.o
obj-$(CONFIG_GPIO_VR41XX) += vr41xx_giu.o obj-$(CONFIG_GPIO_VR41XX) += vr41xx_giu.o
obj-$(CONFIG_GPIO_WM831X) += wm831x-gpio.o obj-$(CONFIG_GPIO_WM831X) += wm831x-gpio.o
+obj-$(CONFIG_GPIO_RDC321X) += rdc321x-gpio.o +obj-$(CONFIG_GPIO_RDC321X) += rdc321x-gpio.o
Index: linux-2.6.32.10/drivers/gpio/rdc321x-gpio.c --- /dev/null
=================================================================== +++ b/drivers/gpio/rdc321x-gpio.c
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
+++ linux-2.6.32.10/drivers/gpio/rdc321x-gpio.c 2010-05-15 22:55:10.000000000 +0200
@@ -0,0 +1,245 @@ @@ -0,0 +1,245 @@
+/* +/*
+ * RDC321x GPIO driver + * RDC321x GPIO driver

View File

@ -10,10 +10,8 @@ Changes from v2:
- replaced rdc321x_pci_{read,write} - replaced rdc321x_pci_{read,write}
- use the pci_dev pointer passed as platform_data - use the pci_dev pointer passed as platform_data
Index: linux-2.6.32.10/drivers/watchdog/rdc321x_wdt.c --- a/drivers/watchdog/rdc321x_wdt.c
=================================================================== +++ b/drivers/watchdog/rdc321x_wdt.c
--- linux-2.6.32.10.orig/drivers/watchdog/rdc321x_wdt.c 2010-05-15 22:14:28.000000000 +0200
+++ linux-2.6.32.10/drivers/watchdog/rdc321x_wdt.c 2010-05-15 22:15:24.000000000 +0200
@@ -1,7 +1,7 @@ @@ -1,7 +1,7 @@
/* /*
* RDC321x watchdog driver * RDC321x watchdog driver
@ -33,7 +31,7 @@ Index: linux-2.6.32.10/drivers/watchdog/rdc321x_wdt.c
#define RDC_WDT_MASK 0x80000000 /* Mask */ #define RDC_WDT_MASK 0x80000000 /* Mask */
#define RDC_WDT_EN 0x00800000 /* Enable bit */ #define RDC_WDT_EN 0x00800000 /* Enable bit */
@@ -63,6 +62,8 @@ @@ -63,6 +62,8 @@ static struct {
int default_ticks; int default_ticks;
unsigned long inuse; unsigned long inuse;
spinlock_t lock; spinlock_t lock;
@ -42,7 +40,7 @@ Index: linux-2.6.32.10/drivers/watchdog/rdc321x_wdt.c
} rdc321x_wdt_device; } rdc321x_wdt_device;
/* generic helper functions */ /* generic helper functions */
@@ -70,14 +71,18 @@ @@ -70,14 +71,18 @@ static struct {
static void rdc321x_wdt_trigger(unsigned long unused) static void rdc321x_wdt_trigger(unsigned long unused)
{ {
unsigned long flags; unsigned long flags;
@ -63,7 +61,7 @@ Index: linux-2.6.32.10/drivers/watchdog/rdc321x_wdt.c
spin_unlock_irqrestore(&rdc321x_wdt_device.lock, flags); spin_unlock_irqrestore(&rdc321x_wdt_device.lock, flags);
/* requeue?? */ /* requeue?? */
@@ -105,10 +110,13 @@ @@ -105,10 +110,13 @@ static void rdc321x_wdt_start(void)
/* Clear the timer */ /* Clear the timer */
spin_lock_irqsave(&rdc321x_wdt_device.lock, flags); spin_lock_irqsave(&rdc321x_wdt_device.lock, flags);
@ -79,7 +77,7 @@ Index: linux-2.6.32.10/drivers/watchdog/rdc321x_wdt.c
spin_unlock_irqrestore(&rdc321x_wdt_device.lock, flags); spin_unlock_irqrestore(&rdc321x_wdt_device.lock, flags);
mod_timer(&rdc321x_wdt_device.timer, mod_timer(&rdc321x_wdt_device.timer,
@@ -148,7 +156,7 @@ @@ -148,7 +156,7 @@ static long rdc321x_wdt_ioctl(struct fil
unsigned long arg) unsigned long arg)
{ {
void __user *argp = (void __user *)arg; void __user *argp = (void __user *)arg;
@ -88,7 +86,7 @@ Index: linux-2.6.32.10/drivers/watchdog/rdc321x_wdt.c
static struct watchdog_info ident = { static struct watchdog_info ident = {
.options = WDIOF_CARDRESET, .options = WDIOF_CARDRESET,
.identity = "RDC321x WDT", .identity = "RDC321x WDT",
@@ -162,9 +170,10 @@ @@ -162,9 +170,10 @@ static long rdc321x_wdt_ioctl(struct fil
case WDIOC_GETSTATUS: case WDIOC_GETSTATUS:
/* Read the value from the DATA register */ /* Read the value from the DATA register */
spin_lock_irqsave(&rdc321x_wdt_device.lock, flags); spin_lock_irqsave(&rdc321x_wdt_device.lock, flags);
@ -101,7 +99,7 @@ Index: linux-2.6.32.10/drivers/watchdog/rdc321x_wdt.c
return -EFAULT; return -EFAULT;
break; break;
case WDIOC_GETSUPPORT: case WDIOC_GETSUPPORT:
@@ -219,17 +228,35 @@ @@ -219,17 +228,35 @@ static struct miscdevice rdc321x_wdt_mis
static int __devinit rdc321x_wdt_probe(struct platform_device *pdev) static int __devinit rdc321x_wdt_probe(struct platform_device *pdev)
{ {
int err; int err;
@ -139,7 +137,7 @@ Index: linux-2.6.32.10/drivers/watchdog/rdc321x_wdt.c
init_completion(&rdc321x_wdt_device.stop); init_completion(&rdc321x_wdt_device.stop);
rdc321x_wdt_device.queue = 0; rdc321x_wdt_device.queue = 0;
@@ -240,7 +267,7 @@ @@ -240,7 +267,7 @@ static int __devinit rdc321x_wdt_probe(s
rdc321x_wdt_device.default_ticks = ticks; rdc321x_wdt_device.default_ticks = ticks;

View File

@ -1,8 +1,6 @@
Index: linux-2.6.32.9/scripts/Makefile.lib --- a/scripts/Makefile.lib
=================================================================== +++ b/scripts/Makefile.lib
--- linux-2.6.32.9.orig/scripts/Makefile.lib 2010-04-13 07:55:06.543296524 +0200 @@ -228,7 +228,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^)
+++ linux-2.6.32.9/scripts/Makefile.lib 2010-04-13 07:55:06.814268461 +0200
@@ -228,7 +228,7 @@
quiet_cmd_lzma = LZMA $@ quiet_cmd_lzma = LZMA $@
cmd_lzma = (cat $(filter-out FORCE,$^) | \ cmd_lzma = (cat $(filter-out FORCE,$^) | \
@ -11,10 +9,8 @@ Index: linux-2.6.32.9/scripts/Makefile.lib
(rm -f $@ ; false) (rm -f $@ ; false)
quiet_cmd_lzo = LZO $@ quiet_cmd_lzo = LZO $@
Index: linux-2.6.32.9/arch/x86/include/asm/boot.h --- a/arch/x86/include/asm/boot.h
=================================================================== +++ b/arch/x86/include/asm/boot.h
--- linux-2.6.32.9.orig/arch/x86/include/asm/boot.h 2010-02-23 16:38:51.000000000 +0100
+++ linux-2.6.32.9/arch/x86/include/asm/boot.h 2010-04-13 08:00:14.474369306 +0200
@@ -28,7 +28,7 @@ @@ -28,7 +28,7 @@
#error "Invalid value for CONFIG_PHYSICAL_ALIGN" #error "Invalid value for CONFIG_PHYSICAL_ALIGN"
#endif #endif

View File

@ -1,8 +1,6 @@
diff --git a/drivers/net/r6040.c b/drivers/net/r6040.c
index 4122916..eeee379 100644
--- a/drivers/net/r6040.c --- a/drivers/net/r6040.c
+++ b/drivers/net/r6040.c +++ b/drivers/net/r6040.c
@@ -400,9 +400,6 @@ static void r6040_init_mac_regs(struct net_device *dev) @@ -401,9 +401,6 @@ static void r6040_init_mac_regs(struct n
* we may got called by r6040_tx_timeout which has left * we may got called by r6040_tx_timeout which has left
* some unsent tx buffers */ * some unsent tx buffers */
iowrite16(0x01, ioaddr + MTPR); iowrite16(0x01, ioaddr + MTPR);
@ -12,7 +10,7 @@ index 4122916..eeee379 100644
} }
static void r6040_tx_timeout(struct net_device *dev) static void r6040_tx_timeout(struct net_device *dev)
@@ -530,8 +527,6 @@ static int r6040_phy_mode_chk(struct net_device *dev) @@ -531,8 +528,6 @@ static int r6040_phy_mode_chk(struct net
phy_dat = 0x0000; phy_dat = 0x0000;
} }
@ -21,7 +19,7 @@ index 4122916..eeee379 100644
return phy_dat; return phy_dat;
}; };
@@ -813,6 +808,9 @@ static void r6040_timer(unsigned long data) @@ -814,6 +809,9 @@ static void r6040_timer(unsigned long da
/* Timer active again */ /* Timer active again */
mod_timer(&lp->timer, round_jiffies(jiffies + HZ)); mod_timer(&lp->timer, round_jiffies(jiffies + HZ));

View File

@ -1,7 +1,5 @@
Index: linux-2.6.32.12/drivers/net/r6040.c --- a/drivers/net/r6040.c
=================================================================== +++ b/drivers/net/r6040.c
--- linux-2.6.32.12.orig/drivers/net/r6040.c 2010-05-20 10:19:41.000000000 +0200
+++ linux-2.6.32.12/drivers/net/r6040.c 2010-05-20 10:28:48.000000000 +0200
@@ -45,6 +45,7 @@ @@ -45,6 +45,7 @@
#include <linux/io.h> #include <linux/io.h>
#include <linux/irq.h> #include <linux/irq.h>
@ -10,7 +8,7 @@ Index: linux-2.6.32.12/drivers/net/r6040.c
#include <asm/processor.h> #include <asm/processor.h>
@@ -180,7 +181,6 @@ @@ -180,7 +181,6 @@ struct r6040_descriptor {
struct r6040_private { struct r6040_private {
spinlock_t lock; /* driver lock */ spinlock_t lock; /* driver lock */
@ -18,7 +16,7 @@ Index: linux-2.6.32.12/drivers/net/r6040.c
struct pci_dev *pdev; struct pci_dev *pdev;
struct r6040_descriptor *rx_insert_ptr; struct r6040_descriptor *rx_insert_ptr;
struct r6040_descriptor *rx_remove_ptr; struct r6040_descriptor *rx_remove_ptr;
@@ -190,13 +190,15 @@ @@ -190,13 +190,15 @@ struct r6040_private {
struct r6040_descriptor *tx_ring; struct r6040_descriptor *tx_ring;
dma_addr_t rx_ring_dma; dma_addr_t rx_ring_dma;
dma_addr_t tx_ring_dma; dma_addr_t tx_ring_dma;
@ -37,7 +35,7 @@ Index: linux-2.6.32.12/drivers/net/r6040.c
}; };
static char version[] __devinitdata = KERN_INFO DRV_NAME static char version[] __devinitdata = KERN_INFO DRV_NAME
@@ -239,20 +241,29 @@ @@ -239,20 +241,29 @@ static void r6040_phy_write(void __iomem
} }
} }
@ -71,7 +69,7 @@ Index: linux-2.6.32.12/drivers/net/r6040.c
} }
static void r6040_free_txbufs(struct net_device *dev) static void r6040_free_txbufs(struct net_device *dev)
@@ -409,10 +420,9 @@ @@ -409,10 +420,9 @@ static void r6040_tx_timeout(struct net_
void __iomem *ioaddr = priv->base; void __iomem *ioaddr = priv->base;
printk(KERN_WARNING "%s: transmit timed out, int enable %4.4x " printk(KERN_WARNING "%s: transmit timed out, int enable %4.4x "
@ -84,7 +82,7 @@ Index: linux-2.6.32.12/drivers/net/r6040.c
dev->stats.tx_errors++; dev->stats.tx_errors++;
@@ -464,9 +474,6 @@ @@ -464,9 +474,6 @@ static int r6040_close(struct net_device
struct r6040_private *lp = netdev_priv(dev); struct r6040_private *lp = netdev_priv(dev);
struct pci_dev *pdev = lp->pdev; struct pci_dev *pdev = lp->pdev;
@ -94,7 +92,7 @@ Index: linux-2.6.32.12/drivers/net/r6040.c
spin_lock_irq(&lp->lock); spin_lock_irq(&lp->lock);
napi_disable(&lp->napi); napi_disable(&lp->napi);
netif_stop_queue(dev); netif_stop_queue(dev);
@@ -496,64 +503,14 @@ @@ -496,64 +503,14 @@ static int r6040_close(struct net_device
return 0; return 0;
} }
@ -162,7 +160,7 @@ Index: linux-2.6.32.12/drivers/net/r6040.c
} }
static int r6040_rx(struct net_device *dev, int limit) static int r6040_rx(struct net_device *dev, int limit)
@@ -752,26 +709,6 @@ @@ -752,26 +709,6 @@ static int r6040_up(struct net_device *d
if (ret) if (ret)
return ret; return ret;
@ -189,7 +187,7 @@ Index: linux-2.6.32.12/drivers/net/r6040.c
/* improve performance (by RDC guys) */ /* improve performance (by RDC guys) */
r6040_phy_write(ioaddr, 30, 17, (r6040_phy_read(ioaddr, 30, 17) | 0x4000)); r6040_phy_write(ioaddr, 30, 17, (r6040_phy_read(ioaddr, 30, 17) | 0x4000));
r6040_phy_write(ioaddr, 30, 17, ~((~r6040_phy_read(ioaddr, 30, 17)) | 0x2000)); r6040_phy_write(ioaddr, 30, 17, ~((~r6040_phy_read(ioaddr, 30, 17)) | 0x2000));
@@ -784,35 +721,6 @@ @@ -784,35 +721,6 @@ static int r6040_up(struct net_device *d
return 0; return 0;
} }
@ -225,7 +223,7 @@ Index: linux-2.6.32.12/drivers/net/r6040.c
/* Read/set MAC address routines */ /* Read/set MAC address routines */
static void r6040_mac_address(struct net_device *dev) static void r6040_mac_address(struct net_device *dev)
@@ -874,10 +782,6 @@ @@ -874,10 +782,6 @@ static int r6040_open(struct net_device
napi_enable(&lp->napi); napi_enable(&lp->napi);
netif_start_queue(dev); netif_start_queue(dev);
@ -236,7 +234,7 @@ Index: linux-2.6.32.12/drivers/net/r6040.c
return 0; return 0;
} }
@@ -1020,40 +924,22 @@ @@ -1020,40 +924,22 @@ static void netdev_get_drvinfo(struct ne
static int netdev_get_settings(struct net_device *dev, struct ethtool_cmd *cmd) static int netdev_get_settings(struct net_device *dev, struct ethtool_cmd *cmd)
{ {
struct r6040_private *rp = netdev_priv(dev); struct r6040_private *rp = netdev_priv(dev);
@ -280,7 +278,7 @@ Index: linux-2.6.32.12/drivers/net/r6040.c
}; };
static const struct net_device_ops r6040_netdev_ops = { static const struct net_device_ops r6040_netdev_ops = {
@@ -1072,6 +958,86 @@ @@ -1072,6 +958,86 @@ static const struct net_device_ops r6040
#endif #endif
}; };
@ -367,7 +365,7 @@ Index: linux-2.6.32.12/drivers/net/r6040.c
static int __devinit r6040_init_one(struct pci_dev *pdev, static int __devinit r6040_init_one(struct pci_dev *pdev,
const struct pci_device_id *ent) const struct pci_device_id *ent)
{ {
@@ -1082,6 +1048,7 @@ @@ -1082,6 +1048,7 @@ static int __devinit r6040_init_one(stru
static int card_idx = -1; static int card_idx = -1;
int bar = 0; int bar = 0;
u16 *adrp; u16 *adrp;
@ -375,7 +373,7 @@ Index: linux-2.6.32.12/drivers/net/r6040.c
printk("%s\n", version); printk("%s\n", version);
@@ -1169,7 +1136,6 @@ @@ -1169,7 +1136,6 @@ static int __devinit r6040_init_one(stru
/* Init RDC private data */ /* Init RDC private data */
lp->mcr0 = 0x1002; lp->mcr0 = 0x1002;
lp->phy_addr = phy_table[card_idx]; lp->phy_addr = phy_table[card_idx];
@ -383,7 +381,7 @@ Index: linux-2.6.32.12/drivers/net/r6040.c
/* The RDC-specific entries in the device structure. */ /* The RDC-specific entries in the device structure. */
dev->netdev_ops = &r6040_netdev_ops; dev->netdev_ops = &r6040_netdev_ops;
@@ -1177,28 +1143,61 @@ @@ -1177,28 +1143,61 @@ static int __devinit r6040_init_one(stru
dev->watchdog_timeo = TX_TIMEOUT; dev->watchdog_timeo = TX_TIMEOUT;
netif_napi_add(dev, &lp->napi, r6040_poll, 64); netif_napi_add(dev, &lp->napi, r6040_poll, 64);
@ -453,7 +451,7 @@ Index: linux-2.6.32.12/drivers/net/r6040.c
err_out_unmap: err_out_unmap:
pci_iounmap(pdev, ioaddr); pci_iounmap(pdev, ioaddr);
err_out_free_res: err_out_free_res:
@@ -1212,8 +1211,12 @@ @@ -1212,8 +1211,12 @@ err_out:
static void __devexit r6040_remove_one(struct pci_dev *pdev) static void __devexit r6040_remove_one(struct pci_dev *pdev)
{ {
struct net_device *dev = pci_get_drvdata(pdev); struct net_device *dev = pci_get_drvdata(pdev);

View File

@ -10,7 +10,6 @@
# drivers-y are linked after core-y # drivers-y are linked after core-y
drivers-$(CONFIG_MATH_EMULATION) += arch/x86/math-emu/ drivers-$(CONFIG_MATH_EMULATION) += arch/x86/math-emu/
drivers-$(CONFIG_PCI) += arch/x86/pci/ drivers-$(CONFIG_PCI) += arch/x86/pci/
--- /dev/null --- /dev/null
+++ b/arch/x86/mach-rdc321x/Makefile +++ b/arch/x86/mach-rdc321x/Makefile
@@ -0,0 +1,5 @@ @@ -0,0 +1,5 @@

View File

@ -1,5 +1,5 @@
--- a/arch/x86/kernel/mfgpt_32.c 2010-03-15 09:52:04.000000000 -0600 --- a/arch/x86/kernel/mfgpt_32.c
+++ b/arch/x86/kernel/mfgpt_32.c 2010-04-08 17:31:56.000000000 -0600 +++ b/arch/x86/kernel/mfgpt_32.c
@@ -33,7 +33,7 @@ @@ -33,7 +33,7 @@
#include <linux/module.h> #include <linux/module.h>
#include <asm/geode.h> #include <asm/geode.h>