popt: update to latest upstream version, fixes build breakage after autofools changes
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43901 3c298f89-4303-0410-b956-a3cf2f4a3e73master
parent
2710b93ef1
commit
515dd33cf9
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=popt
|
||||
PKG_VERSION:=1.7
|
||||
PKG_RELEASE:=5
|
||||
PKG_VERSION:=1.16
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://downloads.openwrt.org/sources/
|
||||
PKG_MD5SUM:=5988e7aeb0ae4dac8d83561265984cc9
|
||||
PKG_SOURCE_URL:=http://rpm5.org/files/popt/
|
||||
PKG_MD5SUM:=3743beefa3dd6247a73f8f7a32c14c33
|
||||
PKG_LICENSE:=MIT
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
|
|
|
@ -1,81 +0,0 @@
|
|||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -64,25 +64,14 @@ else
|
||||
AC_MSG_RESULT(no)
|
||||
fi
|
||||
|
||||
-if test ! -f ../rpm.c
|
||||
-then
|
||||
- AC_MSG_CHECKING(for GNU xgettext)
|
||||
- xgettext --version 2>&1 | grep 'GNU gettext' >/dev/null 2>&1 || AC_MSG_ERROR([
|
||||
- *** GNU gettext is required. The latest version
|
||||
- *** is always available from ftp://ftp.gnu.org/gnu/gettext/.])
|
||||
- AC_MSG_RESULT(yes)
|
||||
-fi
|
||||
-
|
||||
AC_CHECK_FUNCS(strerror mtrace getuid geteuid)
|
||||
AC_CHECK_FUNC(setreuid, [], [
|
||||
AC_CHECK_LIB(ucb, setreuid, [if echo $LIBS | grep -- -lucb >/dev/null ;then :; else LIBS="$LIBS -lc -lucb" USEUCB=y;fi])
|
||||
])
|
||||
|
||||
-AM_GNU_GETTEXT
|
||||
-
|
||||
POPT_SOURCE_PATH="`pwd`"
|
||||
AC_DEFINE_UNQUOTED(POPT_SOURCE_PATH, "$POPT_SOURCE_PATH",
|
||||
[Full path to popt top_sourcedir.])
|
||||
AC_SUBST(POPT_SOURCE_PATH)
|
||||
|
||||
-AC_OUTPUT([Doxyfile Makefile intl/Makefile po/Makefile.in])
|
||||
+AC_OUTPUT([Doxyfile Makefile])
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -4,10 +4,9 @@ AUTOMAKE_OPTIONS = 1.4 foreign
|
||||
|
||||
EXTRA_DIST = autogen.sh CHANGES $(man_MANS) popt.spec \
|
||||
testit.sh test-poptrc \
|
||||
- po/*.in po/*.po po/popt.pot \
|
||||
popt.ps
|
||||
|
||||
-SUBDIRS = intl po
|
||||
+SUBDIRS =
|
||||
|
||||
INCLUDES = -I. -I$(top_srcdir)
|
||||
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -124,7 +124,7 @@ EXTRA_DIST = autogen.sh CHANGES $(man_MA
|
||||
popt.ps
|
||||
|
||||
|
||||
-SUBDIRS = intl po
|
||||
+SUBDIRS =
|
||||
|
||||
INCLUDES = -I. -I$(top_srcdir)
|
||||
|
||||
@@ -160,7 +160,7 @@ subdir = .
|
||||
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
|
||||
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
|
||||
CONFIG_HEADER = config.h
|
||||
-CONFIG_CLEAN_FILES = Doxyfile intl/Makefile
|
||||
+CONFIG_CLEAN_FILES = Doxyfile
|
||||
LTLIBRARIES = $(lib_LTLIBRARIES)
|
||||
|
||||
libpopt_la_LDFLAGS =
|
||||
@@ -261,8 +261,6 @@ distclean-hdr:
|
||||
-rm -f config.h stamp-h1
|
||||
Doxyfile: $(top_builddir)/config.status Doxyfile.in
|
||||
cd $(top_builddir) && $(SHELL) ./config.status $@
|
||||
-intl/Makefile: $(top_builddir)/config.status $(top_srcdir)/intl/Makefile.in
|
||||
- cd $(top_builddir) && $(SHELL) ./config.status $@
|
||||
libLTLIBRARIES_INSTALL = $(INSTALL)
|
||||
install-libLTLIBRARIES: $(lib_LTLIBRARIES)
|
||||
@$(NORMAL_INSTALL)
|
||||
@@ -584,7 +582,7 @@ distcleancheck_listfiles = find . -type
|
||||
distdir: $(DISTFILES)
|
||||
$(am__remove_distdir)
|
||||
mkdir $(distdir)
|
||||
- $(mkinstalldirs) $(distdir)/. $(distdir)/intl $(distdir)/po
|
||||
+ $(mkinstalldirs) $(distdir)/.
|
||||
@list='$(DISTFILES)'; for file in $$list; do \
|
||||
if test -f $$file || test -d $$file; then d=.; else d=$(srcdir); fi; \
|
||||
dir=`echo "$$file" | sed -e 's,/[^/]*$$,,'`; \
|
Loading…
Reference in New Issue