[rdc] move headers to arch/x86/include/asm/, patch from sn9
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18347 3c298f89-4303-0410-b956-a3cf2f4a3e73master
parent
cce5a0876d
commit
4bb74e31f0
|
@ -1,12 +0,0 @@
|
|||
#define PFX "rdc321x: "
|
||||
|
||||
/* General purpose configuration and data registers */
|
||||
#define RDC3210_CFGREG_ADDR 0x0CF8
|
||||
#define RDC3210_CFGREG_DATA 0x0CFC
|
||||
|
||||
#define RDC321X_GPIO_CTRL_REG1 0x48
|
||||
#define RDC321X_GPIO_CTRL_REG2 0x84
|
||||
#define RDC321X_GPIO_DATA_REG1 0x4c
|
||||
#define RDC321X_GPIO_DATA_REG2 0x88
|
||||
|
||||
#define RDC321X_MAX_GPIO 58
|
|
@ -26,8 +26,8 @@
|
|||
#include <linux/types.h>
|
||||
#include <linux/module.h>
|
||||
|
||||
#include <asm/mach-rdc321x/gpio.h>
|
||||
#include <asm/mach-rdc321x/rdc321x_defs.h>
|
||||
#include <asm/rdc321x_gpio.h>
|
||||
#include <asm/rdc321x_defs.h>
|
||||
|
||||
|
||||
/* spin lock to protect our private copy of GPIO data register plus
|
||||
|
|
|
@ -36,7 +36,7 @@
|
|||
#include <linux/mtd/physmap.h>
|
||||
#include <linux/root_dev.h>
|
||||
|
||||
#include <asm/mach-rdc321x/gpio.h>
|
||||
#include <asm/rdc321x_gpio.h>
|
||||
|
||||
/* Flash */
|
||||
#ifdef CONFIG_MTD_R8610
|
||||
|
|
|
@ -1,11 +1,12 @@
|
|||
--- a/arch/x86/Makefile
|
||||
+++ b/arch/x86/Makefile
|
||||
@@ -124,6 +124,10 @@ core-y += $(fcore-y)
|
||||
Index: linux-2.6.30.9/arch/x86/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.30.9.orig/arch/x86/Makefile 2009-11-06 07:29:13.739468521 -0800
|
||||
+++ linux-2.6.30.9/arch/x86/Makefile 2009-11-06 07:30:29.383510569 -0800
|
||||
@@ -124,6 +124,9 @@
|
||||
# Xen paravirtualization support
|
||||
core-$(CONFIG_XEN) += arch/x86/xen/
|
||||
|
||||
+# RDC R-321X support
|
||||
+cflags-$(CONFIG_X86_RDC321X) := -Iarch/x86/include/asm/mach-rdc321x
|
||||
+core-$(CONFIG_X86_RDC321X) += arch/x86/mach-rdc321x/
|
||||
+
|
||||
# lguest paravirtualization support
|
||||
|
|
Loading…
Reference in New Issue