CC: toolchain: use latest glibc 2.21 revision
Fixes "CVE-2015-7547 --- glibc getaddrinfo() stack-based buffer overflow" Signed-off-by: Michael Marley <michael@michaelmarley.com> git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@48864 3c298f89-4303-0410-b956-a3cf2f4a3e73master
parent
706ffd8068
commit
3ea83f0688
|
@ -12,12 +12,6 @@ config EGLIBC_VERSION_2_19
|
||||||
config GLIBC_VERSION_2_21
|
config GLIBC_VERSION_2_21
|
||||||
bool
|
bool
|
||||||
|
|
||||||
config GLIBC_REVISION
|
|
||||||
string
|
|
||||||
default "25243" if EGLIBC_VERSION_2_19
|
|
||||||
default "4e42b5b8f8" if GLIBC_VERSION_2_21
|
|
||||||
default ""
|
|
||||||
|
|
||||||
endif
|
endif
|
||||||
|
|
||||||
menu "eglibc configuration"
|
menu "eglibc configuration"
|
||||||
|
|
|
@ -6,9 +6,19 @@
|
||||||
#
|
#
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
|
||||||
|
MD5SUM_2.19 = 42dad4edd3bcb38006d13b5640b00b38
|
||||||
|
REVISION_2.19 = 25243
|
||||||
|
|
||||||
|
MD5SUM_2.21 = 76050a65c444d58b5c4aa0d6034736ed
|
||||||
|
REVISION_2.21 = 16d0a0c
|
||||||
|
|
||||||
|
|
||||||
PKG_NAME:=glibc
|
PKG_NAME:=glibc
|
||||||
PKG_VERSION:=$(call qstrip,$(CONFIG_GLIBC_VERSION))
|
PKG_VERSION:=$(call qstrip,$(CONFIG_GLIBC_VERSION))
|
||||||
PKG_REVISION:=$(call qstrip,$(CONFIG_GLIBC_REVISION))
|
|
||||||
|
PKG_REVISION:=$(REVISION_$(PKG_VERSION))
|
||||||
|
PKG_MIRROR_MD5SUM:=$(MD5SUM_$(PKG_VERSION))
|
||||||
|
|
||||||
PKG_SOURCE_PROTO:=git
|
PKG_SOURCE_PROTO:=git
|
||||||
PKG_SOURCE_URL:=git://sourceware.org/git/glibc.git
|
PKG_SOURCE_URL:=git://sourceware.org/git/glibc.git
|
||||||
|
|
|
@ -2,7 +2,7 @@ add /usr/lib to default search path for the dynamic linker
|
||||||
|
|
||||||
--- a/Makeconfig
|
--- a/Makeconfig
|
||||||
+++ b/Makeconfig
|
+++ b/Makeconfig
|
||||||
@@ -501,6 +501,9 @@ else
|
@@ -499,6 +499,9 @@ else
|
||||||
default-rpath = $(libdir)
|
default-rpath = $(libdir)
|
||||||
endif
|
endif
|
||||||
|
|
||||||
|
|
Loading…
Reference in New Issue