ar71xx: fix oprofile support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20150 3c298f89-4303-0410-b956-a3cf2f4a3e73master
parent
2e64f11f68
commit
3e2f215c02
|
@ -405,6 +405,8 @@ void __init arch_init_irq(void)
|
||||||
|
|
||||||
ar71xx_misc_irq_init();
|
ar71xx_misc_irq_init();
|
||||||
|
|
||||||
|
cp0_perfcount_irq = AR71XX_MISC_IRQ_PERFC;
|
||||||
|
|
||||||
switch (ar71xx_soc) {
|
switch (ar71xx_soc) {
|
||||||
case AR71XX_SOC_AR7130:
|
case AR71XX_SOC_AR7130:
|
||||||
case AR71XX_SOC_AR7141:
|
case AR71XX_SOC_AR7141:
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/arch/mips/Makefile
|
--- a/arch/mips/Makefile
|
||||||
+++ b/arch/mips/Makefile
|
+++ b/arch/mips/Makefile
|
||||||
@@ -188,6 +188,7 @@ endif
|
@@ -190,6 +190,7 @@ endif
|
||||||
#
|
#
|
||||||
libs-$(CONFIG_ARC) += arch/mips/fw/arc/
|
libs-$(CONFIG_ARC) += arch/mips/fw/arc/
|
||||||
libs-$(CONFIG_CFE) += arch/mips/fw/cfe/
|
libs-$(CONFIG_CFE) += arch/mips/fw/cfe/
|
||||||
|
|
|
@ -0,0 +1,47 @@
|
||||||
|
--- a/arch/mips/Makefile
|
||||||
|
+++ b/arch/mips/Makefile
|
||||||
|
@@ -48,7 +48,9 @@ ifneq ($(SUBARCH),$(ARCH))
|
||||||
|
endif
|
||||||
|
endif
|
||||||
|
|
||||||
|
+ifndef CONFIG_PROFILING
|
||||||
|
cflags-y := -ffunction-sections
|
||||||
|
+endif
|
||||||
|
cflags-y += $(call cc-option, -mno-check-zero-division)
|
||||||
|
|
||||||
|
ifdef CONFIG_32BIT
|
||||||
|
--- a/arch/mips/oprofile/op_model_mipsxx.c
|
||||||
|
+++ b/arch/mips/oprofile/op_model_mipsxx.c
|
||||||
|
@@ -298,6 +298,11 @@ static void reset_counters(void *arg)
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
|
+static irqreturn_t mipsxx_perfcount_int(int irq, void *dev_id)
|
||||||
|
+{
|
||||||
|
+ return mipsxx_perfcount_handler();
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
static int __init mipsxx_init(void)
|
||||||
|
{
|
||||||
|
int counters;
|
||||||
|
@@ -374,6 +379,10 @@ static int __init mipsxx_init(void)
|
||||||
|
save_perf_irq = perf_irq;
|
||||||
|
perf_irq = mipsxx_perfcount_handler;
|
||||||
|
|
||||||
|
+ if (cp0_perfcount_irq >= 0)
|
||||||
|
+ return request_irq(cp0_perfcount_irq, mipsxx_perfcount_int,
|
||||||
|
+ IRQF_SHARED, "Perfcounter", save_perf_irq);
|
||||||
|
+
|
||||||
|
return 0;
|
||||||
|
}
|
||||||
|
|
||||||
|
@@ -381,6 +390,9 @@ static void mipsxx_exit(void)
|
||||||
|
{
|
||||||
|
int counters = op_model_mipsxx_ops.num_counters;
|
||||||
|
|
||||||
|
+ if (cp0_perfcount_irq >= 0)
|
||||||
|
+ free_irq(cp0_perfcount_irq, save_perf_irq);
|
||||||
|
+
|
||||||
|
counters = counters_per_cpu_to_total(counters);
|
||||||
|
on_each_cpu(reset_counters, (void *)(long)counters, 1);
|
||||||
|
|
|
@ -0,0 +1,48 @@
|
||||||
|
--- a/arch/mips/Makefile
|
||||||
|
+++ b/arch/mips/Makefile
|
||||||
|
@@ -49,7 +49,9 @@ ifneq ($(SUBARCH),$(ARCH))
|
||||||
|
endif
|
||||||
|
|
||||||
|
ifndef CONFIG_FUNCTION_TRACER
|
||||||
|
-cflags-y := -ffunction-sections
|
||||||
|
+ ifndef CONFIG_PROFILING
|
||||||
|
+ cflags-y := -ffunction-sections
|
||||||
|
+ endif
|
||||||
|
endif
|
||||||
|
ifdef CONFIG_FUNCTION_GRAPH_TRACER
|
||||||
|
ifndef KBUILD_MCOUNT_RA_ADDRESS
|
||||||
|
--- a/arch/mips/oprofile/op_model_mipsxx.c
|
||||||
|
+++ b/arch/mips/oprofile/op_model_mipsxx.c
|
||||||
|
@@ -298,6 +298,11 @@ static void reset_counters(void *arg)
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
|
+static irqreturn_t mipsxx_perfcount_int(int irq, void *dev_id)
|
||||||
|
+{
|
||||||
|
+ return mipsxx_perfcount_handler();
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
static int __init mipsxx_init(void)
|
||||||
|
{
|
||||||
|
int counters;
|
||||||
|
@@ -374,6 +379,10 @@ static int __init mipsxx_init(void)
|
||||||
|
save_perf_irq = perf_irq;
|
||||||
|
perf_irq = mipsxx_perfcount_handler;
|
||||||
|
|
||||||
|
+ if (cp0_perfcount_irq >= 0)
|
||||||
|
+ return request_irq(cp0_perfcount_irq, mipsxx_perfcount_int,
|
||||||
|
+ IRQF_SHARED, "Perfcounter", save_perf_irq);
|
||||||
|
+
|
||||||
|
return 0;
|
||||||
|
}
|
||||||
|
|
||||||
|
@@ -381,6 +390,9 @@ static void mipsxx_exit(void)
|
||||||
|
{
|
||||||
|
int counters = op_model_mipsxx_ops.num_counters;
|
||||||
|
|
||||||
|
+ if (cp0_perfcount_irq >= 0)
|
||||||
|
+ free_irq(cp0_perfcount_irq, save_perf_irq);
|
||||||
|
+
|
||||||
|
counters = counters_per_cpu_to_total(counters);
|
||||||
|
on_each_cpu(reset_counters, (void *)(long)counters, 1);
|
||||||
|
|
|
@ -0,0 +1,48 @@
|
||||||
|
--- a/arch/mips/Makefile
|
||||||
|
+++ b/arch/mips/Makefile
|
||||||
|
@@ -49,7 +49,9 @@ ifneq ($(SUBARCH),$(ARCH))
|
||||||
|
endif
|
||||||
|
|
||||||
|
ifndef CONFIG_FUNCTION_TRACER
|
||||||
|
-cflags-y := -ffunction-sections
|
||||||
|
+ ifndef CONFIG_PROFILING
|
||||||
|
+ cflags-y := -ffunction-sections
|
||||||
|
+ endif
|
||||||
|
endif
|
||||||
|
ifdef CONFIG_FUNCTION_GRAPH_TRACER
|
||||||
|
ifndef KBUILD_MCOUNT_RA_ADDRESS
|
||||||
|
--- a/arch/mips/oprofile/op_model_mipsxx.c
|
||||||
|
+++ b/arch/mips/oprofile/op_model_mipsxx.c
|
||||||
|
@@ -298,6 +298,11 @@ static void reset_counters(void *arg)
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
|
+static irqreturn_t mipsxx_perfcount_int(int irq, void *dev_id)
|
||||||
|
+{
|
||||||
|
+ return mipsxx_perfcount_handler();
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
static int __init mipsxx_init(void)
|
||||||
|
{
|
||||||
|
int counters;
|
||||||
|
@@ -374,6 +379,10 @@ static int __init mipsxx_init(void)
|
||||||
|
save_perf_irq = perf_irq;
|
||||||
|
perf_irq = mipsxx_perfcount_handler;
|
||||||
|
|
||||||
|
+ if (cp0_perfcount_irq >= 0)
|
||||||
|
+ return request_irq(cp0_perfcount_irq, mipsxx_perfcount_int,
|
||||||
|
+ IRQF_SHARED, "Perfcounter", save_perf_irq);
|
||||||
|
+
|
||||||
|
return 0;
|
||||||
|
}
|
||||||
|
|
||||||
|
@@ -381,6 +390,9 @@ static void mipsxx_exit(void)
|
||||||
|
{
|
||||||
|
int counters = op_model_mipsxx_ops.num_counters;
|
||||||
|
|
||||||
|
+ if (cp0_perfcount_irq >= 0)
|
||||||
|
+ free_irq(cp0_perfcount_irq, save_perf_irq);
|
||||||
|
+
|
||||||
|
counters = counters_per_cpu_to_total(counters);
|
||||||
|
on_each_cpu(reset_counters, (void *)(long)counters, 1);
|
||||||
|
|
Loading…
Reference in New Issue