tools: Fix mkimage build on FreeBSD 10.1
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44280 3c298f89-4303-0410-b956-a3cf2f4a3e73master
parent
b59c2b7ff4
commit
3e095d851a
|
@ -0,0 +1,14 @@
|
|||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -584,7 +584,10 @@ UBOOTINCLUDE := \
|
||||
-I$(srctree)/arch/$(ARCH)/include \
|
||||
-include $(srctree)/include/linux/kconfig.h
|
||||
|
||||
-NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
|
||||
+ifneq ($(shell uname),FreeBSD)
|
||||
+ NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
|
||||
+endif
|
||||
+
|
||||
CHECKFLAGS += $(NOSTDINC_FLAGS)
|
||||
|
||||
# FIX ME
|
Loading…
Reference in New Issue