atheros: v3.18: rename ATHEROS_AR231X symbol to ATH25

This patch starts upsteam ath25 code backporting.

No functional changes.

Signed-off-by: Sergey Ryazanov <ryazanov.s.a@gmail.com>

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44706 3c298f89-4303-0410-b956-a3cf2f4a3e73
master
Felix Fietkau 2015-03-13 02:57:51 +00:00
parent bc66ec6772
commit 3846aa2bb9
12 changed files with 24 additions and 24 deletions

View File

@ -12,7 +12,7 @@
+ +
config MTD_MYLOADER_PARTS config MTD_MYLOADER_PARTS
tristate "MyLoader partition parsing" tristate "MyLoader partition parsing"
depends on ADM5120 || ATHEROS_AR231X || ATHEROS_AR71XX || ATH79 depends on ADM5120 || ATH25 || ATHEROS_AR71XX || ATH79
--- a/drivers/mtd/Makefile --- a/drivers/mtd/Makefile
+++ b/drivers/mtd/Makefile +++ b/drivers/mtd/Makefile
@@ -16,6 +16,7 @@ obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o @@ -16,6 +16,7 @@ obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o

View File

@ -12,7 +12,7 @@ CONFIG_ARCH_MIGHT_HAVE_PC_SERIO=y
CONFIG_ARCH_REQUIRE_GPIOLIB=y CONFIG_ARCH_REQUIRE_GPIOLIB=y
CONFIG_ARCH_SUSPEND_POSSIBLE=y CONFIG_ARCH_SUSPEND_POSSIBLE=y
CONFIG_ARCH_WANT_IPC_PARSE_VERSION=y CONFIG_ARCH_WANT_IPC_PARSE_VERSION=y
CONFIG_ATHEROS_AR231X=y CONFIG_ATH25=y
CONFIG_CC_OPTIMIZE_FOR_SIZE=y CONFIG_CC_OPTIMIZE_FOR_SIZE=y
CONFIG_CEVT_R4K=y CONFIG_CEVT_R4K=y
CONFIG_CLONE_BACKWARDS=y CONFIG_CLONE_BACKWARDS=y

View File

@ -1,10 +1,10 @@
--- a/arch/mips/Kconfig --- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig +++ b/arch/mips/Kconfig
@@ -154,6 +154,19 @@ config BCM63XX @@ -96,6 +96,19 @@ config AR7
help Support for the Texas Instruments AR7 System-on-a-Chip
Support for BCM63XX based boards family: TNETD7100, 7200 and 7300.
+config ATHEROS_AR231X +config ATH25
+ bool "Atheros 231x/531x SoC support" + bool "Atheros 231x/531x SoC support"
+ select CEVT_R4K + select CEVT_R4K
+ select CSRC_R4K + select CSRC_R4K
@ -17,9 +17,9 @@
+ help + help
+ Support for AR231x and AR531x based boards + Support for AR231x and AR531x based boards
+ +
config MIPS_COBALT config ATH79
bool "Cobalt Server" bool "Atheros AR71XX/AR724X/AR913X based boards"
select CEVT_R4K select ARCH_REQUIRE_GPIOLIB
@@ -834,6 +847,7 @@ config MIPS_PARAVIRT @@ -834,6 +847,7 @@ config MIPS_PARAVIRT
endchoice endchoice
@ -44,20 +44,20 @@
+# +#
+# Atheros AR531X/AR231X WiSoC +# Atheros AR531X/AR231X WiSoC
+# +#
+platform-$(CONFIG_ATHEROS_AR231X) += ar231x/ +platform-$(CONFIG_ATH25) += ar231x/
+cflags-$(CONFIG_ATHEROS_AR231X) += -I$(srctree)/arch/mips/include/asm/mach-ar231x +cflags-$(CONFIG_ATH25) += -I$(srctree)/arch/mips/include/asm/mach-ar231x
+load-$(CONFIG_ATHEROS_AR231X) += 0xffffffff80041000 +load-$(CONFIG_ATH25) += 0xffffffff80041000
--- /dev/null --- /dev/null
+++ b/arch/mips/ar231x/Kconfig +++ b/arch/mips/ar231x/Kconfig
@@ -0,0 +1,9 @@ @@ -0,0 +1,9 @@
+config SOC_AR5312 +config SOC_AR5312
+ bool "Atheros 5312/2312+ support" + bool "Atheros 5312/2312+ support"
+ depends on ATHEROS_AR231X + depends on ATH25
+ default y + default y
+ +
+config SOC_AR2315 +config SOC_AR2315
+ bool "Atheros 2315+ support" + bool "Atheros 2315+ support"
+ depends on ATHEROS_AR231X + depends on ATH25
+ default y + default y
--- /dev/null --- /dev/null
+++ b/arch/mips/ar231x/Makefile +++ b/arch/mips/ar231x/Makefile

View File

@ -60,7 +60,7 @@
obj-$(CONFIG_SOC_AR2315) += ar2315.o obj-$(CONFIG_SOC_AR2315) += ar2315.o
--- a/arch/mips/Kconfig --- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig +++ b/arch/mips/Kconfig
@@ -164,6 +164,7 @@ config ATHEROS_AR231X @@ -106,6 +106,7 @@ config ATH25
select SYS_SUPPORTS_BIG_ENDIAN select SYS_SUPPORTS_BIG_ENDIAN
select SYS_SUPPORTS_32BIT_KERNEL select SYS_SUPPORTS_32BIT_KERNEL
select ARCH_REQUIRE_GPIOLIB select ARCH_REQUIRE_GPIOLIB

View File

@ -3,7 +3,7 @@
@@ -1,6 +1,7 @@ @@ -1,6 +1,7 @@
config SOC_AR5312 config SOC_AR5312
bool "Atheros 5312/2312+ support" bool "Atheros 5312/2312+ support"
depends on ATHEROS_AR231X depends on ATH25
+ select GPIO_AR5312 + select GPIO_AR5312
default y default y

View File

@ -3,7 +3,7 @@
@@ -7,4 +7,5 @@ config SOC_AR5312 @@ -7,4 +7,5 @@ config SOC_AR5312
config SOC_AR2315 config SOC_AR2315
bool "Atheros 2315+ support" bool "Atheros 2315+ support"
depends on ATHEROS_AR231X depends on ATH25
+ select GPIO_AR2315 + select GPIO_AR2315
default y default y
--- a/arch/mips/ar231x/ar2315.c --- a/arch/mips/ar231x/ar2315.c

View File

@ -359,7 +359,7 @@
--- a/arch/mips/ar231x/Kconfig --- a/arch/mips/ar231x/Kconfig
+++ b/arch/mips/ar231x/Kconfig +++ b/arch/mips/ar231x/Kconfig
@@ -9,3 +9,10 @@ config SOC_AR2315 @@ -9,3 +9,10 @@ config SOC_AR2315
depends on ATHEROS_AR231X depends on ATH25
select GPIO_AR2315 select GPIO_AR2315
default y default y
+ +

View File

@ -12,7 +12,7 @@
bool "Atheros devices" bool "Atheros devices"
default y default y
- depends on PCI - depends on PCI
+ depends on (PCI || ATHEROS_AR231X) + depends on (PCI || ATH25)
---help--- ---help---
If you have a network (Ethernet) card belonging to this class, say Y If you have a network (Ethernet) card belonging to this class, say Y
and read the Ethernet-HOWTO, available from and read the Ethernet-HOWTO, available from
@ -22,7 +22,7 @@
+config NET_AR231X +config NET_AR231X
+ tristate "Atheros AR231X built-in Ethernet support" + tristate "Atheros AR231X built-in Ethernet support"
+ depends on ATHEROS_AR231X + depends on ATH25
+ help + help
+ Support for the AR231x/531x ethernet controller + Support for the AR231x/531x ethernet controller
+ +

View File

@ -218,7 +218,7 @@
+config AR2315_WDT +config AR2315_WDT
+ tristate "Atheros AR2315+ WiSoCs Watchdog Timer" + tristate "Atheros AR2315+ WiSoCs Watchdog Timer"
+ depends on ATHEROS_AR231X + depends on ATH25
+ help + help
+ Hardware driver for the built-in watchdog timer on the Atheros + Hardware driver for the built-in watchdog timer on the Atheros
+ AR2315/AR2316 WiSoCs. + AR2315/AR2316 WiSoCs.

View File

@ -6,7 +6,7 @@
+config MTD_MYLOADER_PARTS +config MTD_MYLOADER_PARTS
+ tristate "MyLoader partition parsing" + tristate "MyLoader partition parsing"
+ depends on ADM5120 || ATHEROS_AR231X || ATHEROS_AR71XX || ATH79 + depends on ADM5120 || ATH25 || ATHEROS_AR71XX || ATH79
+ ---help--- + ---help---
+ MyLoader is a bootloader which allows the user to define partitions + MyLoader is a bootloader which allows the user to define partitions
+ in flash devices, by putting a table in the second erase block + in flash devices, by putting a table in the second erase block

View File

@ -6,7 +6,7 @@
+config MTD_MYLOADER_PARTS +config MTD_MYLOADER_PARTS
+ tristate "MyLoader partition parsing" + tristate "MyLoader partition parsing"
+ depends on ADM5120 || ATHEROS_AR231X || ATHEROS_AR71XX || ATH79 + depends on ADM5120 || ATH25 || ATHEROS_AR71XX || ATH79
+ ---help--- + ---help---
+ MyLoader is a bootloader which allows the user to define partitions + MyLoader is a bootloader which allows the user to define partitions
+ in flash devices, by putting a table in the second erase block + in flash devices, by putting a table in the second erase block

View File

@ -6,7 +6,7 @@
+config MTD_MYLOADER_PARTS +config MTD_MYLOADER_PARTS
+ tristate "MyLoader partition parsing" + tristate "MyLoader partition parsing"
+ depends on ADM5120 || ATHEROS_AR231X || ATHEROS_AR71XX || ATH79 + depends on ADM5120 || ATH25 || ATHEROS_AR71XX || ATH79
+ ---help--- + ---help---
+ MyLoader is a bootloader which allows the user to define partitions + MyLoader is a bootloader which allows the user to define partitions
+ in flash devices, by putting a table in the second erase block + in flash devices, by putting a table in the second erase block