[ifxmips] refresh .32 platform patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21155 3c298f89-4303-0410-b956-a3cf2f4a3e73master
parent
315bb9fcce
commit
2cf03d3fe4
|
@ -1,8 +1,6 @@
|
||||||
Index: linux-2.6.30.5/arch/mips/kernel/traps.c
|
--- a/arch/mips/kernel/traps.c
|
||||||
===================================================================
|
+++ b/arch/mips/kernel/traps.c
|
||||||
--- linux-2.6.30.5.orig/arch/mips/kernel/traps.c 2009-08-16 23:19:38.000000000 +0200
|
@@ -1537,7 +1537,16 @@ void __cpuinit per_cpu_trap_init(void)
|
||||||
+++ linux-2.6.30.5/arch/mips/kernel/traps.c 2009-09-02 18:23:37.000000000 +0200
|
|
||||||
@@ -1542,7 +1542,16 @@
|
|
||||||
*/
|
*/
|
||||||
if (cpu_has_mips_r2) {
|
if (cpu_has_mips_r2) {
|
||||||
cp0_compare_irq = (read_c0_intctl() >> 29) & 7;
|
cp0_compare_irq = (read_c0_intctl() >> 29) & 7;
|
||||||
|
@ -19,11 +17,9 @@ Index: linux-2.6.30.5/arch/mips/kernel/traps.c
|
||||||
if (cp0_perfcount_irq == cp0_compare_irq)
|
if (cp0_perfcount_irq == cp0_compare_irq)
|
||||||
cp0_perfcount_irq = -1;
|
cp0_perfcount_irq = -1;
|
||||||
} else {
|
} else {
|
||||||
Index: linux-2.6.30.5/arch/mips/include/asm/irq.h
|
--- a/arch/mips/include/asm/irq.h
|
||||||
===================================================================
|
+++ b/arch/mips/include/asm/irq.h
|
||||||
--- linux-2.6.30.5.orig/arch/mips/include/asm/irq.h 2009-09-02 18:24:49.000000000 +0200
|
@@ -158,8 +158,10 @@ extern void free_irqno(unsigned int irq)
|
||||||
+++ linux-2.6.30.5/arch/mips/include/asm/irq.h 2009-09-02 18:26:05.000000000 +0200
|
|
||||||
@@ -157,8 +157,10 @@
|
|
||||||
* IE7. Since R2 their number has to be read from the c0_intctl register.
|
* IE7. Since R2 their number has to be read from the c0_intctl register.
|
||||||
*/
|
*/
|
||||||
#define CP0_LEGACY_COMPARE_IRQ 7
|
#define CP0_LEGACY_COMPARE_IRQ 7
|
||||||
|
|
|
@ -1,7 +1,5 @@
|
||||||
Index: linux-2.6.32.10/arch/mips/kernel/cevt-r4k.c
|
--- a/arch/mips/kernel/cevt-r4k.c
|
||||||
===================================================================
|
+++ b/arch/mips/kernel/cevt-r4k.c
|
||||||
--- linux-2.6.32.10.orig/arch/mips/kernel/cevt-r4k.c 2010-04-02 21:11:39.000000000 +0200
|
|
||||||
+++ linux-2.6.32.10/arch/mips/kernel/cevt-r4k.c 2010-04-02 21:11:52.000000000 +0200
|
|
||||||
@@ -22,6 +22,22 @@
|
@@ -22,6 +22,22 @@
|
||||||
|
|
||||||
#ifndef CONFIG_MIPS_MT_SMTC
|
#ifndef CONFIG_MIPS_MT_SMTC
|
||||||
|
@ -25,7 +23,7 @@ Index: linux-2.6.32.10/arch/mips/kernel/cevt-r4k.c
|
||||||
static int mips_next_event(unsigned long delta,
|
static int mips_next_event(unsigned long delta,
|
||||||
struct clock_event_device *evt)
|
struct clock_event_device *evt)
|
||||||
{
|
{
|
||||||
@@ -31,6 +47,7 @@
|
@@ -31,6 +47,7 @@ static int mips_next_event(unsigned long
|
||||||
cnt = read_c0_count();
|
cnt = read_c0_count();
|
||||||
cnt += delta;
|
cnt += delta;
|
||||||
write_c0_compare(cnt);
|
write_c0_compare(cnt);
|
||||||
|
|
|
@ -1,8 +1,6 @@
|
||||||
Index: linux-2.6.33.2/kernel/irq/chip.c
|
--- a/kernel/irq/chip.c
|
||||||
===================================================================
|
+++ b/kernel/irq/chip.c
|
||||||
--- linux-2.6.33.2.orig/kernel/irq/chip.c 2010-04-02 01:02:33.000000000 +0200
|
@@ -637,6 +637,9 @@ handle_percpu_irq(unsigned int irq, stru
|
||||||
+++ linux-2.6.33.2/kernel/irq/chip.c 2010-04-02 23:37:40.000000000 +0200
|
|
||||||
@@ -650,6 +650,9 @@
|
|
||||||
|
|
||||||
kstat_incr_irqs_this_cpu(irq, desc);
|
kstat_incr_irqs_this_cpu(irq, desc);
|
||||||
|
|
||||||
|
|
|
@ -1,8 +1,6 @@
|
||||||
Index: linux-2.6.33.2/arch/mips/Kconfig
|
--- a/arch/mips/Kconfig
|
||||||
===================================================================
|
+++ b/arch/mips/Kconfig
|
||||||
--- linux-2.6.33.2.orig/arch/mips/Kconfig 2010-04-02 23:31:00.000000000 +0200
|
@@ -151,6 +151,9 @@ config MACH_DECSTATION
|
||||||
+++ linux-2.6.33.2/arch/mips/Kconfig 2010-04-02 23:38:38.000000000 +0200
|
|
||||||
@@ -139,6 +139,9 @@
|
|
||||||
|
|
||||||
otherwise choose R3000.
|
otherwise choose R3000.
|
||||||
|
|
||||||
|
@ -12,7 +10,7 @@ Index: linux-2.6.33.2/arch/mips/Kconfig
|
||||||
config MACH_JAZZ
|
config MACH_JAZZ
|
||||||
bool "Jazz family of machines"
|
bool "Jazz family of machines"
|
||||||
select ARC
|
select ARC
|
||||||
@@ -693,6 +696,7 @@
|
@@ -685,6 +688,7 @@ source "arch/mips/txx9/Kconfig"
|
||||||
source "arch/mips/vr41xx/Kconfig"
|
source "arch/mips/vr41xx/Kconfig"
|
||||||
source "arch/mips/cavium-octeon/Kconfig"
|
source "arch/mips/cavium-octeon/Kconfig"
|
||||||
source "arch/mips/loongson/Kconfig"
|
source "arch/mips/loongson/Kconfig"
|
||||||
|
@ -20,11 +18,9 @@ Index: linux-2.6.33.2/arch/mips/Kconfig
|
||||||
|
|
||||||
endmenu
|
endmenu
|
||||||
|
|
||||||
Index: linux-2.6.33.2/arch/mips/Makefile
|
--- a/arch/mips/Makefile
|
||||||
===================================================================
|
+++ b/arch/mips/Makefile
|
||||||
--- linux-2.6.33.2.orig/arch/mips/Makefile 2010-04-02 23:31:01.000000000 +0200
|
@@ -305,6 +305,18 @@ cflags-$(CONFIG_MIPS_COBALT) += -I$(srct
|
||||||
+++ linux-2.6.33.2/arch/mips/Makefile 2010-04-02 23:38:38.000000000 +0200
|
|
||||||
@@ -317,6 +317,18 @@
|
|
||||||
load-$(CONFIG_MIPS_COBALT) += 0xffffffff80080000
|
load-$(CONFIG_MIPS_COBALT) += 0xffffffff80080000
|
||||||
|
|
||||||
#
|
#
|
||||||
|
@ -43,11 +39,9 @@ Index: linux-2.6.33.2/arch/mips/Makefile
|
||||||
# DECstation family
|
# DECstation family
|
||||||
#
|
#
|
||||||
core-$(CONFIG_MACH_DECSTATION) += arch/mips/dec/
|
core-$(CONFIG_MACH_DECSTATION) += arch/mips/dec/
|
||||||
Index: linux-2.6.33.2/arch/mips/pci/Makefile
|
--- a/arch/mips/pci/Makefile
|
||||||
===================================================================
|
+++ b/arch/mips/pci/Makefile
|
||||||
--- linux-2.6.33.2.orig/arch/mips/pci/Makefile 2010-04-02 01:02:33.000000000 +0200
|
@@ -55,7 +55,7 @@ obj-$(CONFIG_ZAO_CAPCELLA) += fixup-capc
|
||||||
+++ linux-2.6.33.2/arch/mips/pci/Makefile 2010-04-02 23:38:38.000000000 +0200
|
|
||||||
@@ -55,7 +55,7 @@
|
|
||||||
obj-$(CONFIG_WR_PPMC) += fixup-wrppmc.o
|
obj-$(CONFIG_WR_PPMC) += fixup-wrppmc.o
|
||||||
obj-$(CONFIG_MIKROTIK_RB532) += pci-rc32434.o ops-rc32434.o fixup-rc32434.o
|
obj-$(CONFIG_MIKROTIK_RB532) += pci-rc32434.o ops-rc32434.o fixup-rc32434.o
|
||||||
obj-$(CONFIG_CPU_CAVIUM_OCTEON) += pci-octeon.o pcie-octeon.o
|
obj-$(CONFIG_CPU_CAVIUM_OCTEON) += pci-octeon.o pcie-octeon.o
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/drivers/crypto/Kconfig
|
--- a/drivers/crypto/Kconfig
|
||||||
+++ b/drivers/crypto/Kconfig
|
+++ b/drivers/crypto/Kconfig
|
||||||
@@ -209,4 +209,66 @@ config CRYPTO_DEV_PPC4XX
|
@@ -222,4 +222,66 @@ config CRYPTO_DEV_PPC4XX
|
||||||
help
|
help
|
||||||
This option allows you to have support for AMCC crypto acceleration.
|
This option allows you to have support for AMCC crypto acceleration.
|
||||||
|
|
||||||
|
@ -69,7 +69,7 @@
|
||||||
endif # CRYPTO_HW
|
endif # CRYPTO_HW
|
||||||
--- a/drivers/crypto/Makefile
|
--- a/drivers/crypto/Makefile
|
||||||
+++ b/drivers/crypto/Makefile
|
+++ b/drivers/crypto/Makefile
|
||||||
@@ -5,3 +5,4 @@ obj-$(CONFIG_CRYPTO_DEV_HIFN_795X) += hi
|
@@ -6,3 +6,4 @@ obj-$(CONFIG_CRYPTO_DEV_MV_CESA) += mv_c
|
||||||
obj-$(CONFIG_CRYPTO_DEV_TALITOS) += talitos.o
|
obj-$(CONFIG_CRYPTO_DEV_TALITOS) += talitos.o
|
||||||
obj-$(CONFIG_CRYPTO_DEV_IXP4XX) += ixp4xx_crypto.o
|
obj-$(CONFIG_CRYPTO_DEV_IXP4XX) += ixp4xx_crypto.o
|
||||||
obj-$(CONFIG_CRYPTO_DEV_PPC4XX) += amcc/
|
obj-$(CONFIG_CRYPTO_DEV_PPC4XX) += amcc/
|
||||||
|
|
Loading…
Reference in New Issue