mac80211: don't hardcode /bin/bash

Instead of hardcoding /bin/bash, use /usr/bin/env bash - this fixes the
build on FreeBSD 10.1.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44283 3c298f89-4303-0410-b956-a3cf2f4a3e73
master
Jo-Philipp Wich 2015-02-05 23:18:47 +00:00
parent 38aa3a820c
commit 2467d38ca5
1 changed files with 9 additions and 0 deletions

View File

@ -1,5 +1,14 @@
--- a/Makefile --- a/Makefile
+++ b/Makefile +++ b/Makefile
@@ -5,7 +5,7 @@
ifeq ($(KERNELRELEASE),)
MAKEFLAGS += --no-print-directory
-SHELL := /bin/bash
+SHELL := /usr/bin/env bash
BACKPORT_PWD := $(shell pwd)
KMODDIR ?= updates
@@ -19,6 +19,7 @@ KLIB_BUILD ?= $(KLIB)/build/ @@ -19,6 +19,7 @@ KLIB_BUILD ?= $(KLIB)/build/
KERNEL_CONFIG := $(KLIB_BUILD)/.config KERNEL_CONFIG := $(KLIB_BUILD)/.config
KERNEL_MAKEFILE := $(KLIB_BUILD)/Makefile KERNEL_MAKEFILE := $(KLIB_BUILD)/Makefile