[package] iw: fix calculation of fractional multicast rates like 5.5Mbps due to wrong operator precedence
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26968 3c298f89-4303-0410-b956-a3cf2f4a3e73master
parent
13597f0024
commit
1df56fb1e5
|
@ -1,5 +1,5 @@
|
|||
#
|
||||
# Copyright (C) 2007-2009 OpenWrt.org
|
||||
# Copyright (C) 2007-2011 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=iw
|
||||
PKG_VERSION:=0.9.22
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://wireless.kernel.org/download/iw/
|
||||
|
|
|
@ -0,0 +1,11 @@
|
|||
--- a/ibss.c
|
||||
+++ b/ibss.c
|
||||
@@ -104,7 +104,7 @@ static int join_ibss(struct nl80211_stat
|
||||
if (*end != '\0')
|
||||
return 1;
|
||||
|
||||
- NLA_PUT_U32(msg, NL80211_ATTR_MCAST_RATE, (int) rate * 10);
|
||||
+ NLA_PUT_U32(msg, NL80211_ATTR_MCAST_RATE, (int)(rate * 10));
|
||||
argv++;
|
||||
argc--;
|
||||
}
|
Loading…
Reference in New Issue