[kernel] refresh 2.6.31 patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18334 3c298f89-4303-0410-b956-a3cf2f4a3e73master
parent
6b0002d8ff
commit
1393877575
|
@ -1,6 +1,5 @@
|
||||||
diff -Nru linux-2.6.31.5/arch/mips/kernel/Makefile linux-2.6.31.5.new/arch/mips/kernel/Makefile
|
--- a/arch/mips/kernel/Makefile
|
||||||
--- linux-2.6.31.5/arch/mips/kernel/Makefile 2009-10-25 12:35:46.137368384 +0200
|
+++ b/arch/mips/kernel/Makefile
|
||||||
+++ linux-2.6.31.5.new/arch/mips/kernel/Makefile 2009-10-25 15:24:04.713493469 +0200
|
|
||||||
@@ -2,6 +2,8 @@
|
@@ -2,6 +2,8 @@
|
||||||
# Makefile for the Linux/MIPS kernel.
|
# Makefile for the Linux/MIPS kernel.
|
||||||
#
|
#
|
||||||
|
@ -10,10 +9,9 @@ diff -Nru linux-2.6.31.5/arch/mips/kernel/Makefile linux-2.6.31.5.new/arch/mips/
|
||||||
extra-y := head.o init_task.o vmlinux.lds
|
extra-y := head.o init_task.o vmlinux.lds
|
||||||
|
|
||||||
obj-y += cpu-probe.o branch.o entry.o genex.o irq.o process.o \
|
obj-y += cpu-probe.o branch.o entry.o genex.o irq.o process.o \
|
||||||
diff -Nru linux-2.6.31.5/arch/mips/kernel/vmlinux.lds.S linux-2.6.31.5.new/arch/mips/kernel/vmlinux.lds.S
|
--- a/arch/mips/kernel/vmlinux.lds.S
|
||||||
--- linux-2.6.31.5/arch/mips/kernel/vmlinux.lds.S 2009-10-23 01:57:56.000000000 +0300
|
+++ b/arch/mips/kernel/vmlinux.lds.S
|
||||||
+++ linux-2.6.31.5.new/arch/mips/kernel/vmlinux.lds.S 2009-10-25 15:26:11.631618513 +0200
|
@@ -10,15 +10,15 @@ PHDRS {
|
||||||
@@ -10,15 +10,15 @@
|
|
||||||
note PT_NOTE FLAGS(4); /* R__ */
|
note PT_NOTE FLAGS(4); /* R__ */
|
||||||
}
|
}
|
||||||
|
|
||||||
|
|
|
@ -1,5 +1,5 @@
|
||||||
--- a/include/linux/mtd/partitions.h 2009-10-29 11:24:29.000000000 +0100
|
--- a/include/linux/mtd/partitions.h
|
||||||
+++ b/include/linux/mtd/partitions.h 2009-10-29 11:26:35.000000000 +0100
|
+++ b/include/linux/mtd/partitions.h
|
||||||
@@ -33,6 +33,7 @@
|
@@ -33,6 +33,7 @@
|
||||||
* Note: writeable partitions require their size and offset be
|
* Note: writeable partitions require their size and offset be
|
||||||
* erasesize aligned (e.g. use MTDPART_OFS_NEXTBLK).
|
* erasesize aligned (e.g. use MTDPART_OFS_NEXTBLK).
|
||||||
|
@ -8,7 +8,7 @@
|
||||||
|
|
||||||
struct mtd_partition;
|
struct mtd_partition;
|
||||||
struct mtd_partition {
|
struct mtd_partition {
|
||||||
@@ -49,7 +50,6 @@
|
@@ -49,7 +50,6 @@ struct mtd_partition {
|
||||||
#define MTDPART_SIZ_FULL (0)
|
#define MTDPART_SIZ_FULL (0)
|
||||||
|
|
||||||
|
|
||||||
|
|
Loading…
Reference in New Issue