[kernel] refresh 2.6.32 patches

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21783 3c298f89-4303-0410-b956-a3cf2f4a3e73
master
Florian Fainelli 2010-06-13 12:20:42 +00:00
parent 2e2a19f327
commit 0db2a74b2d
20 changed files with 70 additions and 70 deletions

View File

@ -127,11 +127,10 @@
e = (struct ipt_entry *)(loc_cpu_entry + off); e = (struct ipt_entry *)(loc_cpu_entry + off);
if (copy_to_user(userptr + off if (copy_to_user(userptr + off
@@ -1001,6 +1041,14 @@ copy_entries_to_user(unsigned int total_ @@ -1002,6 +1042,14 @@ copy_entries_to_user(unsigned int total_
ret = -EFAULT;
goto free_counters; goto free_counters;
} }
+
+ flags = e->ip.flags & ~IPT_F_NO_DEF_MATCH; + flags = e->ip.flags & ~IPT_F_NO_DEF_MATCH;
+ if (copy_to_user(userptr + off + if (copy_to_user(userptr + off
+ + offsetof(struct ipt_entry, ip.flags), + + offsetof(struct ipt_entry, ip.flags),
@ -139,6 +138,7 @@
+ ret = -EFAULT; + ret = -EFAULT;
+ goto free_counters; + goto free_counters;
+ } + }
+
for (i = sizeof(struct ipt_entry); for (i = sizeof(struct ipt_entry);
i < e->target_offset; i < e->target_offset;
i += m->u.match_size) {

View File

@ -11038,14 +11038,14 @@
+ yaffs_UnpackTags2(tags, &pt); + yaffs_UnpackTags2(tags, &pt);
+ } + }
+ } + }
+
- if(tags && retval == -EBADMSG && tags->eccResult == YAFFS_ECC_RESULT_NO_ERROR)
- tags->eccResult = YAFFS_ECC_RESULT_UNFIXED;
+ if (localData) + if (localData)
+ yaffs_ReleaseTempBuffer(dev, data, __LINE__); + yaffs_ReleaseTempBuffer(dev, data, __LINE__);
- if(tags && retval == -EBADMSG && tags->eccResult == YAFFS_ECC_RESULT_NO_ERROR)
+ if (tags && retval == -EBADMSG && tags->eccResult == YAFFS_ECC_RESULT_NO_ERROR) + if (tags && retval == -EBADMSG && tags->eccResult == YAFFS_ECC_RESULT_NO_ERROR)
tags->eccResult = YAFFS_ECC_RESULT_UNFIXED; + tags->eccResult = YAFFS_ECC_RESULT_UNFIXED;
-
if (retval == 0) if (retval == 0)
return YAFFS_OK; return YAFFS_OK;
else else

View File

@ -1,6 +1,6 @@
--- a/include/linux/phy.h --- a/include/linux/phy.h
+++ b/include/linux/phy.h +++ b/include/linux/phy.h
@@ -393,9 +393,18 @@ struct phy_driver { @@ -379,9 +379,18 @@ struct phy_driver {
*/ */
int (*config_aneg)(struct phy_device *phydev); int (*config_aneg)(struct phy_device *phydev);
@ -21,7 +21,7 @@
--- a/drivers/net/phy/phy_device.c --- a/drivers/net/phy/phy_device.c
+++ b/drivers/net/phy/phy_device.c +++ b/drivers/net/phy/phy_device.c
@@ -695,6 +695,9 @@ int genphy_update_link(struct phy_device @@ -681,6 +681,9 @@ int genphy_update_link(struct phy_device
{ {
int status; int status;

View File

@ -1,7 +1,7 @@
--- a/drivers/net/phy/Kconfig --- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig +++ b/drivers/net/phy/Kconfig
@@ -106,6 +106,10 @@ config IP175C_PHY @@ -106,6 +106,10 @@ config IP17XX_PHY
tristate "Driver for IC+ IP175C/IP178C switches" tristate "Driver for IC+ IP17xx switches"
select SWCONFIG select SWCONFIG
+config AR8216_PHY +config AR8216_PHY
@ -15,7 +15,7 @@
+++ b/drivers/net/phy/Makefile +++ b/drivers/net/phy/Makefile
@@ -18,6 +18,7 @@ obj-$(CONFIG_ADM6996_PHY) += adm6996.o @@ -18,6 +18,7 @@ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
obj-$(CONFIG_IP175C_PHY) += ip175c.o obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
obj-$(CONFIG_REALTEK_PHY) += realtek.o obj-$(CONFIG_REALTEK_PHY) += realtek.o
+obj-$(CONFIG_AR8216_PHY) += ar8216.o +obj-$(CONFIG_AR8216_PHY) += ar8216.o
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o

View File

@ -14,7 +14,7 @@
--- a/drivers/net/phy/Makefile --- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile +++ b/drivers/net/phy/Makefile
@@ -19,6 +19,7 @@ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o @@ -19,6 +19,7 @@ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
obj-$(CONFIG_IP175C_PHY) += ip175c.o obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
obj-$(CONFIG_REALTEK_PHY) += realtek.o obj-$(CONFIG_REALTEK_PHY) += realtek.o
obj-$(CONFIG_AR8216_PHY) += ar8216.o obj-$(CONFIG_AR8216_PHY) += ar8216.o
+obj-$(CONFIG_RTL8306_PHY) += rtl8306.o +obj-$(CONFIG_RTL8306_PHY) += rtl8306.o

View File

@ -32,7 +32,7 @@
endif # PHYLIB endif # PHYLIB
--- a/drivers/net/phy/Makefile --- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile +++ b/drivers/net/phy/Makefile
@@ -20,6 +20,9 @@ obj-$(CONFIG_IP175C_PHY) += ip175c.o @@ -20,6 +20,9 @@ obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
obj-$(CONFIG_REALTEK_PHY) += realtek.o obj-$(CONFIG_REALTEK_PHY) += realtek.o
obj-$(CONFIG_AR8216_PHY) += ar8216.o obj-$(CONFIG_AR8216_PHY) += ar8216.o
obj-$(CONFIG_RTL8306_PHY) += rtl8306.o obj-$(CONFIG_RTL8306_PHY) += rtl8306.o

View File

@ -404,10 +404,7 @@
+static int ssb_pcmcia_get_mac(struct pcmcia_device *p_dev, +static int ssb_pcmcia_get_mac(struct pcmcia_device *p_dev,
+ tuple_t *tuple, + tuple_t *tuple,
+ void *priv) + void *priv)
{ +{
- tuple_t tuple;
- int res;
- unsigned char buf[32];
+ struct ssb_sprom *sprom = priv; + struct ssb_sprom *sprom = priv;
+ +
+ if (tuple->TupleData[0] != CISTPL_FUNCE_LAN_NODE_ID) + if (tuple->TupleData[0] != CISTPL_FUNCE_LAN_NODE_ID)
@ -423,7 +420,10 @@
+static int ssb_pcmcia_do_get_invariants(struct pcmcia_device *p_dev, +static int ssb_pcmcia_do_get_invariants(struct pcmcia_device *p_dev,
+ tuple_t *tuple, + tuple_t *tuple,
+ void *priv) + void *priv)
+{ {
- tuple_t tuple;
- int res;
- unsigned char buf[32];
+ struct ssb_init_invariants *iv = priv; + struct ssb_init_invariants *iv = priv;
struct ssb_sprom *sprom = &iv->sprom; struct ssb_sprom *sprom = &iv->sprom;
struct ssb_boardinfo *bi = &iv->boardinfo; struct ssb_boardinfo *bi = &iv->boardinfo;