[kernel] restore accidentally deleted ofc patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13293 3c298f89-4303-0410-b956-a3cf2f4a3e73master
parent
0fdf82f36a
commit
057c85aca2
|
@ -0,0 +1,25 @@
|
||||||
|
--- a/crypto/Kconfig
|
||||||
|
+++ b/crypto/Kconfig
|
||||||
|
@@ -675,6 +675,8 @@ config CRYPTO_PRNG
|
||||||
|
for cryptographic modules. Uses the Algorithm specified in
|
||||||
|
ANSI X9.31 A.2.4
|
||||||
|
|
||||||
|
+source "crypto/ocf/Kconfig"
|
||||||
|
+
|
||||||
|
source "drivers/crypto/Kconfig"
|
||||||
|
|
||||||
|
endif # if CRYPTO
|
||||||
|
--- a/crypto/Makefile
|
||||||
|
+++ b/crypto/Makefile
|
||||||
|
@@ -73,6 +73,11 @@ obj-$(CONFIG_CRYPTO_PRNG) += prng.o
|
||||||
|
obj-$(CONFIG_CRYPTO_TEST) += tcrypt.o
|
||||||
|
|
||||||
|
#
|
||||||
|
+# OCF
|
||||||
|
+#
|
||||||
|
+obj-$(CONFIG_OCF_OCF) += ocf/
|
||||||
|
+
|
||||||
|
+#
|
||||||
|
# generic algorithms and the async_tx api
|
||||||
|
#
|
||||||
|
obj-$(CONFIG_XOR_BLOCKS) += xor.o
|
|
@ -0,0 +1,25 @@
|
||||||
|
--- a/crypto/Kconfig
|
||||||
|
+++ b/crypto/Kconfig
|
||||||
|
@@ -666,6 +666,8 @@ config CRYPTO_LZO
|
||||||
|
help
|
||||||
|
This is the LZO algorithm.
|
||||||
|
|
||||||
|
+source "crypto/ocf/Kconfig"
|
||||||
|
+
|
||||||
|
source "drivers/crypto/Kconfig"
|
||||||
|
|
||||||
|
endif # if CRYPTO
|
||||||
|
--- a/crypto/Makefile
|
||||||
|
+++ b/crypto/Makefile
|
||||||
|
@@ -73,6 +73,11 @@ obj-$(CONFIG_CRYPTO_LZO) += lzo.o
|
||||||
|
obj-$(CONFIG_CRYPTO_TEST) += tcrypt.o
|
||||||
|
|
||||||
|
#
|
||||||
|
+# OCF
|
||||||
|
+#
|
||||||
|
+obj-$(CONFIG_OCF_OCF) += ocf/
|
||||||
|
+
|
||||||
|
+#
|
||||||
|
# generic algorithms and the async_tx api
|
||||||
|
#
|
||||||
|
obj-$(CONFIG_XOR_BLOCKS) += xor.o
|
Loading…
Reference in New Issue