uboot-kirkwood: bump to 2014.10
Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43436 3c298f89-4303-0410-b956-a3cf2f4a3e73master
parent
904e509b87
commit
03c303d3e9
|
@ -8,15 +8,15 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=u-boot
|
PKG_NAME:=u-boot
|
||||||
PKG_VERSION:=2014.07
|
PKG_VERSION:=2014.10
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:= \
|
PKG_SOURCE_URL:=\
|
||||||
http://mirror2.openwrt.org/sources \
|
http://mirror2.openwrt.org/sources \
|
||||||
ftp://ftp.denx.de/pub/u-boot
|
ftp://ftp.denx.de/pub/u-boot
|
||||||
PKG_MD5SUM:=36d4bad687edcafa396fee607e505d4e
|
PKG_MD5SUM:=3ddcaee2f05b7c464778112ec83664b5
|
||||||
PKG_TARGETS:=bin
|
PKG_TARGETS:=bin
|
||||||
|
|
||||||
PKG_LICENSE:=GPL-2.0 GPL-2.0+
|
PKG_LICENSE:=GPL-2.0 GPL-2.0+
|
||||||
|
@ -28,8 +28,6 @@ include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
define uboot/Default
|
define uboot/Default
|
||||||
TITLE:=
|
TITLE:=
|
||||||
CONFIG:=
|
|
||||||
IMAGE:=
|
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define uboot/dockstar
|
define uboot/dockstar
|
||||||
|
@ -97,15 +95,15 @@ define BuildUBootPackage
|
||||||
$(call Package/uboot/template,$(1),$(TITLE))
|
$(call Package/uboot/template,$(1),$(TITLE))
|
||||||
endef
|
endef
|
||||||
|
|
||||||
ifdef BUILD_VARIANT
|
|
||||||
$(eval $(call uboot/$(BUILD_VARIANT)))
|
|
||||||
UBOOT_CONFIG:=$(if $(CONFIG),$(CONFIG),$(BUILD_VARIANT))
|
|
||||||
UBOOT_IMAGE:=$(if $(IMAGE),$(IMAGE),openwrt-$(BOARD)-$(BUILD_VARIANT)-u-boot.bin)
|
|
||||||
endif
|
|
||||||
|
|
||||||
define Build/Configure
|
define Build/Configure
|
||||||
|
$(if $(findstring _second_stage,$(BUILD_VARIANT)),
|
||||||
|
$(CP) \
|
||||||
|
$(PKG_BUILD_DIR)/configs/$(subst _second_stage,,$(BUILD_VARIANT))_defconfig \
|
||||||
|
$(PKG_BUILD_DIR)/configs/$(BUILD_VARIANT)_defconfig
|
||||||
|
echo CONFIG_SECOND_STAGE=y >> $(PKG_BUILD_DIR)/configs/$(BUILD_VARIANT)_defconfig
|
||||||
|
)
|
||||||
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
|
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
|
||||||
$(UBOOT_CONFIG)_config
|
$(BUILD_VARIANT)_config V=1
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Build/Compile
|
define Build/Compile
|
||||||
|
|
|
@ -0,0 +1,96 @@
|
||||||
|
From 76a9fed9e5580945827a82963ac7315186fd0ebe Mon Sep 17 00:00:00 2001
|
||||||
|
From: Luka Perkov <luka@openwrt.org>
|
||||||
|
Date: Mon, 11 Nov 2013 06:45:44 +0100
|
||||||
|
Subject: [PATCH 1/9] cosmetic: kirkwood: style fixes in kwbimage.cfg files
|
||||||
|
|
||||||
|
When diffing through the changes only the relevant changes
|
||||||
|
should be displayed.
|
||||||
|
|
||||||
|
Signed-off-by: Luka Perkov <luka@openwrt.org>
|
||||||
|
---
|
||||||
|
board/iomega/iconnect/kwbimage.cfg | 4 ++--
|
||||||
|
board/raidsonic/ib62x0/kwbimage.cfg | 22 +++++++++++-----------
|
||||||
|
2 files changed, 13 insertions(+), 13 deletions(-)
|
||||||
|
|
||||||
|
--- a/board/iomega/iconnect/kwbimage.cfg
|
||||||
|
+++ b/board/iomega/iconnect/kwbimage.cfg
|
||||||
|
@@ -20,7 +20,7 @@ NAND_PAGE_SIZE 0x0800
|
||||||
|
# Configure RGMII-0 interface pad voltage to 1.8V
|
||||||
|
DATA 0xffd100e0 0x1b1b1b9b
|
||||||
|
|
||||||
|
-#Dram initalization for SINGLE x16 CL=5 @ 400MHz
|
||||||
|
+# Dram initalization for SINGLE x16 CL=5 @ 400MHz
|
||||||
|
DATA 0xffd01400 0x43000c30 # DDR Configuration register
|
||||||
|
# bit13-0: 0xc30, (3120 DDR2 clks refresh rate)
|
||||||
|
# bit23-14: 0x0,
|
||||||
|
@@ -87,7 +87,7 @@ DATA 0xffd0141c 0x00000c52 # DDR Mode
|
||||||
|
# bit6-4: 0x4, CL=5
|
||||||
|
# bit7: 0x0, TestMode=0 normal
|
||||||
|
# bit8: 0x0, DLL reset=0 normal
|
||||||
|
-# bit11-9: 0x6, auto-precharge write recovery ????????????
|
||||||
|
+# bit11-9: 0x6, auto-precharge write recovery
|
||||||
|
# bit12: 0x0, PD must be zero
|
||||||
|
# bit31-13: 0x0, required
|
||||||
|
|
||||||
|
--- a/board/raidsonic/ib62x0/kwbimage.cfg
|
||||||
|
+++ b/board/raidsonic/ib62x0/kwbimage.cfg
|
||||||
|
@@ -11,7 +11,7 @@
|
||||||
|
#
|
||||||
|
|
||||||
|
# Boot Media configurations
|
||||||
|
-BOOT_FROM nand # change from nand to uart if building UART image
|
||||||
|
+BOOT_FROM nand
|
||||||
|
NAND_ECC_MODE default
|
||||||
|
NAND_PAGE_SIZE 0x0800
|
||||||
|
|
||||||
|
@@ -21,12 +21,12 @@ NAND_PAGE_SIZE 0x0800
|
||||||
|
# Configure RGMII-0 interface pad voltage to 1.8V
|
||||||
|
DATA 0xffd100e0 0x1b1b1b9b
|
||||||
|
|
||||||
|
-#Dram initalization for SINGLE x16 CL=5 @ 400MHz
|
||||||
|
+# Dram initalization for SINGLE x16 CL=5 @ 400MHz
|
||||||
|
DATA 0xffd01400 0x43000c30 # DDR Configuration register
|
||||||
|
# bit13-0: 0xc30, (3120 DDR2 clks refresh rate)
|
||||||
|
# bit23-14: 0x0,
|
||||||
|
-# bit24: 0x1, enable exit self refresh mode on DDR access
|
||||||
|
-# bit25: 0x1, required
|
||||||
|
+# bit24: 0x1, enable exit self refresh mode on DDR access
|
||||||
|
+# bit25: 0x1, required
|
||||||
|
# bit29-26: 0x0,
|
||||||
|
# bit31-30: 0x1,
|
||||||
|
|
||||||
|
@@ -64,10 +64,10 @@ DATA 0xffd01410 0x0000000c # DDR Address
|
||||||
|
# bit3-2: 11, Cs0size (1Gb)
|
||||||
|
# bit5-4: 00, Cs1width (x8)
|
||||||
|
# bit7-6: 11, Cs1size (1Gb)
|
||||||
|
-# bit9-8: 00, Cs2width (nonexistent
|
||||||
|
-# bit11-10: 00, Cs2size (nonexistent
|
||||||
|
-# bit13-12: 00, Cs3width (nonexistent
|
||||||
|
-# bit15-14: 00, Cs3size (nonexistent
|
||||||
|
+# bit9-8: 00, Cs2width (nonexistent)
|
||||||
|
+# bit11-10: 00, Cs2size (nonexistent)
|
||||||
|
+# bit13-12: 00, Cs3width (nonexistent)
|
||||||
|
+# bit15-14: 00, Cs3size (nonexistent)
|
||||||
|
# bit16: 0, Cs0AddrSel
|
||||||
|
# bit17: 0, Cs1AddrSel
|
||||||
|
# bit18: 0, Cs2AddrSel
|
||||||
|
@@ -88,7 +88,7 @@ DATA 0xffd0141c 0x00000c52 # DDR Mode
|
||||||
|
# bit6-4: 0x4, CL=5
|
||||||
|
# bit7: 0x0, TestMode=0 normal
|
||||||
|
# bit8: 0x0, DLL reset=0 normal
|
||||||
|
-# bit11-9: 0x6, auto-precharge write recovery ????????????
|
||||||
|
+# bit11-9: 0x6, auto-precharge write recovery
|
||||||
|
# bit12: 0x0, PD must be zero
|
||||||
|
# bit31-13: 0x0, required
|
||||||
|
|
||||||
|
@@ -148,8 +148,8 @@ DATA 0xffd0149c 0x0000e803 # CPU ODT Con
|
||||||
|
DATA 0xffd01480 0x00000001 # DDR Initialization Control
|
||||||
|
# bit0: 0x1, enable DDR init upon this register write
|
||||||
|
|
||||||
|
-DATA 0xFFD20134 0x66666666 # L2 RAM Timing 0 Register
|
||||||
|
-DATA 0xFFD20138 0x66666666 # L2 RAM Timing 1 Register
|
||||||
|
+DATA 0xffd20134 0x66666666 # L2 RAM Timing 0 Register
|
||||||
|
+DATA 0xffd20138 0x66666666 # L2 RAM Timing 1 Register
|
||||||
|
|
||||||
|
# End of Header extension
|
||||||
|
DATA 0x0 0x0
|
|
@ -0,0 +1,32 @@
|
||||||
|
From 292d4cf9257921912e8ea352687c977208e7553d Mon Sep 17 00:00:00 2001
|
||||||
|
From: Luka Perkov <luka@openwrt.org>
|
||||||
|
Date: Mon, 11 Nov 2013 07:27:53 +0100
|
||||||
|
Subject: [PATCH 2/9] kirkwood: define empty CONFIG_MVGBE_PORTS by default
|
||||||
|
|
||||||
|
Each board with defines it's own set of values. If we do not define
|
||||||
|
CONFIG_MVGBE_PORTS we will hit following error:
|
||||||
|
|
||||||
|
mvgbe.c: In function 'mvgbe_initialize':
|
||||||
|
mvgbe.c:700:34: error: 'CONFIG_MVGBE_PORTS' undeclared (first use in this function)
|
||||||
|
u8 used_ports[MAX_MVGBE_DEVS] = CONFIG_MVGBE_PORTS;
|
||||||
|
|
||||||
|
This patch fixes above described problem.
|
||||||
|
|
||||||
|
Signed-off-by: Luka Perkov <luka@openwrt.org>
|
||||||
|
---
|
||||||
|
drivers/net/mvgbe.c | 4 ++++
|
||||||
|
1 file changed, 4 insertions(+)
|
||||||
|
|
||||||
|
--- a/drivers/net/mvgbe.c
|
||||||
|
+++ b/drivers/net/mvgbe.c
|
||||||
|
@@ -35,6 +35,10 @@
|
||||||
|
|
||||||
|
DECLARE_GLOBAL_DATA_PTR;
|
||||||
|
|
||||||
|
+#ifndef CONFIG_MVGBE_PORTS
|
||||||
|
+# define CONFIG_MVGBE_PORTS {0, 0}
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
#define MV_PHY_ADR_REQUEST 0xee
|
||||||
|
#define MVGBE_SMI_REG (((struct mvgbe_registers *)MVGBE0_BASE)->smi)
|
||||||
|
|
|
@ -0,0 +1,45 @@
|
||||||
|
From fa0ece2cc571ba1ccb9d1e0a8d337417c032576e Mon Sep 17 00:00:00 2001
|
||||||
|
From: Luka Perkov <luka@openwrt.org>
|
||||||
|
Date: Mon, 23 Dec 2013 01:23:07 +0100
|
||||||
|
Subject: [PATCH 3/9] ARM: kirkwood: fix cpu info for 6282 device id
|
||||||
|
|
||||||
|
Signed-off-by: Luka Perkov <luka@openwrt.org>
|
||||||
|
CC: Prafulla Wadaskar <prafulla@marvell.com>
|
||||||
|
---
|
||||||
|
arch/arm/cpu/arm926ejs/kirkwood/cpu.c | 11 ++++++++---
|
||||||
|
1 file changed, 8 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
|
--- a/arch/arm/cpu/arm926ejs/kirkwood/cpu.c
|
||||||
|
+++ b/arch/arm/cpu/arm926ejs/kirkwood/cpu.c
|
||||||
|
@@ -253,7 +253,7 @@ static void kw_sysrst_check(void)
|
||||||
|
#if defined(CONFIG_DISPLAY_CPUINFO)
|
||||||
|
int print_cpuinfo(void)
|
||||||
|
{
|
||||||
|
- char *rev;
|
||||||
|
+ char *rev = "??";
|
||||||
|
u16 devid = (readl(KW_REG_PCIE_DEVID) >> 16) & 0xffff;
|
||||||
|
u8 revid = readl(KW_REG_PCIE_REVID) & 0xff;
|
||||||
|
|
||||||
|
@@ -264,7 +264,13 @@ int print_cpuinfo(void)
|
||||||
|
|
||||||
|
switch (revid) {
|
||||||
|
case 0:
|
||||||
|
- rev = "Z0";
|
||||||
|
+ if (devid == 0x6281)
|
||||||
|
+ rev = "Z0";
|
||||||
|
+ else if (devid == 0x6282)
|
||||||
|
+ rev = "A0";
|
||||||
|
+ break;
|
||||||
|
+ case 1:
|
||||||
|
+ rev = "A1";
|
||||||
|
break;
|
||||||
|
case 2:
|
||||||
|
rev = "A0";
|
||||||
|
@@ -273,7 +279,6 @@ int print_cpuinfo(void)
|
||||||
|
rev = "A1";
|
||||||
|
break;
|
||||||
|
default:
|
||||||
|
- rev = "??";
|
||||||
|
break;
|
||||||
|
}
|
||||||
|
|
|
@ -0,0 +1,27 @@
|
||||||
|
From 280b03ba28b4287de677d4c4b097918364395b5e Mon Sep 17 00:00:00 2001
|
||||||
|
From: Luka Perkov <luka@openwrt.org>
|
||||||
|
Date: Wed, 2 Jul 2014 01:47:23 +0200
|
||||||
|
Subject: [PATCH 4/9] kirkwood: ib62x0: add CONFIG_SYS_GENERIC_BOARD define
|
||||||
|
|
||||||
|
Signed-off-by: Luka Perkov <luka@openwrt.org>
|
||||||
|
CC: Prafulla Wadaskar <prafulla@marvell.com>
|
||||||
|
CC: Stefan Roese <sr@denx.de>
|
||||||
|
---
|
||||||
|
This is patch was sent already in July:
|
||||||
|
|
||||||
|
http://lists.denx.de/pipermail/u-boot/2014-July/182900.html
|
||||||
|
---
|
||||||
|
include/configs/ib62x0.h | 2 ++
|
||||||
|
1 file changed, 2 insertions(+)
|
||||||
|
|
||||||
|
--- a/include/configs/ib62x0.h
|
||||||
|
+++ b/include/configs/ib62x0.h
|
||||||
|
@@ -9,6 +9,8 @@
|
||||||
|
#ifndef _CONFIG_IB62x0_H
|
||||||
|
#define _CONFIG_IB62x0_H
|
||||||
|
|
||||||
|
+#define CONFIG_SYS_GENERIC_BOARD
|
||||||
|
+
|
||||||
|
/*
|
||||||
|
* Version number information
|
||||||
|
*/
|
|
@ -0,0 +1,23 @@
|
||||||
|
From 5f9e6f640098e6963ff9b470cd5d2ab9f6a3579e Mon Sep 17 00:00:00 2001
|
||||||
|
From: Luka Perkov <luka@openwrt.org>
|
||||||
|
Date: Sun, 30 Nov 2014 02:40:37 +0100
|
||||||
|
Subject: [PATCH 5/9] kirkwood: dockstar: add CONFIG_SYS_GENERIC_BOARD define
|
||||||
|
|
||||||
|
Signed-off-by: Luka Perkov <luka@openwrt.org>
|
||||||
|
CC: Prafulla Wadaskar <prafulla@marvell.com>
|
||||||
|
CC: Stefan Roese <sr@denx.de>
|
||||||
|
---
|
||||||
|
include/configs/dockstar.h | 2 ++
|
||||||
|
1 file changed, 2 insertions(+)
|
||||||
|
|
||||||
|
--- a/include/configs/dockstar.h
|
||||||
|
+++ b/include/configs/dockstar.h
|
||||||
|
@@ -12,6 +12,8 @@
|
||||||
|
#ifndef _CONFIG_DOCKSTAR_H
|
||||||
|
#define _CONFIG_DOCKSTAR_H
|
||||||
|
|
||||||
|
+#define CONFIG_SYS_GENERIC_BOARD
|
||||||
|
+
|
||||||
|
/*
|
||||||
|
* Version number information
|
||||||
|
*/
|
|
@ -0,0 +1,23 @@
|
||||||
|
From 0d0a6606396f0cc1a4f2966d167ef9e85d533650 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Luka Perkov <luka@openwrt.org>
|
||||||
|
Date: Sun, 30 Nov 2014 02:40:51 +0100
|
||||||
|
Subject: [PATCH 6/9] kirkwood: goflexhome: add CONFIG_SYS_GENERIC_BOARD define
|
||||||
|
|
||||||
|
Signed-off-by: Luka Perkov <luka@openwrt.org>
|
||||||
|
CC: Prafulla Wadaskar <prafulla@marvell.com>
|
||||||
|
CC: Stefan Roese <sr@denx.de>
|
||||||
|
---
|
||||||
|
include/configs/goflexhome.h | 2 ++
|
||||||
|
1 file changed, 2 insertions(+)
|
||||||
|
|
||||||
|
--- a/include/configs/goflexhome.h
|
||||||
|
+++ b/include/configs/goflexhome.h
|
||||||
|
@@ -15,6 +15,8 @@
|
||||||
|
#ifndef _CONFIG_GOFLEXHOME_H
|
||||||
|
#define _CONFIG_GOFLEXHOME_H
|
||||||
|
|
||||||
|
+#define CONFIG_SYS_GENERIC_BOARD
|
||||||
|
+
|
||||||
|
/*
|
||||||
|
* Version number information
|
||||||
|
*/
|
|
@ -0,0 +1,23 @@
|
||||||
|
From 45ba20427135e526cfa528773de0cfe215f4dc40 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Luka Perkov <luka@openwrt.org>
|
||||||
|
Date: Sun, 30 Nov 2014 02:41:04 +0100
|
||||||
|
Subject: [PATCH 7/9] kirkwood: iconnect: add CONFIG_SYS_GENERIC_BOARD define
|
||||||
|
|
||||||
|
Signed-off-by: Luka Perkov <luka@openwrt.org>
|
||||||
|
CC: Prafulla Wadaskar <prafulla@marvell.com>
|
||||||
|
CC: Stefan Roese <sr@denx.de>
|
||||||
|
---
|
||||||
|
include/configs/iconnect.h | 2 ++
|
||||||
|
1 file changed, 2 insertions(+)
|
||||||
|
|
||||||
|
--- a/include/configs/iconnect.h
|
||||||
|
+++ b/include/configs/iconnect.h
|
||||||
|
@@ -9,6 +9,8 @@
|
||||||
|
#ifndef _CONFIG_ICONNECT_H
|
||||||
|
#define _CONFIG_ICONNECT_H
|
||||||
|
|
||||||
|
+#define CONFIG_SYS_GENERIC_BOARD
|
||||||
|
+
|
||||||
|
/*
|
||||||
|
* Version number information
|
||||||
|
*/
|
|
@ -0,0 +1,23 @@
|
||||||
|
From bd862f4e7a559e38763a5280e35bf7ff14b535f1 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Luka Perkov <luka@openwrt.org>
|
||||||
|
Date: Sun, 30 Nov 2014 02:41:19 +0100
|
||||||
|
Subject: [PATCH 8/9] kirkwood: pogo_e02: add CONFIG_SYS_GENERIC_BOARD define
|
||||||
|
|
||||||
|
Signed-off-by: Luka Perkov <luka@openwrt.org>
|
||||||
|
CC: Prafulla Wadaskar <prafulla@marvell.com>
|
||||||
|
CC: Stefan Roese <sr@denx.de>
|
||||||
|
---
|
||||||
|
include/configs/pogo_e02.h | 2 ++
|
||||||
|
1 file changed, 2 insertions(+)
|
||||||
|
|
||||||
|
--- a/include/configs/pogo_e02.h
|
||||||
|
+++ b/include/configs/pogo_e02.h
|
||||||
|
@@ -13,6 +13,8 @@
|
||||||
|
#ifndef _CONFIG_POGO_E02_H
|
||||||
|
#define _CONFIG_POGO_E02_H
|
||||||
|
|
||||||
|
+#define CONFIG_SYS_GENERIC_BOARD
|
||||||
|
+
|
||||||
|
/*
|
||||||
|
* Machine type definition and ID
|
||||||
|
*/
|
|
@ -0,0 +1,23 @@
|
||||||
|
From 787e23179708ddad7ecd9dcd6c841546689864b0 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Luka Perkov <luka@openwrt.org>
|
||||||
|
Date: Sun, 30 Nov 2014 02:41:49 +0100
|
||||||
|
Subject: [PATCH 9/9] kirkwood: sheevaplug: add CONFIG_SYS_GENERIC_BOARD define
|
||||||
|
|
||||||
|
Signed-off-by: Luka Perkov <luka@openwrt.org>
|
||||||
|
CC: Prafulla Wadaskar <prafulla@marvell.com>
|
||||||
|
CC: Stefan Roese <sr@denx.de>
|
||||||
|
---
|
||||||
|
include/configs/sheevaplug.h | 2 ++
|
||||||
|
1 file changed, 2 insertions(+)
|
||||||
|
|
||||||
|
--- a/include/configs/sheevaplug.h
|
||||||
|
+++ b/include/configs/sheevaplug.h
|
||||||
|
@@ -10,6 +10,8 @@
|
||||||
|
#ifndef _CONFIG_SHEEVAPLUG_H
|
||||||
|
#define _CONFIG_SHEEVAPLUG_H
|
||||||
|
|
||||||
|
+#define CONFIG_SYS_GENERIC_BOARD
|
||||||
|
+
|
||||||
|
/*
|
||||||
|
* Version number information
|
||||||
|
*/
|
|
@ -1,22 +1,20 @@
|
||||||
--- a/include/configs/dockstar.h
|
--- a/include/configs/dockstar.h
|
||||||
+++ b/include/configs/dockstar.h
|
+++ b/include/configs/dockstar.h
|
||||||
@@ -15,21 +15,26 @@
|
@@ -17,20 +17,25 @@
|
||||||
/*
|
/*
|
||||||
* Version number information
|
* Version number information
|
||||||
*/
|
*/
|
||||||
-#define CONFIG_IDENT_STRING "\nSeagate FreeAgent DockStar"
|
-#define CONFIG_IDENT_STRING "\nSeagate FreeAgent DockStar"
|
||||||
+#define CONFIG_IDENT_STRING " Seagate FreeAgent DockStar"
|
+#define CONFIG_IDENT_STRING "Seagate FreeAgent DockStar"
|
||||||
|
|
||||||
/*
|
/*
|
||||||
- * High Level Configuration Options (easy to change)
|
- * High Level Configuration Options (easy to change)
|
||||||
+ * High level configuration options
|
+ * High Level Configuration Options
|
||||||
*/
|
*/
|
||||||
-#define CONFIG_FEROCEON_88FR131 1 /* CPU Core subversion */
|
-#define CONFIG_FEROCEON_88FR131 1 /* CPU Core subversion */
|
||||||
-#define CONFIG_KIRKWOOD 1 /* SOC Family Name */
|
|
||||||
-#define CONFIG_KW88F6281 1 /* SOC Name */
|
-#define CONFIG_KW88F6281 1 /* SOC Name */
|
||||||
-#define CONFIG_MACH_DOCKSTAR /* Machine type */
|
-#define CONFIG_MACH_DOCKSTAR /* Machine type */
|
||||||
+#define CONFIG_FEROCEON_88FR131 /* CPU Core subversion */
|
+#define CONFIG_FEROCEON_88FR131 /* CPU Core subversion */
|
||||||
+#define CONFIG_KIRKWOOD /* SOC Family Name */
|
|
||||||
+#define CONFIG_KW88F6281 /* SOC Name */
|
+#define CONFIG_KW88F6281 /* SOC Name */
|
||||||
#define CONFIG_SKIP_LOWLEVEL_INIT /* disable board lowlevel_init */
|
#define CONFIG_SKIP_LOWLEVEL_INIT /* disable board lowlevel_init */
|
||||||
|
|
||||||
|
@ -34,7 +32,7 @@
|
||||||
#include <config_cmd_default.h>
|
#include <config_cmd_default.h>
|
||||||
#define CONFIG_CMD_DHCP
|
#define CONFIG_CMD_DHCP
|
||||||
#define CONFIG_CMD_ENV
|
#define CONFIG_CMD_ENV
|
||||||
@@ -37,55 +42,58 @@
|
@@ -38,55 +43,58 @@
|
||||||
#define CONFIG_CMD_NAND
|
#define CONFIG_CMD_NAND
|
||||||
#define CONFIG_CMD_PING
|
#define CONFIG_CMD_PING
|
||||||
#define CONFIG_CMD_USB
|
#define CONFIG_CMD_USB
|
||||||
|
@ -120,7 +118,7 @@
|
||||||
*/
|
*/
|
||||||
#ifdef CONFIG_CMD_NET
|
#ifdef CONFIG_CMD_NET
|
||||||
#define CONFIG_MVGBE_PORTS {1, 0} /* enable port 0 only */
|
#define CONFIG_MVGBE_PORTS {1, 0} /* enable port 0 only */
|
||||||
@@ -101,7 +109,7 @@
|
@@ -102,7 +110,7 @@
|
||||||
#define CONFIG_CMD_UBI
|
#define CONFIG_CMD_UBI
|
||||||
#define CONFIG_CMD_UBIFS
|
#define CONFIG_CMD_UBIFS
|
||||||
#define CONFIG_RBTREE
|
#define CONFIG_RBTREE
|
||||||
|
@ -129,13 +127,3 @@
|
||||||
#define CONFIG_MTD_PARTITIONS
|
#define CONFIG_MTD_PARTITIONS
|
||||||
#define CONFIG_CMD_MTDPARTS
|
#define CONFIG_CMD_MTDPARTS
|
||||||
#define CONFIG_LZO
|
#define CONFIG_LZO
|
||||||
--- a/boards.cfg
|
|
||||||
+++ b/boards.cfg
|
|
||||||
@@ -198,6 +198,7 @@ Active arm arm926ejs kirkw
|
|
||||||
Active arm arm926ejs kirkwood Marvell sheevaplug sheevaplug - Prafulla Wadaskar <prafulla@marvell.com>
|
|
||||||
Active arm arm926ejs kirkwood raidsonic ib62x0 ib62x0 - Luka Perkov <luka@openwrt.org>
|
|
||||||
Active arm arm926ejs kirkwood Seagate dockstar dockstar - Eric Cooper <ecc@cmu.edu>
|
|
||||||
+Active arm arm926ejs kirkwood Seagate dockstar dockstar_second_stage dockstar:SECOND_STAGE Luka Perkov <luka@openwrt.org>
|
|
||||||
Active arm arm926ejs kirkwood Seagate goflexhome goflexhome - Suriyan Ramasami <suriyan.r@gmail.com>
|
|
||||||
Active arm arm926ejs lpc32xx timll devkit3250 devkit3250 - Vladimir Zapolskiy <vz@mleia.com>
|
|
||||||
Active arm arm926ejs mb86r0x syteco jadecpu jadecpu - Matthias Weisser <weisserm@arcor.de>
|
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/include/configs/iconnect.h
|
--- a/include/configs/iconnect.h
|
||||||
+++ b/include/configs/iconnect.h
|
+++ b/include/configs/iconnect.h
|
||||||
@@ -65,30 +65,35 @@
|
@@ -66,30 +66,35 @@
|
||||||
#define CONFIG_ENV_IS_NOWHERE
|
#define CONFIG_ENV_IS_NOWHERE
|
||||||
#endif
|
#endif
|
||||||
#define CONFIG_ENV_SIZE 0x20000
|
#define CONFIG_ENV_SIZE 0x20000
|
||||||
|
@ -45,13 +45,3 @@
|
||||||
|
|
||||||
/*
|
/*
|
||||||
* Ethernet driver configuration
|
* Ethernet driver configuration
|
||||||
--- a/boards.cfg
|
|
||||||
+++ b/boards.cfg
|
|
||||||
@@ -170,6 +170,7 @@ Active arm arm926ejs kirkw
|
|
||||||
Active arm arm926ejs kirkwood cloudengines pogo_e02 pogo_e02 - Dave Purdy <david.c.purdy@gmail.com>
|
|
||||||
Active arm arm926ejs kirkwood d-link dns325 dns325 - Stefan Herbrechtsmeier <stefan@code.herbrechtsmeier.net>
|
|
||||||
Active arm arm926ejs kirkwood iomega iconnect iconnect - Luka Perkov <luka@openwrt.org>
|
|
||||||
+Active arm arm926ejs kirkwood iomega iconnect iconnect_second_stage iconnect:SECOND_STAGE Luka Perkov <luka@openwrt.org>
|
|
||||||
Active arm arm926ejs kirkwood karo tk71 tk71 - -
|
|
||||||
Active arm arm926ejs kirkwood keymile km_arm km_kirkwood km_kirkwood:KM_KIRKWOOD Valentin Longchamp <valentin.longchamp@keymile.com>
|
|
||||||
Active arm arm926ejs kirkwood keymile km_arm km_kirkwood_128m16 km_kirkwood:KM_KIRKWOOD_128M16 Valentin Longchamp <valentin.longchamp@keymile.com>
|
|
||||||
|
|
|
@ -1,16 +1,6 @@
|
||||||
--- a/boards.cfg
|
|
||||||
+++ b/boards.cfg
|
|
||||||
@@ -198,6 +198,7 @@ Active arm arm926ejs kirkw
|
|
||||||
Active arm arm926ejs kirkwood Marvell rd6281a rd6281a - Prafulla Wadaskar <prafulla@marvell.com>
|
|
||||||
Active arm arm926ejs kirkwood Marvell sheevaplug sheevaplug - Prafulla Wadaskar <prafulla@marvell.com>
|
|
||||||
Active arm arm926ejs kirkwood raidsonic ib62x0 ib62x0 - Luka Perkov <luka@openwrt.org>
|
|
||||||
+Active arm arm926ejs kirkwood raidsonic ib62x0 ib62x0_second_stage ib62x0:SECOND_STAGE Luka Perkov <luka@openwrt.org>
|
|
||||||
Active arm arm926ejs kirkwood Seagate dockstar dockstar - Eric Cooper <ecc@cmu.edu>
|
|
||||||
Active arm arm926ejs kirkwood Seagate dockstar dockstar_second_stage dockstar:SECOND_STAGE Luka Perkov <luka@openwrt.org>
|
|
||||||
Active arm arm926ejs kirkwood Seagate goflexhome goflexhome - Suriyan Ramasami <suriyan.r@gmail.com>
|
|
||||||
--- a/include/configs/ib62x0.h
|
--- a/include/configs/ib62x0.h
|
||||||
+++ b/include/configs/ib62x0.h
|
+++ b/include/configs/ib62x0.h
|
||||||
@@ -91,7 +91,8 @@
|
@@ -92,7 +92,8 @@
|
||||||
"mtdparts=orion_nand:" \
|
"mtdparts=orion_nand:" \
|
||||||
"0xe0000@0x0(uboot)," \
|
"0xe0000@0x0(uboot)," \
|
||||||
"0x20000@0xe0000(uboot_env)," \
|
"0x20000@0xe0000(uboot_env)," \
|
||||||
|
@ -20,7 +10,7 @@
|
||||||
|
|
||||||
#define CONFIG_EXTRA_ENV_SETTINGS \
|
#define CONFIG_EXTRA_ENV_SETTINGS \
|
||||||
"console=console=ttyS0,115200\0" \
|
"console=console=ttyS0,115200\0" \
|
||||||
@@ -99,7 +100,7 @@
|
@@ -100,7 +101,7 @@
|
||||||
"mtdparts="CONFIG_MTDPARTS \
|
"mtdparts="CONFIG_MTDPARTS \
|
||||||
"kernel=/boot/zImage\0" \
|
"kernel=/boot/zImage\0" \
|
||||||
"fdt=/boot/ib62x0.dtb\0" \
|
"fdt=/boot/ib62x0.dtb\0" \
|
||||||
|
|
|
@ -1,16 +1,6 @@
|
||||||
--- a/boards.cfg
|
|
||||||
+++ b/boards.cfg
|
|
||||||
@@ -168,6 +168,7 @@ Active arm arm926ejs davin
|
|
||||||
Active arm arm926ejs kirkwood buffalo lsxl lschlv2 lsxl:LSCHLV2 Michael Walle <michael@walle.cc>
|
|
||||||
Active arm arm926ejs kirkwood buffalo lsxl lsxhl lsxl:LSXHL Michael Walle <michael@walle.cc>
|
|
||||||
Active arm arm926ejs kirkwood cloudengines pogo_e02 pogo_e02 - Dave Purdy <david.c.purdy@gmail.com>
|
|
||||||
+Active arm arm926ejs kirkwood cloudengines pogo_e02 pogo_e02_second_stage pogo_e02:SECOND_STAGE Felix Kaechele <felix@fetzig.org>
|
|
||||||
Active arm arm926ejs kirkwood d-link dns325 dns325 - Stefan Herbrechtsmeier <stefan@code.herbrechtsmeier.net>
|
|
||||||
Active arm arm926ejs kirkwood iomega iconnect iconnect - Luka Perkov <luka@openwrt.org>
|
|
||||||
Active arm arm926ejs kirkwood iomega iconnect iconnect_second_stage iconnect:SECOND_STAGE Luka Perkov <luka@openwrt.org>
|
|
||||||
--- a/include/configs/pogo_e02.h
|
--- a/include/configs/pogo_e02.h
|
||||||
+++ b/include/configs/pogo_e02.h
|
+++ b/include/configs/pogo_e02.h
|
||||||
@@ -62,23 +62,35 @@
|
@@ -63,23 +63,35 @@
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
#define CONFIG_ENV_SIZE 0x20000 /* 128k */
|
#define CONFIG_ENV_SIZE 0x20000 /* 128k */
|
||||||
|
|
|
@ -1,6 +1,16 @@
|
||||||
|
--- a/arch/arm/cpu/arm926ejs/kirkwood/Kconfig
|
||||||
|
+++ b/arch/arm/cpu/arm926ejs/kirkwood/Kconfig
|
||||||
|
@@ -84,4 +84,7 @@
|
||||||
|
source "board/Seagate/dockstar/Kconfig"
|
||||||
|
source "board/Seagate/goflexhome/Kconfig"
|
||||||
|
|
||||||
|
+config SECOND_STAGE
|
||||||
|
+ bool "OpenWrt second stage hack"
|
||||||
|
+
|
||||||
|
endif
|
||||||
--- a/include/configs/dockstar.h
|
--- a/include/configs/dockstar.h
|
||||||
+++ b/include/configs/dockstar.h
|
+++ b/include/configs/dockstar.h
|
||||||
@@ -114,4 +114,6 @@
|
@@ -115,4 +115,6 @@
|
||||||
#define CONFIG_CMD_MTDPARTS
|
#define CONFIG_CMD_MTDPARTS
|
||||||
#define CONFIG_LZO
|
#define CONFIG_LZO
|
||||||
|
|
||||||
|
@ -9,7 +19,7 @@
|
||||||
#endif /* _CONFIG_DOCKSTAR_H */
|
#endif /* _CONFIG_DOCKSTAR_H */
|
||||||
--- a/include/configs/ib62x0.h
|
--- a/include/configs/ib62x0.h
|
||||||
+++ b/include/configs/ib62x0.h
|
+++ b/include/configs/ib62x0.h
|
||||||
@@ -144,4 +144,6 @@
|
@@ -145,4 +145,6 @@
|
||||||
#define CONFIG_MTD_PARTITIONS
|
#define CONFIG_MTD_PARTITIONS
|
||||||
#define CONFIG_CMD_MTDPARTS
|
#define CONFIG_CMD_MTDPARTS
|
||||||
|
|
||||||
|
@ -18,7 +28,7 @@
|
||||||
#endif /* _CONFIG_IB62x0_H */
|
#endif /* _CONFIG_IB62x0_H */
|
||||||
--- a/include/configs/iconnect.h
|
--- a/include/configs/iconnect.h
|
||||||
+++ b/include/configs/iconnect.h
|
+++ b/include/configs/iconnect.h
|
||||||
@@ -117,4 +117,6 @@
|
@@ -118,4 +118,6 @@
|
||||||
#define CONFIG_MTD_PARTITIONS
|
#define CONFIG_MTD_PARTITIONS
|
||||||
#define CONFIG_CMD_MTDPARTS
|
#define CONFIG_CMD_MTDPARTS
|
||||||
|
|
||||||
|
@ -82,7 +92,7 @@
|
||||||
+#endif /* __OPENWRT_KIRKWOOD_COMMON_H */
|
+#endif /* __OPENWRT_KIRKWOOD_COMMON_H */
|
||||||
--- a/include/configs/pogo_e02.h
|
--- a/include/configs/pogo_e02.h
|
||||||
+++ b/include/configs/pogo_e02.h
|
+++ b/include/configs/pogo_e02.h
|
||||||
@@ -114,4 +114,6 @@
|
@@ -115,4 +115,6 @@
|
||||||
#define CONFIG_CMD_MTDPARTS
|
#define CONFIG_CMD_MTDPARTS
|
||||||
#define CONFIG_LZO
|
#define CONFIG_LZO
|
||||||
|
|
||||||
|
@ -91,7 +101,7 @@
|
||||||
#endif /* _CONFIG_POGO_E02_H */
|
#endif /* _CONFIG_POGO_E02_H */
|
||||||
--- a/include/configs/sheevaplug.h
|
--- a/include/configs/sheevaplug.h
|
||||||
+++ b/include/configs/sheevaplug.h
|
+++ b/include/configs/sheevaplug.h
|
||||||
@@ -95,4 +95,6 @@
|
@@ -143,4 +143,6 @@
|
||||||
#define CONFIG_CMD_MTDPARTS
|
#define CONFIG_CMD_MTDPARTS
|
||||||
#define CONFIG_LZO
|
#define CONFIG_LZO
|
||||||
|
|
||||||
|
|
Loading…
Reference in New Issue