Kismet: Update to latest kismet rev, merge new kismet openwrt makefiles

dropping some of the old deps, python2, etc
master
Mike Kershaw / Dragorn 2022-03-14 13:49:02 -04:00
parent fe4e1a808c
commit 53e44e3805
19 changed files with 106 additions and 117 deletions

View File

@ -11,7 +11,7 @@ define Package/kismet-capture-linux-bluetooth
CATEGORY:=Network
TITLE:=Kismet HCI Bluetooth Support
URL:=https://www.kismetwireless.net
DEPENDS:=+libpthread +libpcap +libnl +libcap +protobuf-lite +libprotobuf-c +libwebsockets-full
DEPENDS:=+libpthread +libpcap +libnl +libcap +protobuf-lite +libprotobuf-c
SUBMENU:=kismet
endef

View File

@ -11,7 +11,7 @@ define Package/kismet-capture-linux-wifi
CATEGORY:=Network
TITLE:=Kismet Wi-Fi Capture Support
URL:=https://www.kismetwireless.net
DEPENDS:=+libpthread +libpcap +libnl +libcap +protobuf-lite +libprotobuf-c +libwebsockets-full
DEPENDS:=+libpthread +libpcap +libnl +libcap +protobuf-lite +libprotobuf-c
SUBMENU:=kismet
endef

View File

@ -11,7 +11,7 @@ define Package/kismet-capture-nrf-51822
CATEGORY:=Network
TITLE:=Kismet NRF51822 BTLE
URL:=https://www.kismetwireless.net
DEPENDS:=+libpthread +libpcap +libnl +libcap +protobuf-lite +libprotobuf-c +libusb-1.0 +libwebsockets-full
DEPENDS:=+libpthread +libpcap +libnl +libcap +protobuf-lite +libprotobuf-c +libusb-1.0
SUBMENU:=kismet
endef

View File

@ -0,0 +1,47 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=kismet-capture-nrf-52840
include ../kismet.mk
include $(INCLUDE_DIR)/package.mk
define Package/kismet-capture-nrf-52840
SECTION:=net
CATEGORY:=Network
TITLE:=Kismet NRF52840 Bluetooth Source
URL:=https://www.kismetwireless.net
DEPENDS:=+libpthread +libpcap +libnl +libcap +protobuf-lite +libprotobuf-c +libusb-1.0
SUBMENU:=kismet
endef
define Package/kismet-capture-nrf-52840/description
Helper binary to use an NRF52840 serial adapter as a Bluetooth capture source.
endef
define Build/Configure
$(call Build/Configure/Default,--with-linux-headers=$(LINUX_DIR))
endef
CONFIGURE_ARGS += \
$(CONFIGURE_OPTS) \
--enable-capture-tools-only
# Override libs to force lpthread because we don't detect it properly on openwrt
CONFIGURE_VARS += \
CXXFLAGS="$$$$CXXFLAGS" \
LIBS="-lm -lpthread"
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
LD="$(TARGET_CXX)" \
capture_nrf_52840/kismet_cap_nrf_52840
endef
define Package/kismet-capture-nrf-52840/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/capture_nrf_52840/kismet_cap_nrf_52840 $(1)/usr/bin/
endef
$(eval $(call BuildPackage,kismet-capture-nrf-52840))

View File

@ -11,7 +11,7 @@ define Package/kismet-capture-nxp-kw41z
CATEGORY:=Network
TITLE:=Kismet NXPKW41Z Capture Support
URL:=https://www.kismetwireless.net
DEPENDS:=+libpthread +libpcap +libnl +libcap +protobuf-lite +libprotobuf-c +libusb-1.0 +libwebsockets-full
DEPENDS:=+libpthread +libpcap +libnl +libcap +protobuf-lite +libprotobuf-c +libusb-1.0
SUBMENU:=kismet
endef

View File

@ -0,0 +1,48 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=kismet-capture-rz-killerbee
include ../kismet.mk
include $(INCLUDE_DIR)/package.mk
define Package/kismet-capture-rz-killerbee
SECTION:=net
CATEGORY:=Network
TITLE:=Kismet Killerbee Capture Support
URL:=https://www.kismetwireless.net
DEPENDS:=+libpthread +libpcap +libnl +libcap +protobuf-lite +libprotobuf-c +libusb-1.0
SUBMENU:=kismet
endef
define Package/kismet-capture-rz-killerbee/description
Helper binary to capture Zigbee from a Killerbee adapter.
Enables local and remote 802.15.4 packet capture with Kismet
endef
define Build/Configure
$(call Build/Configure/Default,--with-linux-headers=$(LINUX_DIR))
endef
CONFIGURE_ARGS += \
$(CONFIGURE_OPTS) \
--enable-capture-tools-only
# Override libs to force lpthread because we don't detect it properly on openwrt
CONFIGURE_VARS += \
CXXFLAGS="$$$$CXXFLAGS" \
LIBS="-lm -lpthread"
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
LD="$(TARGET_CXX)" \
capture_rz_killerbee/kismet_cap_rz_killerbee
endef
define Package/kismet-capture-rz-killerbee/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/capture_rz_killerbee/kismet_cap_rz_killerbee $(1)/usr/bin/
endef
$(eval $(call BuildPackage,kismet-capture-rz-killerbee))

View File

@ -7,7 +7,6 @@ PKG_NAME:=kismet-capture-sdr-rtl433
include ../kismet.mk
include $(INCLUDE_DIR)/package.mk
include $(TOPDIR)/feeds/packages/lang/python/python-package.mk
include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
KISMET_MODULE:=KismetCaptureRtl433

View File

@ -7,7 +7,6 @@ PKG_NAME:=kismet-capture-sdr-rtladsb
include ../kismet.mk
include $(INCLUDE_DIR)/package.mk
include $(TOPDIR)/feeds/packages/lang/python/python-package.mk
include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
KISMET_MODULE:=KismetCaptureRtladsb

View File

@ -7,7 +7,6 @@ PKG_NAME:=kismet-capture-sdr-rtlamr
include ../kismet.mk
include $(INCLUDE_DIR)/package.mk
include $(TOPDIR)/feeds/packages/lang/python/python-package.mk
include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
KISMET_MODULE:=KismetCaptureRtlamr

View File

@ -11,7 +11,7 @@ define Package/kismet-capture-ti-cc2531
CATEGORY:=Network
TITLE:=Kismet TI CC2531 802.15.4 Capture Support
URL:=https://www.kismetwireless.net
DEPENDS:=+libpthread +libpcap +libnl +libcap +protobuf-lite +libprotobuf-c +libusb-1.0 +libwebsockets-full
DEPENDS:=+libpthread +libpcap +libnl +libcap +protobuf-lite +libprotobuf-c +libusb-1.0
SUBMENU:=kismet
endef

View File

@ -11,7 +11,7 @@ define Package/kismet-capture-ti-cc2540
CATEGORY:=Network
TITLE:=Kismet TI CC2540 BTLE Capture Support
URL:=https://www.kismetwireless.net
DEPENDS:=+libpthread +libpcap +libnl +libcap +protobuf-lite +libprotobuf-c +libusb-1.0 +libwebsockets-full
DEPENDS:=+libpthread +libpcap +libnl +libcap +protobuf-lite +libprotobuf-c +libusb-1.0
SUBMENU:=kismet
endef

View File

@ -30,7 +30,7 @@ define Build/Compile
echo "No compilation needed"
endef
define Package/kismet-manuf-database/install
define Package/kismet-icao-database/install
$(INSTALL_DIR) $(1)/etc/kismet/
$(INSTALL_CONF) $(PKG_BUILD_DIR)/conf/kismet_adsb_icao.txt.gz $(1)/etc/kismet
endef

View File

@ -11,12 +11,12 @@ define Package/kismet-tools
CATEGORY:=Network
TITLE:=Kismet server and log tools
URL:=https://www.kismetwireless.net
DEPENDS:=+libpthread +libpcap +libpcre +libmicrohttpd +libnl +libcap +libstdcpp +libncurses +libsqlite3 +zlib +protobuf-lite +libprotobuf-c +libwebsockets-full kismet
DEPENDS:=+libpthread +libpcap +libpcre +libstdcpp +libsqlite3 +zlib
SUBMENU:=kismet
endef
define Package/kismet-tools/description
Kismet server and log manipulation tools for monitoring for announcing
Kismet server and log manipulation tools for discovering Kismet
servers and converting kismetdb logs to wigle, csv, json, pcap, etc.
endef

View File

@ -16,7 +16,7 @@ include $(INCLUDE_DIR)/package.mk
define Package/kismet
SECTION:=net
CATEGORY:=Network
TITLE:=Kismet 2020
TITLE:=Kismet 2021
URL:=https://www.kismetwireless.net/
DEPENDS:=+libpthread +libpcap +libpcre +libstdcpp +libncurses +libsqlite3 +zlib +protobuf-lite +libprotobuf-c +libsensors
SUBMENU:=kismet

View File

@ -1,37 +0,0 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=python3-cython
PKG_VERSION:=0.29.21
PKG_RELEASE:=1
PKG_SOURCE:=Cython-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/c/cython/
PKG_HASH:=e57acb89bd55943c8d8bf813763d20b9099cc7165c0f16b707631a7654be9cad
PKG_BUILD_DIR:=$(BUILD_DIR)/Cython-$(PKG_VERSION)
include $(INCLUDE_DIR)/package.mk
include $(TOPDIR)/feeds/packages/lang/python/python-package.mk
include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
define Package/python3-cython
SECTION:=lang
CATEGORY:=Languages
SUBMENU:=Python
TITLE:=Cython
URL:=https://pypi.org/project/Cython/
DEPENDS:= \
+python3-light \
+python3-setuptools
VARIANT:=python3
endef
define Package/python3-cython/description
C language extension library for Python
endef
$(eval $(call Py3Package,python3-cython))
$(eval $(call BuildPackage,python3-cython))
$(eval $(call BuildPackage,python3-cython-src))

View File

@ -1,40 +0,0 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=python3-numpy
PKG_VERSION:=1.19.1
PKG_RELEASE:=1
PKG_SOURCE:=numpy-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/numpy/numpy/releases/download/v${PKG_VERSION}/
PKG_HASH:=1396e6c3d20cbfc119195303b0272e749610b7042cc498be4134f013e9a3215c
PKG_BUILD_DIR:=$(BUILD_DIR)/numpy-$(PKG_VERSION)
HOST_PYTHON3_PACKAGE_BUILD_DEPENDS:=cython
include $(INCLUDE_DIR)/package.mk
include $(TOPDIR)/feeds/packages/lang/python/python-package.mk
include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
define Package/python3-numpy
SECTION:=lang
CATEGORY:=Languages
SUBMENU:=Python
TITLE:=Numpy
URL:=https://github.com/numpy/numpy
DEPENDS:= \
+PACKAGE_python3-numpy:python3-light \
+PACKAGE_python3-numpy:python3-setuptools \
+PACKAGE_python3-numpy:python3-cython
VARIANT:=python3
endef
define Package/python3-numpy/description
Numpy math library for Python3
endef
$(eval $(call Py3Package,python3-numpy))
$(eval $(call BuildPackage,python3-numpy))
$(eval $(call BuildPackage,python3-numpy-src))

View File

@ -1,24 +0,0 @@
--- a/numpy/core/include/numpy/npy_math.h
+++ b/numpy/core/include/numpy/npy_math.h
@@ -22,6 +22,21 @@
#define NPY_INPLACE
#endif
+#ifndef FE_UNDERFLOW
+#define FE_UNDERFLOW 0
+#endif
+
+#ifndef FE_OVERFLOW
+#define FE_OVERFLOW 0
+#endif
+
+#ifndef FE_DIVBYZERO
+#define FE_DIVBYZERO 0
+#endif
+
+#ifndef FE_INVALID
+#define FE_INVALID 0
+#endif
/*
* NAN and INFINITY like macros (same behavior as glibc for NAN, same as C99

View File

@ -12,7 +12,6 @@ PKG_HASH:=6a82e0c8bb2bf58f606040cc5814e07715b2094caeba281e2e7d0b0e2e397db5
PKG_BUILD_DIR:=$(BUILD_DIR)/protobuf-$(PKG_VERSION)
include $(INCLUDE_DIR)/package.mk
include $(TOPDIR)/feeds/packages/lang/python/python-package.mk
include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
define Package/python3-protobuf
@ -34,4 +33,4 @@ endef
$(eval $(call Py3Package,python3-protobuf))
$(eval $(call BuildPackage,python3-protobuf))
$(eval $(call BuildPackage,python3-protobuf-src))
#$(eval $(call BuildPackage,python3-protobuf-src))

View File

@ -12,7 +12,6 @@ PKG_HASH:=5c65d2da8c6bce0fca2528f69f44b2f977e06954c8512a952222cea50dad430f
PKG_BUILD_DIR:=$(BUILD_DIR)/websockets-$(PKG_VERSION)
include $(INCLUDE_DIR)/package.mk
include $(TOPDIR)/feeds/packages/lang/python/python-package.mk
include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
define Package/python3-websockets