mirror of https://github.com/hak5/openwrt.git
21 lines
567 B
Diff
21 lines
567 B
Diff
--- a/src/Makefile.am
|
|
+++ b/src/Makefile.am
|
|
@@ -81,6 +81,7 @@ MOSTLYCLEANFILES = yacc
|
|
|
|
yacc:
|
|
echo '#! /bin/sh' >$@
|
|
+ echo 'test -n "$$STAGING_DIR" && exec "$$STAGING_DIR/../host/bin/bison" -y "$$@"' >>$@
|
|
echo "exec '$(bindir)/bison' -y "'"$$@"' >>$@
|
|
chmod a+x $@
|
|
|
|
--- a/src/Makefile.in
|
|
+++ b/src/Makefile.in
|
|
@@ -1609,6 +1609,7 @@ uninstall-am: uninstall-binPROGRAMS unin
|
|
|
|
yacc:
|
|
echo '#! /bin/sh' >$@
|
|
+ echo 'test -n "$$STAGING_DIR" && exec "$$STAGING_DIR/../host/bin/bison" -y "$$@"' >>$@
|
|
echo "exec '$(bindir)/bison' -y "'"$$@"' >>$@
|
|
chmod a+x $@
|
|
|