mirror of https://github.com/hak5/openwrt.git
28 lines
848 B
Diff
28 lines
848 B
Diff
Index: linux-2.4.35.4/fs/squashfs/Makefile
|
|
===================================================================
|
|
--- linux-2.4.35.4.orig/fs/squashfs/Makefile
|
|
+++ linux-2.4.35.4/fs/squashfs/Makefile
|
|
@@ -4,7 +4,7 @@
|
|
|
|
O_TARGET := squashfs.o
|
|
|
|
-obj-y := inode.o squashfs2_0.o LzmaDecode.o
|
|
+obj-y := inode.o LzmaDecode.o
|
|
|
|
obj-m := $(O_TARGET)
|
|
|
|
Index: linux-2.4.35.4/fs/squashfs/squashfs.h
|
|
===================================================================
|
|
--- linux-2.4.35.4.orig/fs/squashfs/squashfs.h
|
|
+++ linux-2.4.35.4/fs/squashfs/squashfs.h
|
|
@@ -24,6 +24,9 @@
|
|
#ifdef CONFIG_SQUASHFS_1_0_COMPATIBILITY
|
|
#undef CONFIG_SQUASHFS_1_0_COMPATIBILITY
|
|
#endif
|
|
+#ifdef CONFIG_SQUASHFS_2_0_COMPATIBILITY
|
|
+#undef CONFIG_SQUASHFS_2_0_COMPATIBILITY
|
|
+#endif
|
|
#ifdef SQUASHFS_TRACE
|
|
#define TRACE(s, args...) printk(KERN_NOTICE "SQUASHFS: "s, ## args)
|
|
#else
|