mirror of https://github.com/hak5/openwrt.git
42 lines
1.1 KiB
Diff
42 lines
1.1 KiB
Diff
From 5128799df668a7ff5b2861fab39f9f788369eb43 Mon Sep 17 00:00:00 2001
|
|
From: John Crispin <blogic@openwrt.org>
|
|
Date: Wed, 13 Mar 2013 09:36:16 +0100
|
|
Subject: [PATCH 36/40] owrt: lantiq dtb image hack
|
|
|
|
---
|
|
arch/mips/lantiq/Makefile | 2 --
|
|
arch/mips/lantiq/prom.c | 4 +++-
|
|
2 files changed, 3 insertions(+), 3 deletions(-)
|
|
|
|
--- a/arch/mips/lantiq/Makefile
|
|
+++ b/arch/mips/lantiq/Makefile
|
|
@@ -6,8 +6,6 @@
|
|
|
|
obj-y := irq.o clk.o prom.o
|
|
|
|
-obj-y += dts/
|
|
-
|
|
obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
|
|
|
|
obj-$(CONFIG_SOC_TYPE_XWAY) += xway/
|
|
--- a/arch/mips/lantiq/prom.c
|
|
+++ b/arch/mips/lantiq/prom.c
|
|
@@ -57,6 +57,8 @@ static void __init prom_init_cmdline(voi
|
|
}
|
|
}
|
|
|
|
+extern struct boot_param_header __image_dtb;
|
|
+
|
|
void __init plat_mem_setup(void)
|
|
{
|
|
ioport_resource.start = IOPORT_RESOURCE_START;
|
|
@@ -70,7 +72,7 @@ void __init plat_mem_setup(void)
|
|
* Load the builtin devicetree. This causes the chosen node to be
|
|
* parsed resulting in our memory appearing
|
|
*/
|
|
- __dt_setup_arch(&__dtb_start);
|
|
+ __dt_setup_arch(&__image_dtb);
|
|
}
|
|
|
|
void __init device_tree_init(void)
|