mirror of https://github.com/hak5/openwrt.git
42 lines
1.6 KiB
Diff
42 lines
1.6 KiB
Diff
--- a/arch/mips/ath79/Kconfig
|
|
+++ b/arch/mips/ath79/Kconfig
|
|
@@ -70,6 +70,18 @@ config ATH79_MACH_AP121
|
|
Say 'Y' here if you want your kernel to support the
|
|
Atheros AP121 reference board.
|
|
|
|
+config ATH79_MACH_AP132
|
|
+ bool "Atheros AP132 reference board"
|
|
+ select SOC_QCA955X
|
|
+ select ATH79_DEV_GPIO_BUTTONS
|
|
+ select ATH79_DEV_LEDS_GPIO
|
|
+ select ATH79_DEV_SPI
|
|
+ select ATH79_DEV_USB
|
|
+ select ATH79_DEV_WMAC
|
|
+ help
|
|
+ Say 'Y' here if you want your kernel to support the
|
|
+ Atheros AP132 reference boards.
|
|
+
|
|
config ATH79_MACH_AP136
|
|
bool "Atheros AP136/AP135 reference board"
|
|
select SOC_QCA955X
|
|
--- a/arch/mips/ath79/machtypes.h
|
|
+++ b/arch/mips/ath79/machtypes.h
|
|
@@ -24,6 +24,7 @@ enum ath79_mach_type {
|
|
ATH79_MACH_AP113, /* Atheros AP113 reference board */
|
|
ATH79_MACH_AP121, /* Atheros AP121 reference board */
|
|
ATH79_MACH_AP121_MINI, /* Atheros AP121-MINI reference board */
|
|
+ ATH79_MACH_AP132, /* Atheros AP132 reference board */
|
|
ATH79_MACH_AP135_020, /* Atheros AP135-020 reference board */
|
|
ATH79_MACH_AP136_010, /* Atheros AP136-010 reference board */
|
|
ATH79_MACH_AP136_020, /* Atheros AP136-020 reference board */
|
|
--- a/arch/mips/ath79/Makefile
|
|
+++ b/arch/mips/ath79/Makefile
|
|
@@ -44,6 +44,7 @@ obj-$(CONFIG_ATH79_MACH_ALL0258N) += mac
|
|
obj-$(CONFIG_ATH79_MACH_ALL0315N) += mach-all0315n.o
|
|
obj-$(CONFIG_ATH79_MACH_AP113) += mach-ap113.o
|
|
obj-$(CONFIG_ATH79_MACH_AP121) += mach-ap121.o
|
|
+obj-$(CONFIG_ATH79_MACH_AP132) += mach-ap132.o
|
|
obj-$(CONFIG_ATH79_MACH_AP136) += mach-ap136.o
|
|
obj-$(CONFIG_ATH79_MACH_AP81) += mach-ap81.o
|
|
obj-$(CONFIG_ATH79_MACH_AP83) += mach-ap83.o
|