mirror of https://github.com/hak5/openwrt.git
26 lines
928 B
Diff
26 lines
928 B
Diff
--- a/drivers/gpio/Kconfig
|
|
+++ b/drivers/gpio/Kconfig
|
|
@@ -450,6 +450,12 @@ config GPIO_MC33880
|
|
SPI driver for Freescale MC33880 high-side/low-side switch.
|
|
This provides GPIO interface supporting inputs and outputs.
|
|
|
|
+config GPIO_MCS814X
|
|
+ tristate "Moschip MCS814x GPIO support"
|
|
+ depends on ARCH_MCS814X
|
|
+ help
|
|
+ GPIO driver for Moschip MCS814x SoC gpio controllers.
|
|
+
|
|
config GPIO_74X164
|
|
tristate "74x164 serial-in/parallel-out 8-bits shift register"
|
|
depends on SPI_MASTER
|
|
--- a/drivers/gpio/Makefile
|
|
+++ b/drivers/gpio/Makefile
|
|
@@ -26,6 +26,7 @@ obj-$(CONFIG_GPIO_MAX7300) += gpio-max73
|
|
obj-$(CONFIG_GPIO_MAX7301) += gpio-max7301.o
|
|
obj-$(CONFIG_GPIO_MAX732X) += gpio-max732x.o
|
|
obj-$(CONFIG_GPIO_MC33880) += gpio-mc33880.o
|
|
+obj-$(CONFIG_GPIO_MCS814X) += gpio-mcs814x.o
|
|
obj-$(CONFIG_GPIO_MCP23S08) += gpio-mcp23s08.o
|
|
obj-$(CONFIG_GPIO_ML_IOH) += gpio-ml-ioh.o
|
|
obj-$(CONFIG_GPIO_MPC5200) += gpio-mpc5200.o
|