mirror of https://github.com/hak5/openwrt.git
24 lines
667 B
Diff
24 lines
667 B
Diff
--- a/drivers/net/Kconfig
|
|
+++ b/drivers/net/Kconfig
|
|
@@ -606,6 +606,10 @@
|
|
If you have an Alchemy Semi AU1X00 based system
|
|
say Y. Otherwise, say N.
|
|
|
|
+config MIPS_ADM5120_ENET
|
|
+ tristate "MIPS ADM5120 Ethernet switch support"
|
|
+ depends on MIPS_ADM5120
|
|
+
|
|
config SGI_IOC3_ETH
|
|
bool "SGI IOC3 Ethernet"
|
|
depends on PCI && SGI_IP27
|
|
--- a/drivers/net/Makefile
|
|
+++ b/drivers/net/Makefile
|
|
@@ -187,6 +187,7 @@
|
|
# This is also a 82596 and should probably be merged
|
|
obj-$(CONFIG_LP486E) += lp486e.o
|
|
|
|
+obj-$(CONFIG_MIPS_ADM5120_ENET) += adm5120sw.o
|
|
obj-$(CONFIG_ETH16I) += eth16i.o
|
|
obj-$(CONFIG_ZORRO8390) += zorro8390.o
|
|
obj-$(CONFIG_HPLANCE) += hplance.o 7990.o
|