mirror of https://github.com/hak5/openwrt.git
26 lines
871 B
Diff
26 lines
871 B
Diff
--- a/drivers/spi/Kconfig
|
|
+++ b/drivers/spi/Kconfig
|
|
@@ -288,6 +288,12 @@ config SPI_PXA2XX
|
|
config SPI_PXA2XX_PCI
|
|
def_bool SPI_PXA2XX && X86_32 && PCI
|
|
|
|
+config SPI_RB4XX
|
|
+ tristate "Mikrotik RB4XX SPI master"
|
|
+ depends on SPI_MASTER && ATH79_MACH_RB4XX
|
|
+ help
|
|
+ SPI controller driver for the Mikrotik RB4xx series boards.
|
|
+
|
|
config SPI_S3C24XX
|
|
tristate "Samsung S3C24XX series SPI"
|
|
depends on ARCH_S3C2410 && EXPERIMENTAL
|
|
--- a/drivers/spi/Makefile
|
|
+++ b/drivers/spi/Makefile
|
|
@@ -45,6 +45,7 @@ obj-$(CONFIG_SPI_PL022) += spi-pl022.o
|
|
obj-$(CONFIG_SPI_PPC4xx) += spi-ppc4xx.o
|
|
obj-$(CONFIG_SPI_PXA2XX) += spi-pxa2xx.o
|
|
obj-$(CONFIG_SPI_PXA2XX_PCI) += spi-pxa2xx-pci.o
|
|
+obj-$(CONFIG_SPI_RB4XX) += spi-rb4xx.o
|
|
obj-$(CONFIG_SPI_S3C24XX) += spi-s3c24xx-hw.o
|
|
spi-s3c24xx-hw-y := spi-s3c24xx.o
|
|
spi-s3c24xx-hw-$(CONFIG_SPI_S3C24XX_FIQ) += spi-s3c24xx-fiq.o
|