mirror of https://github.com/hak5/openwrt.git
35 lines
1.1 KiB
Diff
35 lines
1.1 KiB
Diff
--- a/drivers/mtd/Kconfig
|
|
+++ b/drivers/mtd/Kconfig
|
|
@@ -158,7 +158,7 @@ config MTD_BCM63XX_PARTS
|
|
|
|
config MTD_WRT160NL_PARTS
|
|
tristate "Linksys WRT160NL partitioning support"
|
|
- depends on MTD_PARTITIONS && ATH79_MACH_WRT160NL
|
|
+ depends on ATH79_MACH_WRT160NL
|
|
---help---
|
|
Linksys WRT160NL partitioning support
|
|
|
|
@@ -178,6 +178,12 @@ config MTD_MYLOADER_PARTS
|
|
You will still need the parsing functions to be called by the driver
|
|
for your particular device. It won't happen automatically.
|
|
|
|
+config MTD_TPLINK_PARTS
|
|
+ tristate "TP-Link AR7XXX/AR9XXX partitioning support"
|
|
+ depends on ATH79
|
|
+ ---help---
|
|
+ TBD.
|
|
+
|
|
comment "User Modules And Translation Layers"
|
|
|
|
config MTD_CHAR
|
|
--- a/drivers/mtd/Makefile
|
|
+++ b/drivers/mtd/Makefile
|
|
@@ -13,6 +13,7 @@ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
|
|
obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
|
|
obj-$(CONFIG_MTD_BCM63XX_PARTS) += bcm63xxpart.o
|
|
obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
|
|
+obj-$(CONFIG_MTD_TPLINK_PARTS) += tplinkpart.o
|
|
obj-$(CONFIG_MTD_WRT160NL_PARTS) += wrt160nl_part.o
|
|
|
|
# 'Users' - code which presents functionality to userspace.
|