mirror of https://github.com/hak5/openwrt.git
28 lines
706 B
Diff
28 lines
706 B
Diff
--- a/drivers/net/wireless/ath/Makefile
|
|
+++ b/drivers/net/wireless/ath/Makefile
|
|
@@ -8,6 +8,5 @@ obj-$(CONFIG_ATH_COMMON) += ath.o
|
|
ath-objs := main.o \
|
|
regd.o \
|
|
hw.o \
|
|
- key.o
|
|
-
|
|
-ath-$(CONFIG_ATH_DEBUG) += debug.o
|
|
+ key.o \
|
|
+ debug.o
|
|
--- a/drivers/net/wireless/ath/ath.h
|
|
+++ b/drivers/net/wireless/ath/ath.h
|
|
@@ -272,13 +272,6 @@ void ath_dbg(struct ath_common *common,
|
|
#endif /* CONFIG_ATH_DEBUG */
|
|
|
|
/** Returns string describing opmode, or NULL if unknown mode. */
|
|
-#ifdef CONFIG_ATH_DEBUG
|
|
const char *ath_opmode_to_string(enum nl80211_iftype opmode);
|
|
-#else
|
|
-static inline const char *ath_opmode_to_string(enum nl80211_iftype opmode)
|
|
-{
|
|
- return "UNKNOWN";
|
|
-}
|
|
-#endif
|
|
|
|
#endif /* ATH_H */
|