mirror of https://github.com/hak5/openwrt.git
22 lines
761 B
Diff
22 lines
761 B
Diff
--- a/drivers/leds/Kconfig
|
|
+++ b/drivers/leds/Kconfig
|
|
@@ -450,4 +450,11 @@ config LEDS_TRIGGER_NETDEV
|
|
This allows LEDs to be controlled by network device activity.
|
|
If unsure, say Y.
|
|
|
|
+config LEDS_TRIGGER_USBDEV
|
|
+ tristate "LED USB device Trigger"
|
|
+ depends on USB && LEDS_TRIGGERS
|
|
+ help
|
|
+ This allows LEDs to be controlled by the presence/activity of
|
|
+ an USB device. If unsure, say N.
|
|
+
|
|
endif # NEW_LEDS
|
|
--- a/drivers/leds/Makefile
|
|
+++ b/drivers/leds/Makefile
|
|
@@ -54,3 +54,4 @@ obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledt
|
|
obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
|
|
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
|
|
obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
|
|
+obj-$(CONFIG_LEDS_TRIGGER_USBDEV) += ledtrig-usbdev.o
|