mirror of https://github.com/hak5/openwrt.git
87 lines
2.2 KiB
Diff
87 lines
2.2 KiB
Diff
From 467e9cb87261c27b6c70ec714ae3cb58b48d0f6b Mon Sep 17 00:00:00 2001
|
|
From: Eric Anholt <eric@anholt.net>
|
|
Date: Fri, 9 Mar 2018 13:20:21 -0800
|
|
Subject: [PATCH] overlays: Add an overlay for the Adafruit Kippah with
|
|
their 7" panel
|
|
|
|
Signed-off-by: Eric Anholt <eric@anholt.net>
|
|
---
|
|
arch/arm/boot/dts/overlays/Makefile | 1 +
|
|
arch/arm/boot/dts/overlays/README | 7 +++
|
|
.../overlays/vc4-kms-kippah-7inch-overlay.dts | 43 +++++++++++++++++++
|
|
3 files changed, 51 insertions(+)
|
|
create mode 100644 arch/arm/boot/dts/overlays/vc4-kms-kippah-7inch-overlay.dts
|
|
|
|
--- a/arch/arm/boot/dts/overlays/Makefile
|
|
+++ b/arch/arm/boot/dts/overlays/Makefile
|
|
@@ -134,6 +134,7 @@ dtbo-$(CONFIG_ARCH_BCM2835) += \
|
|
upstream.dtbo \
|
|
upstream-aux-interrupt.dtbo \
|
|
vc4-fkms-v3d.dtbo \
|
|
+ vc4-kms-kippah-7inch.dtbo \
|
|
vc4-kms-v3d.dtbo \
|
|
vga666.dtbo \
|
|
w1-gpio.dtbo \
|
|
--- a/arch/arm/boot/dts/overlays/README
|
|
+++ b/arch/arm/boot/dts/overlays/README
|
|
@@ -1920,6 +1920,13 @@ Params: cma-256 CMA is 2
|
|
cma-64 CMA is 64MB, 64MB-aligned
|
|
|
|
|
|
+Name: vc4-kms-kippah-7inch
|
|
+Info: Enable the Adafruit DPI Kippah with the 7" Ontat panel attached.
|
|
+ Requires vc4-kms-v3d to be loaded.
|
|
+Load: dtoverlay=vc4-kms-kippah-7inch
|
|
+Params: <None>
|
|
+
|
|
+
|
|
Name: vc4-kms-v3d
|
|
Info: Enable Eric Anholt's DRM VC4 HDMI/HVS/V3D driver. Running startx or
|
|
booting to GUI while this overlay is in use will cause interesting
|
|
--- /dev/null
|
|
+++ b/arch/arm/boot/dts/overlays/vc4-kms-kippah-7inch-overlay.dts
|
|
@@ -0,0 +1,43 @@
|
|
+/*
|
|
+ * vc4-kms-v3d-overlay.dts
|
|
+ */
|
|
+
|
|
+/dts-v1/;
|
|
+/plugin/;
|
|
+
|
|
+#include <dt-bindings/pinctrl/bcm2835.h>
|
|
+
|
|
+/ {
|
|
+ compatible = "brcm,bcm2835", "brcm,bcm2708", "brcm,bcm2709";
|
|
+
|
|
+ fragment@0 {
|
|
+ target-path = "/";
|
|
+ __overlay__ {
|
|
+ panel: panel {
|
|
+ compatible = "ontat,yx700wv03", "simple-panel";
|
|
+
|
|
+ port {
|
|
+ panel_in: endpoint {
|
|
+ remote-endpoint = <&dpi_out>;
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+
|
|
+ fragment@1 {
|
|
+ target = <&dpi>;
|
|
+ __overlay__ {
|
|
+ status = "okay";
|
|
+
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&dpi_18bit_gpio0>;
|
|
+
|
|
+ port {
|
|
+ dpi_out: endpoint@0 {
|
|
+ remote-endpoint = <&panel_in>;
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+};
|