mirror of https://github.com/hak5/openwrt.git
46 lines
1.4 KiB
Diff
46 lines
1.4 KiB
Diff
From 4efa3f8f53d8249905a1c9216a0fe5473d5df5c4 Mon Sep 17 00:00:00 2001
|
|
From: Lars-Peter Clausen <lars@metafoo.de>
|
|
Date: Tue, 21 Jul 2009 12:45:26 +0200
|
|
Subject: [PATCH] 054-bq27000.patch
|
|
|
|
---
|
|
drivers/power/Kconfig | 12 ++++++++++++
|
|
drivers/power/Makefile | 3 +++
|
|
2 files changed, 15 insertions(+), 0 deletions(-)
|
|
|
|
diff --git a/drivers/power/Kconfig b/drivers/power/Kconfig
|
|
index 7eda348..3661595 100644
|
|
--- a/drivers/power/Kconfig
|
|
+++ b/drivers/power/Kconfig
|
|
@@ -96,4 +96,16 @@ config CHARGER_PCF50633
|
|
help
|
|
Say Y to include support for NXP PCF50633 Main Battery Charger.
|
|
|
|
+config BATTERY_BQ27000_HDQ
|
|
+ tristate "BQ27000 HDQ battery monitor driver"
|
|
+ help
|
|
+ Say Y to enable support for the battery on the Neo Freerunner
|
|
+
|
|
+config HDQ_GPIO_BITBANG
|
|
+ bool "Generic gpio based HDQ bitbang"
|
|
+ help
|
|
+ Say Y to enable supoort for generic gpio based HDQ bitbang driver.
|
|
+ This can not be built as a module.
|
|
+
|
|
endif # POWER_SUPPLY
|
|
+
|
|
diff --git a/drivers/power/Makefile b/drivers/power/Makefile
|
|
index daf3179..e277a05 100644
|
|
--- a/drivers/power/Makefile
|
|
+++ b/drivers/power/Makefile
|
|
@@ -27,3 +27,6 @@ obj-$(CONFIG_BATTERY_BQ27x00) += bq27x00_battery.o
|
|
obj-$(CONFIG_BATTERY_DA9030) += da9030_battery.o
|
|
obj-$(CONFIG_BATTERY_MAX17040) += max17040_battery.o
|
|
obj-$(CONFIG_CHARGER_PCF50633) += pcf50633-charger.o
|
|
+obj-$(CONFIG_BATTERY_BQ27000_HDQ) += bq27000_battery.o
|
|
+
|
|
+obj-$(CONFIG_HDQ_GPIO_BITBANG) += hdq.o
|
|
--
|
|
1.5.6.5
|
|
|