mirror of https://github.com/hak5/openwrt.git
31 lines
1.1 KiB
Diff
31 lines
1.1 KiB
Diff
--- a/drivers/input/misc/Kconfig
|
|
+++ b/drivers/input/misc/Kconfig
|
|
@@ -207,4 +207,20 @@ config HP_SDC_RTC
|
|
Say Y here if you want to support the built-in real time clock
|
|
of the HP SDC controller.
|
|
|
|
+config INPUT_GPIO_BUTTONS
|
|
+ tristate "Polled GPIO buttons interface"
|
|
+ depends on GENERIC_GPIO
|
|
+ select INPUT_POLLDEV
|
|
+ help
|
|
+ This driver implements support for buttons connected
|
|
+ to GPIO pins of various CPUs (and some other chips).
|
|
+
|
|
+ Say Y here if your device has buttons connected
|
|
+ directly to such GPIO pins. Your board-specific
|
|
+ setup logic must also provide a platform device,
|
|
+ with configuration data saying which GPIOs are used.
|
|
+
|
|
+ To compile this driver as a module, choose M here: the
|
|
+ module will be called gpio-buttons.
|
|
+
|
|
endif
|
|
--- a/drivers/input/misc/Makefile
|
|
+++ b/drivers/input/misc/Makefile
|
|
@@ -20,3 +20,4 @@ obj-$(CONFIG_HP_SDC_RTC) += hp_sdc_rtc.
|
|
obj-$(CONFIG_INPUT_UINPUT) += uinput.o
|
|
obj-$(CONFIG_INPUT_APANEL) += apanel.o
|
|
obj-$(CONFIG_INPUT_SGI_BTNS) += sgi_btns.o
|
|
+obj-$(CONFIG_INPUT_GPIO_BUTTONS) += gpio_buttons.o
|