mirror of https://github.com/hak5/openwrt.git
54 lines
1.8 KiB
Diff
54 lines
1.8 KiB
Diff
Index: linux-2.6.22-rc6/drivers/ide/ide.c
|
|
===================================================================
|
|
--- linux-2.6.22-rc6.orig/drivers/ide/ide.c 2007-06-28 08:23:49.463514496 +0200
|
|
+++ linux-2.6.22-rc6/drivers/ide/ide.c 2007-06-28 08:23:54.658724704 +0200
|
|
@@ -1604,6 +1604,7 @@
|
|
extern void __init pnpide_init(void);
|
|
extern void __exit pnpide_exit(void);
|
|
extern void __init h8300_ide_init(void);
|
|
+extern void __init ide_magicbox_init(void);
|
|
|
|
/*
|
|
* probe_for_hwifs() finds/initializes "known" IDE interfaces
|
|
@@ -1668,6 +1669,9 @@
|
|
#ifdef CONFIG_H8300
|
|
h8300_ide_init();
|
|
#endif
|
|
+#ifdef CONFIG_BLK_DEV_MAGICBOX_IDE
|
|
+ ide_magicbox_init();
|
|
+#endif
|
|
}
|
|
|
|
/*
|
|
Index: linux-2.6.22-rc6/drivers/ide/Kconfig
|
|
===================================================================
|
|
--- linux-2.6.22-rc6.orig/drivers/ide/Kconfig 2007-06-28 08:23:49.470513432 +0200
|
|
+++ linux-2.6.22-rc6/drivers/ide/Kconfig 2007-06-28 08:23:54.658724704 +0200
|
|
@@ -946,6 +946,14 @@
|
|
|
|
If unsure, say N.
|
|
|
|
+config BLK_DEV_MAGICBOX_IDE
|
|
+ bool "MagicBox 2.0 CF IDE support"
|
|
+ depends on 4xx && IDE
|
|
+ help
|
|
+ This option provides support for IDE on MagicBox 2.0 boards.
|
|
+
|
|
+ If unsure, say N.
|
|
+
|
|
choice
|
|
prompt "Type of MPC8xx IDE interface"
|
|
depends on BLK_DEV_MPC8xx_IDE
|
|
Index: linux-2.6.22-rc6/drivers/ide/Makefile
|
|
===================================================================
|
|
--- linux-2.6.22-rc6.orig/drivers/ide/Makefile 2007-06-28 08:23:49.478512216 +0200
|
|
+++ linux-2.6.22-rc6/drivers/ide/Makefile 2007-06-28 08:23:54.659724552 +0200
|
|
@@ -37,6 +37,7 @@
|
|
# built-in only drivers from ppc/
|
|
ide-core-$(CONFIG_BLK_DEV_MPC8xx_IDE) += ppc/mpc8xx.o
|
|
ide-core-$(CONFIG_BLK_DEV_IDE_PMAC) += ppc/pmac.o
|
|
+ide-core-$(CONFIG_BLK_DEV_MAGICBOX_IDE) += ppc/magicbox_ide.o
|
|
|
|
# built-in only drivers from h8300/
|
|
ide-core-$(CONFIG_H8300) += h8300/ide-h8300.o
|