mirror of https://github.com/hak5/openwrt.git
124 lines
3.6 KiB
Diff
124 lines
3.6 KiB
Diff
From 00fefa81d4919c72470ad68f05bc9e239108ca1b Mon Sep 17 00:00:00 2001
|
|
From: Maxime Bizon <mbizon@freebox.fr>
|
|
Date: Tue, 24 May 2011 21:50:33 +0200
|
|
Subject: [PATCH 23/57] MIPS: BCM63XX: register ehci device.
|
|
|
|
---
|
|
arch/mips/bcm63xx/Kconfig | 2 +
|
|
arch/mips/bcm63xx/Makefile | 2 +-
|
|
arch/mips/bcm63xx/boards/board_bcm963xx.c | 4 ++
|
|
arch/mips/bcm63xx/dev-usb-ehci.c | 50 ++++++++++++++++++++
|
|
.../asm/mach-bcm63xx/bcm63xx_dev_usb_ehci.h | 6 ++
|
|
5 files changed, 63 insertions(+), 1 deletions(-)
|
|
create mode 100644 arch/mips/bcm63xx/dev-usb-ehci.c
|
|
create mode 100644 arch/mips/include/asm/mach-bcm63xx/bcm63xx_dev_usb_ehci.h
|
|
|
|
--- a/arch/mips/bcm63xx/Kconfig
|
|
+++ b/arch/mips/bcm63xx/Kconfig
|
|
@@ -18,11 +18,13 @@ config BCM63XX_CPU_6358
|
|
bool "support 6358 CPU"
|
|
select HW_HAS_PCI
|
|
select USB_ARCH_HAS_OHCI if USB_SUPPORT
|
|
+ select USB_ARCH_HAS_EHCI if USB_SUPPORT
|
|
|
|
config BCM63XX_CPU_6368
|
|
bool "support 6368 CPU"
|
|
select HW_HAS_PCI
|
|
select USB_ARCH_HAS_OHCI if USB_SUPPORT
|
|
+ select USB_ARCH_HAS_EHCI if USB_SUPPORT
|
|
endmenu
|
|
|
|
source "arch/mips/bcm63xx/boards/Kconfig"
|
|
--- a/arch/mips/bcm63xx/Makefile
|
|
+++ b/arch/mips/bcm63xx/Makefile
|
|
@@ -1,6 +1,6 @@
|
|
obj-y += clk.o cpu.o cs.o gpio.o irq.o prom.o setup.o timer.o \
|
|
dev-dsp.o dev-enet.o dev-pcmcia.o dev-uart.o \
|
|
- dev-usb-ohci.o dev-wdt.o
|
|
+ dev-usb-ehci.o dev-usb-ohci.o dev-wdt.o
|
|
obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
|
|
|
|
obj-y += boards/
|
|
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
|
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
|
@@ -26,6 +26,7 @@
|
|
#include <bcm63xx_dev_dsp.h>
|
|
#include <bcm63xx_dev_pcmcia.h>
|
|
#include <bcm63xx_dev_usb_ohci.h>
|
|
+#include <bcm63xx_dev_usb_ehci.h>
|
|
#include <board_bcm963xx.h>
|
|
|
|
#define PFX "board_bcm963xx: "
|
|
@@ -875,6 +876,9 @@ int __init board_register_devices(void)
|
|
!board_get_mac_address(board.enet1.mac_addr))
|
|
bcm63xx_enet_register(1, &board.enet1);
|
|
|
|
+ if (board.has_ehci0)
|
|
+ bcm63xx_ehci_register();
|
|
+
|
|
if (board.has_ohci0)
|
|
bcm63xx_ohci_register();
|
|
|
|
--- /dev/null
|
|
+++ b/arch/mips/bcm63xx/dev-usb-ehci.c
|
|
@@ -0,0 +1,50 @@
|
|
+/*
|
|
+ * This file is subject to the terms and conditions of the GNU General Public
|
|
+ * License. See the file "COPYING" in the main directory of this archive
|
|
+ * for more details.
|
|
+ *
|
|
+ * Copyright (C) 2008 Maxime Bizon <mbizon@freebox.fr>
|
|
+ */
|
|
+
|
|
+#include <linux/init.h>
|
|
+#include <linux/kernel.h>
|
|
+#include <linux/platform_device.h>
|
|
+#include <bcm63xx_cpu.h>
|
|
+#include <bcm63xx_dev_usb_ehci.h>
|
|
+
|
|
+static struct resource ehci_resources[] = {
|
|
+ {
|
|
+ .start = -1, /* filled at runtime */
|
|
+ .end = -1, /* filled at runtime */
|
|
+ .flags = IORESOURCE_MEM,
|
|
+ },
|
|
+ {
|
|
+ .start = -1, /* filled at runtime */
|
|
+ .flags = IORESOURCE_IRQ,
|
|
+ },
|
|
+};
|
|
+
|
|
+static u64 ehci_dmamask = ~(u32)0;
|
|
+
|
|
+static struct platform_device bcm63xx_ehci_device = {
|
|
+ .name = "bcm63xx_ehci",
|
|
+ .id = 0,
|
|
+ .num_resources = ARRAY_SIZE(ehci_resources),
|
|
+ .resource = ehci_resources,
|
|
+ .dev = {
|
|
+ .dma_mask = &ehci_dmamask,
|
|
+ .coherent_dma_mask = 0xffffffff,
|
|
+ },
|
|
+};
|
|
+
|
|
+int __init bcm63xx_ehci_register(void)
|
|
+{
|
|
+ if (!BCMCPU_IS_6358() && !BCMCPU_IS_6368())
|
|
+ return 0;
|
|
+
|
|
+ ehci_resources[0].start = bcm63xx_regset_address(RSET_EHCI0);
|
|
+ ehci_resources[0].end = ehci_resources[0].start;
|
|
+ ehci_resources[0].end += RSET_EHCI_SIZE - 1;
|
|
+ ehci_resources[1].start = bcm63xx_get_irq_number(IRQ_EHCI0);
|
|
+ return platform_device_register(&bcm63xx_ehci_device);
|
|
+}
|
|
--- /dev/null
|
|
+++ b/arch/mips/include/asm/mach-bcm63xx/bcm63xx_dev_usb_ehci.h
|
|
@@ -0,0 +1,6 @@
|
|
+#ifndef BCM63XX_DEV_USB_EHCI_H_
|
|
+#define BCM63XX_DEV_USB_EHCI_H_
|
|
+
|
|
+int bcm63xx_ehci_register(void);
|
|
+
|
|
+#endif /* BCM63XX_DEV_USB_EHCI_H_ */
|