mirror of https://github.com/hak5/openwrt.git
26 lines
856 B
Diff
26 lines
856 B
Diff
--- a/drivers/gpio/Kconfig
|
|
+++ b/drivers/gpio/Kconfig
|
|
@@ -401,4 +401,12 @@ config GPIO_JANZ_TTL
|
|
This driver provides support for driving the pins in output
|
|
mode only. Input mode is not supported.
|
|
|
|
+comment "Other GPIO expanders"
|
|
+
|
|
+config GPIO_NXP_74HC153
|
|
+ tristate "NXP 74HC153 Dual 4-input multiplexer"
|
|
+ help
|
|
+ Platform driver for NXP 74HC153 Dual 4-input Multiplexer. This
|
|
+ provides a GPIO interface supporting inputs.
|
|
+
|
|
endif
|
|
--- a/drivers/gpio/Makefile
|
|
+++ b/drivers/gpio/Makefile
|
|
@@ -18,6 +18,7 @@ obj-$(CONFIG_GPIO_MAX7301) += max7301.o
|
|
obj-$(CONFIG_GPIO_MAX732X) += max732x.o
|
|
obj-$(CONFIG_GPIO_MC33880) += mc33880.o
|
|
obj-$(CONFIG_GPIO_MCP23S08) += mcp23s08.o
|
|
+obj-$(CONFIG_GPIO_NXP_74HC153) += nxp_74hc153.o
|
|
obj-$(CONFIG_GPIO_74X164) += 74x164.o
|
|
obj-$(CONFIG_GPIO_PCA953X) += pca953x.o
|
|
obj-$(CONFIG_GPIO_PCF857X) += pcf857x.o
|