mirror of https://github.com/hak5/openwrt.git
20 lines
426 B
Diff
20 lines
426 B
Diff
|
|
Use values exported from $(TOPDIR)/rules.mk for determining
|
|
the target system instead of the host configuration
|
|
|
|
--- a/configure
|
|
+++ b/configure
|
|
@@ -8,9 +8,9 @@ SYSCONF=/etc
|
|
# if [ -d /NextApps ]; then
|
|
# system="NeXTStep"
|
|
# else
|
|
- system=`uname -s`
|
|
- release=`uname -r`
|
|
- arch=`uname -m`
|
|
+ system=${UNAME_S:-`uname -s`}
|
|
+ release=${UNAME_R:-`uname -r`}
|
|
+ arch=${UNAME_M:-`uname -m`}
|
|
# fi
|
|
state="unknown"
|
|
|